Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » 'Updating Software' has encountered a problem.(Just tried to do an update and got a bunch of errors.)
'Updating Software' has encountered a problem. [message #1760076] Fri, 21 April 2017 20:46 Go to next message
Chuck Pergiel is currently offline Chuck PergielFriend
Messages: 25
Registered: April 2016
Location: Silicon Forest
Junior Member
This is what the update box showed.

'Updating Software' has encountered a problem.

An error occurred while collecting iterms to be installed

When I asked for details it gave me a list of a zillion lines like this:
An error occurred while collecting items to be installed
session context was:(profile=_home_c_eclipse_cpp-neon_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.eclipse.cdt,9.2.1.201704050430
No repository found containing: osgi.bundle,org.eclipse.cdt.autotools.core,2.0.0.201704050430
No repository found containing: osgi.bundle,org.eclipse.cdt.autotools.docs,2.0.2.201704050430
. . .


Sent from my Commodore-64 via a US Robotics 300 Baud Modem
Re: 'Updating Software' has encountered a problem. [message #1760086 is a reply to message #1760076] Sat, 22 April 2017 06:39 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30453
Registered: July 2009
Senior Member
There could have been a network failure.
Re: 'Updating Software' has encountered a problem. [message #1760097 is a reply to message #1760086] Sat, 22 April 2017 13:37 Go to previous messageGo to next message
Chuck Pergiel is currently offline Chuck PergielFriend
Messages: 25
Registered: April 2016
Location: Silicon Forest
Junior Member
If there was a network failure, it's not on my end. I just ran an update on Linux and it worked fine. Then I tried to update Eclipse again and I got the same error as before.

Sent from my Commodore-64 via a US Robotics 300 Baud Modem
Re: 'Updating Software' has encountered a problem. [message #1760133 is a reply to message #1760097] Sun, 23 April 2017 15:41 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30453
Registered: July 2009
Senior Member
Maybe there are more clues in the Error Log?
Re: 'Updating Software' has encountered a problem. [message #1760135 is a reply to message #1760133] Sun, 23 April 2017 16:05 Go to previous messageGo to next message
Chuck Pergiel is currently offline Chuck PergielFriend
Messages: 25
Registered: April 2016
Location: Silicon Forest
Junior Member
Error Log? Where is the Error Log?

Sent from my Commodore-64 via a US Robotics 300 Baud Modem
Re: 'Updating Software' has encountered a problem. [message #1760137 is a reply to message #1760135] Sun, 23 April 2017 16:09 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30453
Registered: July 2009
Senior Member
Type Error Log in the Quick Access to open the Error Log view.
Re: 'Updating Software' has encountered a problem. [message #1760138 is a reply to message #1760137] Sun, 23 April 2017 16:29 Go to previous messageGo to next message
Chuck Pergiel is currently offline Chuck PergielFriend
Messages: 25
Registered: April 2016
Location: Silicon Forest
Junior Member
Most of today's entries in the Error Log are the same as above. I did find these four items from Friday at 2:30PM, which was like 9 hours before I tried to do the update.

Unknown Host: http://download.eclipse.org/oomph/updates/milestone/latest/compositeContent.xml
Unknown Host: http://download.eclipse.org/tools/cdt/releases/9.2/compositeContent.xml
Unknown Host: http://download.eclipse.org/eclipse/updates/4.6/compositeContent.xml
Unknown Host: http://download.eclipse.org/releases/neon/compositeContent.xml

The event details for all four of these are identical, except for the URL.

eclipse.buildId=4.6.3.M20170301-0400
java.version=1.8.0_121
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Framework arguments: -product org.eclipse.epp.package.cpp.product
Command-line arguments: -os linux -ws gtk -arch x86_64 -product org.eclipse.epp.package.cpp.product

org.eclipse.equinox.p2.transport.ecf
Error
Fri Apr 21 14:29:07 PDT 2017
Unknown Host: http://download.eclipse.org/oomph/updates/milestone/latest/compositeContent.xml

java.net.UnknownHostException: download.eclipse.org
at java.net.InetAddress.getAllByName0(InetAddress.java:1280)
at java.net.InetAddress.getAllByName(InetAddress.java:1192)
at java.net.InetAddress.getAllByName(InetAddress.java:1126)
at org.apache.http.impl.conn.SystemDefaultDnsResolver.resolve(SystemDefaultDnsResolver.java:44)
at org.apache.http.impl.conn.DefaultClientConnectionOperator.resolveHostname(DefaultClientConnectionOperator.java:259)
at org.apache.http.impl.conn.DefaultClientConnectionOperator.openConnection(DefaultClientConnectionOperator.java:159)
at org.apache.http.impl.conn.ManagedClientConnectionImpl.open(ManagedClientConnectionImpl.java:304)
at org.apache.http.impl.client.DefaultRequestDirector.tryConnect(DefaultRequestDirector.java:611)
at org.apache.http.impl.client.DefaultRequestDirector.execute(DefaultRequestDirector.java:446)
at org.apache.http.impl.client.AbstractHttpClient.doExecute(AbstractHttpClient.java:863)
at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:82)
at org.eclipse.ecf.provider.filetransfer.httpclient4.HttpClientFileSystemBrowser.runRequest(HttpClientFileSystemBrowser.java:263)
at org.eclipse.ecf.provider.filetransfer.browse.AbstractFileSystemBrowser$DirectoryJob.run(AbstractFileSystemBrowser.java:69)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)


Sent from my Commodore-64 via a US Robotics 300 Baud Modem
Re: 'Updating Software' has encountered a problem. [message #1760157 is a reply to message #1760138] Mon, 24 April 2017 06:11 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30453
Registered: July 2009
Senior Member
These logs entries suggest network problems, at least at that point in time. You could clear the log, try again, and see what's all in the log. I'm not sure what else to suggest. Perhaps there is some inconsistency in CDT's update sites. You might try using Windows -> Preferences -> Install/Update -> Available Software Sites and disabling the CDT one; CDT should be in the Neon repository anyway.
Re: 'Updating Software' has encountered a problem. [message #1760182 is a reply to message #1760157] Mon, 24 April 2017 11:37 Go to previous messageGo to next message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 495
Registered: August 2014
Senior Member
There might be something fishy in the links or Eclipse repository.
When used as browser URL's, only the CDT link got a XML page, the other three gave the Eclipse project 'Not found' page.



--

Tauno Voipio
Re: 'Updating Software' has encountered a problem. [message #1806532 is a reply to message #1760182] Fri, 10 May 2019 08:48 Go to previous messageGo to next message
Wojciech Lisik is currently offline Wojciech LisikFriend
Messages: 2
Registered: May 2019
Junior Member
I strongly suggest closing down Eclipse as this bug (its a BUG) is still relevant 2 years on.....
It clearly shows that developers give a middle finger to it. Either because they don't have a clue what's going on, or they don't care....
Re: 'Updating Software' has encountered a problem. [message #1806570 is a reply to message #1806532] Fri, 10 May 2019 13:36 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3503
Registered: July 2009
Senior Member

Is it? You've reopened a two year old thread about an outdated release without adding any other information.

Nitin Dahyabhai
Eclipse Web Tools Platform
Previous Topic:Java Exit Code - 1
Next Topic:Where is the correct place to add a trusted certificate on Linux?
Goto Forum:
  


Current Time: Fri Sep 20 16:16:19 GMT 2019

Powered by FUDForum. Page generated in 0.03805 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top