Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » HTML Tags in PHP Files(Matching Tags Dead)
HTML Tags in PHP Files [message #1759686] Sat, 15 April 2017 14:02 Go to next message
Dan Allen is currently offline Dan AllenFriend
Messages: 14
Registered: April 2017
Junior Member
This is an undocumented problem with highlighting matching html tags not working, as shown these pictures.

This picture shows the objective, and it is working awesome, just not in Eclipse, unfortunately.
index.php/fa/29056/0/

The picture shows the failure mode in Eclipse. Basically, the tags are not highlighting in a visible manner. I cannot complain about the price of Eclipse, but this fail is a problem nonetheless. I don't use it every day, but when I do, it is because it is extremely handy.
index.php/fa/29057/0/

I have read 30 times today, the way to get this working is to enable it through Preferences->General->Editors->Text Editors-> annotations->matching tags This picture shows that preference set, but having no effect.
index.php/fa/29058/0/

If you have any tips I would really appreciate them. Thank you.
  • Attachment: aptana.png
    (Size: 261.50KB, Downloaded 434 times)
  • Attachment: e1.png
    (Size: 233.08KB, Downloaded 362 times)
  • Attachment: e2.png
    (Size: 210.79KB, Downloaded 364 times)
Re: HTML Tags in PHP Files [message #1759798 is a reply to message #1759686] Tue, 18 April 2017 06:42 Go to previous messageGo to next message
Kaloyan Raev is currently offline Kaloyan RaevFriend
Messages: 201
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Matching tags in HTML files works for me out-of-the-box with the Eclipse PHP Neon.3 package.

Could you attach the actual file (not as image), so I can try with it and see if it makes a difference.
Re: HTML Tags in PHP Files [message #1759913 is a reply to message #1759798] Wed, 19 April 2017 20:45 Go to previous messageGo to next message
Dan Allen is currently offline Dan AllenFriend
Messages: 14
Registered: April 2017
Junior Member
Kaloyan, Thank you for responding and assisting with my problem.

The php file containing html is attached.

It just dawned on me, I should have mentioned I am using Remote System Explorer and do not have this setup as a project. I am using Remote System Explorer to connect to a remote linux installation. The network connection is very high speed, so I do not have a local directory or project, just the remote file system accessed with either FTP or SSH in RSE. In other words, the problem might be tied to the RSE.

Based on what you wrote, I bet if I set up a project with these files, I would see the same result as you.

index.php/fa/29084/0/
  • Attachment: rse.png
    (Size: 288.74KB, Downloaded 318 times)
  • Attachment: php.php
    (Size: 8.45KB, Downloaded 31 times)

[Updated on: Wed, 19 April 2017 22:59]

Report message to a moderator

Re: HTML Tags in PHP Files [message #1760061 is a reply to message #1759913] Fri, 21 April 2017 14:59 Go to previous messageGo to next message
Kaloyan Raev is currently offline Kaloyan RaevFriend
Messages: 201
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Thanks for attaching the PHP file!
However, I still could not reproduce the problem. I tried opening the file via RSE SFTP connection. I also tested on a Mac system.

Perhaps, the set of plugins you have installed on top of the PHP EPP package makes the difference. If you have the will, you can try this same file on the simplest possible setup - default PHP EPP installation and place the file in a project. If you see the closing tag highlighted then you can try making the setup closer to your working setup step by step and see on which step the problem occurs.
Re: HTML Tags in PHP Files [message #1760081 is a reply to message #1760061] Sat, 22 April 2017 02:56 Go to previous message
Dan Allen is currently offline Dan AllenFriend
Messages: 14
Registered: April 2017
Junior Member
I deleted all my eclipse stuff. reinstall, the tag matching worked. I applied my color preferences, it all works beautifully now.

Thank you for your assistance it is more than you think. Simply having reliable report of it working right was enough guidance for me to find my way.

Much appreciated.
Previous Topic:How to include a file to a php page?
Next Topic:Code Style - PHPDoc: @param description in same line AND a blank line before the @return-block
Goto Forum:
  


Current Time: Tue Apr 24 21:11:27 GMT 2018

Powered by FUDForum. Page generated in 0.01779 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software