Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » EMF Forms: PackageNotFoundException for view proxy model(emfforms viewproxy model seems not to be there)
EMF Forms: PackageNotFoundException for view proxy model [message #1756019] Fri, 10 March 2017 07:37 Go to next message
Wernke zur Borg is currently offline Wernke zur BorgFriend
Messages: 16
Registered: December 2011
Junior Member
Hi Smile

I am trying to use EMF Forms View Proxies in an ECP project but it seems the view proxy model is not available.

Error:
org.eclipse.emf.ecore.xmi.PackageNotFoundException: Package with uri 'http://org/eclipse/emf/ecp/view/viewproxy/model' not found.

Versions:
EMF 2.10.2
ECP 1.9.0
EMF Forms 1.9.0

My Eclipse product is based on features, org.eclipse.emf.ecp.emfforms.runtime.feature is included. All ECP and EMF Forms stuff basically works. The exception is thrown when I open the editor for a model element that uses a view proxy of its base class. The base class attributes are not shown, instead the above exception is thrown.

Let me know what information you need in addition.

Thanks, Wernke

[edit] Sorry I made a mistake. The view proxy is not one of a baseclass but of a referenced class. This can't work without somehow linking a feature to the proxy. But the error message indicates some other problem.

[Updated on: Fri, 10 March 2017 11:12]

Report message to a moderator

Re: EMF Forms: PackageNotFoundException for view proxy model [message #1756109 is a reply to message #1756019] Sat, 11 March 2017 12:57 Go to previous messageGo to next message
Jonas Helming is currently offline Jonas HelmingFriend
Messages: 58
Registered: September 2016
Member
Hi,

the view proxy sub model is not in the core SDK, you please make sure, that you have it in your target. Further, you need to make sure, that the bundles (ideally the feature) is contained in your product/run config.

Best regards
Jonas

--
Get professional Eclipse developer support:
http://eclipsesource.com/en/services/developer-support/
Re: EMF Forms: PackageNotFoundException for view proxy model [message #1756324 is a reply to message #1756109] Wed, 15 March 2017 11:34 Go to previous messageGo to next message
Wernke zur Borg is currently offline Wernke zur BorgFriend
Messages: 16
Registered: December 2011
Junior Member
Thanks, Jonas.

I did not have any problem with the SDK, but with the runtime. I find it strange that the SDK contains the view proxy model but the runtime does not. I added the view proxy feature to the target platform, and it is working now.
Re: EMF Forms: PackageNotFoundException for view proxy model [message #1756377 is a reply to message #1756324] Thu, 16 March 2017 07:32 Go to previous messageGo to next message
Jonas Helming is currently offline Jonas HelmingFriend
Messages: 58
Registered: September 2016
Member
Hi,

how is your runtime configured? We strongly recommend to configure your product feature based to avoid such missing bundles.

Best regards
Jonas

--
Get professional Eclipse developer support:
http://eclipsesource.com/en/services/developer-support/
Re: EMF Forms: PackageNotFoundException for view proxy model [message #1756383 is a reply to message #1756377] Thu, 16 March 2017 09:07 Go to previous message
Wernke zur Borg is currently offline Wernke zur BorgFriend
Messages: 16
Registered: December 2011
Junior Member
Hi Jonas,

my runtime is based on a product requiring these features:

https://snag.gy/wq8drI.jpg

I had to manually add the org.eclipse.emf.ecp.view.viewproxy.feature (selected) to make it work. I had expected it to be contained in the ecp feature. But never mind, the problem is solved. Smile

Cheers, Wernke
Previous Topic:[EMF Forms]Unusual Model element creation
Next Topic:EMF Refactor
Goto Forum:
  


Current Time: Sun Nov 19 21:57:52 GMT 2017

Powered by FUDForum. Page generated in 0.01907 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software