Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » SysML: wrong model validation result?(When I try to validate a model where one block is a specialization of another block I get a validation error 8.3.2.3. Block [8])
SysML: wrong model validation result? [message #1755546] Sun, 05 March 2017 14:26 Go to next message
Elmar Ihler is currently offline Elmar IhlerFriend
Messages: 2
Registered: March 2017
Junior Member
Hi,
when I try to validate (using "validate model") a SysML-model where one block is a specialization of another block I get a validation error "8.3.2.3. Block [8] Any classifier that specializes a Block must also have the Block stereotype or one of its specializations applied." In my understanding it should be possible to use a generalization between blocks, and, because both blocks have the Block stereotype, this check should be passed. Have I missed something?


Config:
Papyrus 2.0.2.201701101800 as downloaded from papyrus downloads
Papyrus SysML 1.4 0.10.0
Java 1.8.0_121 64bit
Windows 10

index.php/fa/28667/0/
Re: SysML: wrong model validation result? [message #1755721 is a reply to message #1755546] Tue, 07 March 2017 08:59 Go to previous messageGo to next message
Benoit Maggi is currently offline Benoit MaggiFriend
Messages: 129
Registered: March 2013
Location: Bordeaux, France
Senior Member
Hi Elmar,

You didn't miss anything, it's a bug that is present in 0.10.0 and should be fixed for 0.10.1.

I created the bug
https://bugs.eclipse.org/bugs/show_bug.cgi?id=513220
and pushed a first version for the fix.

In the mean time, you can disable the validation rule in the preferences:
- Window>Preferences>Model Validation>Constraints
- Chose SysML 1.4 Validation Category
- Deactivate : block.specialization

Thanks for reporting that,
Regards,
Benoit
Re: SysML: wrong model validation result? [message #1755772 is a reply to message #1755721] Tue, 07 March 2017 19:31 Go to previous message
Elmar Ihler is currently offline Elmar IhlerFriend
Messages: 2
Registered: March 2017
Junior Member
Hi Benoit,
I got the changed version yesterday.
Thanks for the quick fix!

Regards,
Elmar
Previous Topic:Change in class diagram layout with Papyrus v2.0
Next Topic:Papyrus Internationalization -> new video available
Goto Forum:
  


Current Time: Wed Jan 22 23:51:57 GMT 2020

Powered by FUDForum. Page generated in 0.02322 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top