Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » 4DIAC - Framework for Distributed Industrial Automation and Control » FORTE: Bugs in CLocalComLayer (With these bugs "CLEANDevice" doesn't work properly.)
FORTE: Bugs in CLocalComLayer [message #1754573] Mon, 20 February 2017 12:38 Go to next message
Lik Lik is currently offline Lik LikFriend
Messages: 20
Registered: February 2017
Location: Russia
Junior Member
Hi,
We found some bugs in CLocalComLayer:
1) The method closeConnection() is without "m_poLocalCommGroup = 0;" after unregisterPubl or unregisterSubl.
2) In the method removeListEntry() must be "itRevNode = pa_rlstList.end();" instead of "itRevNode = pa_rlstList.begin();"

With these bugs "CLEANDevice" doesn't work properly.

P.S. I could not get permission to file bugs at https://bugs.eclipse.org/bugs/enter_bug.cgi
Re: FORTE: Bugs in CLocalComLayer [message #1754606 is a reply to message #1754573] Mon, 20 February 2017 21:04 Go to previous messageGo to next message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 524
Registered: January 2014
Senior Member
Hi,

thanks for reporting these issues. I've reviewed them and applied them in commit [1].

For future fixes please have a look in the 4diac documentation in the section on how to contribute to FORTE. Regarding the bugzilla permission: Eclipse had a lot of spam bugs in the last half year. Therefore you need to get in contact with the webmaster to get for your Eclipse account also bugzilla write permissions, as it is pointed out by the green status message on the top of the bugzilla page.

BR,
Alois

[1] http://git.eclipse.org/c/4diac/org.eclipse.4diac.forte.git/commit/?h=1.8.x&id=56d699814283092fac9bac18803cc08a77cfc4d0
Re: FORTE: Bugs in CLocalComLayer [message #1754615 is a reply to message #1754606] Tue, 21 February 2017 05:39 Go to previous messageGo to next message
Lik Lik is currently offline Lik LikFriend
Messages: 20
Registered: February 2017
Location: Russia
Junior Member
Thank you for fix.

[Updated on: Tue, 21 February 2017 06:01]

Report message to a moderator

Re: FORTE: Bugs in CLocalComLayer [message #1754634 is a reply to message #1754615] Tue, 21 February 2017 08:46 Go to previous message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 524
Registered: January 2014
Senior Member
I just did a second check and both fixes should be in the repository.
Previous Topic:json com layer
Next Topic:FORTE: Bug in CIPComLayer
Goto Forum:
  


Current Time: Sat May 26 02:43:28 GMT 2018

Powered by FUDForum. Page generated in 0.02134 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top