Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse Stops Running When Importing From Maven(Java Program Halts with no error)
Eclipse Stops Running When Importing From Maven [message #1753771] Fri, 10 February 2017 03:53 Go to next message
Colin Woodworth is currently offline Colin WoodworthFriend
Messages: 1
Registered: February 2017
Junior Member
Hi Everyone,

I'm fairly new to Eclipse (2 months) and have been rolling right along with it until this morning. Suddenly some code that I hadn't touched in a couple of days suddenly stopped working. It simply halts right in the middle of execution without any error messages. I've narrowed the offending bit of code, here's what happens, if I run this simple bit of code and everything works great:


import java.awt.Font;
import java.awt.FontMetrics;
import java.awt.Graphics;
import java.awt.image.BufferedImage;

public class GrrrrEclipse{

	public static void main(String[] args)  {
		System.err.println("HERE1");
		BufferedImage bi = new BufferedImage(5, 5, BufferedImage.TYPE_INT_RGB);
		System.err.println("HERE2");
		Font f = new Font("Helvetica",Font.PLAIN,12);
		System.err.println("HERE3");
		Graphics g = bi.getGraphics();

		System.err.println(bi.toString());
		System.err.println(f.toString());
		System.err.println(g.toString());

		System.err.println("HERE4");

		FontMetrics fm = g.getFontMetrics(f);		

		System.err.println("FINISHED!!!!");
	}
}


But if I import the Amazon AWS SDK through Maven (//mvnrepository.com/artifact/com.amazonaws/aws-java-sdk-s3/1.11.86) and leave everything unchanged otherwise, the execution stops at "HERE4" and there is ZERO error message or indication of a problem. Furthermore this package has NOTHING to do with what this code is doing but it seems to be conflicting with it somehow. I've tried different versions of the aws-java-sdk-s3, pretty much anything I can think of. The worst part this code was working 2 days ago and this project has gone unchanged.

I'm out of things to try, is there anyone who might shed some light on what is happening?

Thank You!

[Updated on: Fri, 10 February 2017 15:00]

Report message to a moderator

Re: Eclipse Stops Running When Importing From Maven [message #1755037 is a reply to message #1753771] Mon, 27 February 2017 10:08 Go to previous message
Davide Vecchi is currently offline Davide VecchiFriend
Messages: 34
Registered: July 2009
Member
Does the ".log" file in the ".metadata" folder of the workspace mention something that could be related to this issue ? There might also be some crash dump file in the Eclipse installation folder, they have names like "hs_err_pid" something; they get created when the JVM itself crashes.

It could also be good to make sure that the Java runtime used in the two cases is the same. The problem could be caused by something in that AWS SDK that you import without which the crash doesn't occur.
Previous Topic:installed plugins not showing in eclipse nsight
Next Topic:AVRdude .hex file upload
Goto Forum:
  


Current Time: Tue Jun 15 14:24:42 GMT 2021

Powered by FUDForum. Page generated in 0.03469 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top