Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Import Existing Projects doesnt use project name(It always uses folder name instead of project name)
Import Existing Projects doesnt use project name [message #1752550] Wed, 25 January 2017 03:38 Go to next message
Iwan Satria is currently offline Iwan SatriaFriend
Messages: 3
Registered: January 2017
Junior Member
Hi,
This is my first submitted question here. Please correct me if I'm posting it in the wrong category.

I'm using latest Eclipse version (Neon.2). I have a problem when importing existing Eclipse projects as it uses the folder name (as displayed in the projects sidebar on the left) instead of the project name specified in the .project file.

All my colleagues do not have this issue. It only happens in my PC.

These are my failed attempts so far:
- I have tried opening the same project with older Eclipse version.
- I have cloned the whole workspace from the repository and use it as the new workspace and then re-import them.

I have googled around and apparently there are reported bugs similar to what I'm encountering here:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=225754
https://bugs.eclipse.org/bugs/show_bug.cgi?id=429881

I'm a bit confused though because the reported problems are with older versions and they're already fixed. Yet when I use the older version to open my projects the issue still occurs.

Any advice is appreciated.
Re: Import Existing Projects doesnt use project name [message #1752604 is a reply to message #1752550] Wed, 25 January 2017 15:12 Go to previous messageGo to next message
Brian de Alwis is currently offline Brian de AlwisFriend
Messages: 772
Registered: January 2012
Senior Member

You're likely hitting the case described at the of bug 225754 comment 38. Check that your workspace doesn't already contain directories with the same names.

Brian.


Eclipse Platform committer. Ask me about Eclipse support, training, and consulting.
Re: Import Existing Projects doesnt use project name [message #1753702 is a reply to message #1752604] Thu, 09 February 2017 06:50 Go to previous messageGo to next message
Iwan Satria is currently offline Iwan SatriaFriend
Messages: 3
Registered: January 2017
Junior Member
Hi Brian,
Thanks for the reply. I have checked and can confirm that there's no other directory with the same name. Is there anything else I need to check?
Re: Import Existing Projects doesnt use project name [message #1757881 is a reply to message #1753702] Tue, 21 March 2017 08:29 Go to previous message
Iwan Satria is currently offline Iwan SatriaFriend
Messages: 3
Registered: January 2017
Junior Member
Just to answer my own question, in case someone else encounters the same problem.
I solve this issue by adding another layer, i.e. folder, between the workspace folders and the projects.

My workspace path:
D:\workspace

Importing all my projects directly into the workspace below
D:\workspace\*
causes the aforementioned problems.

I solve this problem by importing my projects into a new folder inside the workspace folder.
D:\workspace\dev\*

I think it's a bug? Anyway, I have already resolved it.
Previous Topic:Content / Label provider in project explorer not refreshing with IResource.refreshLocal
Next Topic:Drag outline color when dragging Views. Use of applicationCSS
Goto Forum:
  


Current Time: Sat Sep 22 14:34:29 GMT 2018

Powered by FUDForum. Page generated in 0.01481 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top