Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Compatibility between plugins versions in Eclipse Mars(Repository not found (especially http://marketplace.eclipse.org), synchronize Gradle projects failed)
Compatibility between plugins versions in Eclipse Mars [message #1752471] Tue, 24 January 2017 08:24
pierre durand is currently offline pierre durandFriend
Messages: 3
Registered: January 2017
Junior Member
I use an Eclipse SDK, Mars 2 (4.5.2).

As I develop an Android application with JavafxPorts, I have added some plugins in Eclipse. All previous configurations worked fine.

After recently installing some plugins like Buildship (for more details, refer to http://stackoverflow.com/questions/41788999/after-installing-the-gluon-plugin-in-eclipse-sdk-mars2-the-gradle-task-view-is) .
Now, in Eclipse menu, the items about the Gradle tasks have changed, but they don't work. There are also some other errors.

It seems to be a compatibility problem between installed components in Eclipse (I hope so).
-----------------------
Main Eclipse SDK configuration:
-----------------------
- Buildship (Eclipse Plug-in for Gradle) : 2.0.1
- e(fx)clipse - IDE : 2.3.0
- Eclipse e4 tools : 4.5.1
- Eclipse SDK (Mars.2) : 4.5.2
- FileSync: 1.3.9
- Gluon Tools : 2.4.0
- JDepend4Eclipse : 1.2.4
- m2e (Maven) : 1.6.2

-----------------------
And, now, the failure context:
-----------------------
Plug-in: org.eclipse.equinox.p2.metadata.repository:
-----------------------
No repository found at http://marketplace.eclipse.org

No repository found at file:/C:/Users/pascal/AppData/Local/Android/sdk/buildshipArchive

No repository found at jar:file:/C:/Documents/Formations/Java/wkfx/appassembler-master.zip!/

No repository found at file:/C:/Users/pascal/AppData/Local/

---------------------
Plug-in: org.eclipse.buildship.core
---------------------
Synchronize Gradle projects with workspace failed due to an error connecting to the Gradle build.

-----------------------
Plug-in: org.eclipse.core.runtime AND Plug-in: org.eclipse.jface
-----------------------
Invalid input url:platform:/plugin/org.springsource.ide.eclipse.gradle.ui.taskview/icons/gradle-icon-16.png

-----------------------
After updating the Buildship:
-----------------------
Some internal and external locations could not be found.
---------------------
No repository found at file:/C:/Users/pascal/AppData/Local/.

No repository found at jar:file:/C:/Documents/Formations/Java/wkfx/appassembler-master.zip!/.

No repository found at file:/C:/Users/pascal/AppData/Local/Android/sdk/buildshipArchive.

Unable to read repository at http://marketplace.eclipse.org/marketplace-client-intro?mpc_install=2496245.

http://marketplace.eclipse.org/marketplace-client-intro?mpc_install=2496245 is not a valid repository location.

No repository found at http://marketplace.eclipse.org.

Thanks a lot for your answer
Note: I tried to revert the recently done installations under Eclipse by using Help - Installation Details - Installation History and then by reverting one by one from the youngest to the oldest. But the third Revert action failed...
Previous Topic:Expand Section widget in Eclipse Forms
Next Topic:Dynamic menu in eclipse 3.3
Goto Forum:
  


Current Time: Sat Jun 23 12:32:36 GMT 2018

Powered by FUDForum. Page generated in 0.02158 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top