Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Eclipse C/C++ Neon.2 (4.6.2) & macOS Sierra (10.12.2)(Eclipse C/C++ Neon.2 (4.6.2) & macOS Sierra (10.12.2) & Xcode 8.2.1 & GDB 7.12.1 — eclipse debug cannot start!)
Eclipse C/C++ Neon.2 (4.6.2) & macOS Sierra (10.12.2) [message #1750664] Sat, 24 December 2016 10:20 Go to next message
Alexander Bychkov is currently offline Alexander BychkovFriend
Messages: 2
Registered: October 2011
Junior Member
I have next configuration:
1. macOS Sierra (10.12.2);
2. Xcode 8.2.1;
3. Eclipse C/C++ Neon.2 (4.6.2);
4. GDB 7.12.1 -- installed by homebrew and signed as required!

I had working configuration with Eclipse C/C++ Neon.1a (4.6.1)!
But after upgrading (or pure install) to Neon.2 I have situation:

When I start debug into Eclipse the CDT waits (I suppose) "Developer Tools Access" dialog. But dialog does not appear!

And I see "launch debug (62 %).." Infinite time!!!

To continue development process I return to Neon.1a.

What's wrong?!
Re: Eclipse C/C++ Neon.2 (4.6.2) & macOS Sierra (10.12.2) [message #1751007 is a reply to message #1750664] Tue, 03 January 2017 15:28 Go to previous messageGo to next message
Jonah Graham is currently offline Jonah GrahamFriend
Messages: 404
Registered: June 2014
Senior Member
If you have a reproducible case would you be able to file a bug report? CDT in Neon.2 has a new Debug Console, but AFAIK nothing that should cause the problem you are seeing. Unfortunately I don't have access to a Mac to test at the moment, but if it is reproducible it would be great to resolve this: https://bugs.eclipse.org/bugs/enter_bug.cgi?product=CDT
Re: Eclipse C/C++ Neon.2 (4.6.2) & macOS Sierra (10.12.2) [message #1751267 is a reply to message #1751007] Fri, 06 January 2017 16:30 Go to previous message
Jonah Graham is currently offline Jonah GrahamFriend
Messages: 404
Registered: June 2014
Senior Member
This problem is known and currently being worked on: https://bugs.eclipse.org/bugs/show_bug.cgi?id=509737

Previous Topic:Multiple projects in Oxygen
Next Topic:Where did the cross compiler option go for neon?
Goto Forum:
  


Current Time: Sat Jan 29 05:44:18 GMT 2022

Powered by FUDForum. Page generated in 0.01887 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top