Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Can I use the latest PDE to develop plugins targeted for an earlier version of Eclipse?(I assume it's possible but dependency is giving me a headache)
Can I use the latest PDE to develop plugins targeted for an earlier version of Eclipse? [message #1750323] Mon, 19 December 2016 23:16 Go to next message
Max Yang is currently offline Max YangFriend
Messages: 3
Registered: December 2016
Junior Member
I'm developing a plugin on Neon.1a targeted to run on Luna (4.4.x). What do I need to do to make it compatible? Currently it fails because it requires org.eclipse.core.filesystem bundle version 1.6.0 which is too new for Luna.

I have already tried specifying a version in MANIFEST.MF but it's still resolving to 1.6.0. How can I make my plugin compatible with older versions? Do I have to use older version of Eclipse and PDE to package the plugin?

MANIFEST.MF
Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Workbench
Bundle-SymbolicName: workbench;singleton:=true
Bundle-Version: 1.0.0.beta
Require-Bundle: org.eclipse.core.runtime;bundle-version="3.10.0",
org.eclipse.ui,
org.eclipse.core.filesystem;bundle-version="1.4.0",
org.apache.commons.io,
org.apache.commons.lang
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ClassPath: .,
swing2swt.jar
Import-Package: javax.xml.bind,
org.apache.commons.io,
org.eclipse.core.filesystem;version="[1.4.0,2.0.0)",
org.eclipse.core.runtime;version="[3.10.0,4.0.0)",
org.eclipse.datatools.connectivity,
org.eclipse.swt,
org.eclipse.ui,
org.eclipse.ui.ide,
org.osgi.framework
Bundle-Activator: Activator
Bundle-ActivationPolicy: lazy

index.php/fa/27913/0/
Re: Can I use the latest PDE to develop plugins targeted for an earlier version of Eclipse? [message #1750847 is a reply to message #1750323] Thu, 29 December 2016 23:37 Go to previous message
Max Yang is currently offline Max YangFriend
Messages: 3
Registered: December 2016
Junior Member
It turned out I only just needed to specify a target platform by creating a target definition and set it as current.
Previous Topic:Confusing LinkageError
Next Topic:View initializing in dev mode but not after installation
Goto Forum:
  


Current Time: Sun Jul 15 18:47:30 GMT 2018

Powered by FUDForum. Page generated in 0.01425 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top