Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse Luna v4.4.2 - Need to upgrade Debug UI from v
Eclipse Luna v4.4.2 - Need to upgrade Debug UI from v [message #1750304] Mon, 19 December 2016 18:23 Go to next message
Alex Murray is currently offline Alex MurrayFriend
Messages: 2
Registered: December 2016
Junior Member
Working with SailPoint vendor on their IIQDA addin for Eclipse. They specifically state to use Eclipse Luna (IDE for Java Developers) version: Luna Service Release 2 (4.4.2). We installed build id: 20150219-0600.
When we attempt to install the plugin using Help > Install New Software > using their github.io address, we get the following error:

Cannot complete the install because one or more required items could not be found.
Software being installed: IdentityIQ Deployment Accelerator Feature 3.0.0.I20161219-1150 (sailpoint.iiqda.feature.feature.group 3.0.0.I20161219-1150)
Missing requirement: sailpoint.iiqda 3.0.0.I20161219-1150 (sailpoint.IIQ_Deployment_Accelerator 3.0.0.I20161219-1150) requires 'bundle org.eclipse.debug.ui [3.11.0,4.0.0)' but it could not be found
Cannot satisfy dependency:
From: IdentityIQ Deployment Accelerator Feature 3.0.0.I20161219-1150 (sailpoint.iiqda.feature.feature.group 3.0.0.I20161219-1150)
To: sailpoint.IIQ_Deployment_Accelerator [3.0.0.I20161219-1150]

I have confirmed in the Eclipse Luna install, we have the Debug UI plugin as version 3.10.2.v20141014-1039. So I am attempting to upgrade that the Debug UI to v3.11 per the plugin's requirement, I have tried the Check for Updates and no updates seem to be found.

We installed Eclipse Neon on another computer and had no issues with the plugin install and the debug UI installed is version v3.11+.

I have searched the forums here and other sites but had no success so far.
Is there a way to update the Debug UI to v3.11.0,4.0.0 in Eclipse Luna? Or must we use Neon?

Thank you for your assistance.
Re: Eclipse Luna v4.4.2 - Need to upgrade Debug UI from v [message #1750307 is a reply to message #1750304] Mon, 19 December 2016 19:01 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
It seems that the vendor's statements and their actual plug-in configuration conflict with each other. They say that Luna should be used but then their configuration requires a later version (at least a later version of the org.eclipse.debug.ui plug-in, but that's probably just the tip of the iceberg). If you don't have any problems using Neon, I'd say just use it. Perhaps contact the vendor about their statements regarding Luna, since they appear to be invalid.

In any case, I would not recommend trying to update just that one plug-in. Chance are it won't work anyway, and there's no simple way to update just one plug-in from that low-level of the platform.

[Updated on: Mon, 19 December 2016 19:03]

Report message to a moderator

Re: Eclipse Luna v4.4.2 - Need to upgrade Debug UI from v [message #1750310 is a reply to message #1750307] Mon, 19 December 2016 19:36 Go to previous message
Alex Murray is currently offline Alex MurrayFriend
Messages: 2
Registered: December 2016
Junior Member
Thank you for the reply. Appreciate the information.
Previous Topic:Preserving undo history after saving
Next Topic:Convert Eclipse RCP Help Project to Standalone Help System (WebHelp)
Goto Forum:
  


Current Time: Sun Oct 25 08:23:59 GMT 2020

Powered by FUDForum. Page generated in 0.03349 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top