Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Installer Cache Problem
Installer Cache Problem [message #1747273] Fri, 11 November 2016 13:50 Go to next message
Helios Hyperion is currently offline Helios HyperionFriend
Messages: 2
Registered: May 2016
Junior Member
Hi,

I created a private setup for my company and modified the .ini file using the
-Doomph.redirection.oasp=index:/redirectable.products.setup-> to point to it.

At the first time we launch the installer it runs ok, but the problem comes when we change the .setup file in the server. If I run the installer again I still see the old setup options.

Problem is that the files are being stored in a local cache found in .eclipse/org.eclipse.oomph.setup/cache and the system is not even making any attempt to go to the server to verify for new content, just uses the cache contents always.

The only way to solve my problem is to erase the /cache contents before I launch the installer again.

Questions:

- Is this designed to work like this or is a bug?
- There is an option that I can use in the .ini file that prevents the installer from caching files or at least to ignore the cache and always go get the server content?
Re: Installer Cache Problem [message #1747282 is a reply to message #1747273] Fri, 11 November 2016 15:59 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31032
Registered: July 2009
Senior Member
It should use the cache initially, but it should check the eTag (or time stamp if there is no eTag) as well. Perhaps using -Doomph.setup.ecf.trace=true and monitoring the behavior of ECFURIHandlerImpl on System.out will help determine what's going on. Perhaps the changes you make on the server are not reflected in the eTag the server returns for that resource?
Previous Topic:Show the Oomph-Toolbar per default
Next Topic:[Closed] Non-triggering Project Tasks in a given Product
Goto Forum:
  


Current Time: Sat Apr 04 13:28:38 GMT 2020

Powered by FUDForum. Page generated in 0.03773 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top