Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Virgo 3.7.0.M03 - Repository/org.springframework.spring-library-4.2.1.RELEASE.libd incompatible(Spring version available into file does not match with current spring version)
Virgo 3.7.0.M03 - Repository/org.springframework.spring-library-4.2.1.RELEASE.libd incompatible [message #1747176] Thu, 10 November 2016 14:11 Go to next message
Junior Sousa is currently offline Junior SousaFriend
Messages: 15
Registered: September 2016
Junior Member
The content of file org.springframework.spring-library-4.2.1.RELEASE.libd does not match with current version of spring 4.2.4.

Library-SymbolicName: org.springframework.spring
Library-Version: 4.2.1.RELEASE
Library-Name: Spring Framework
Import-Bundle: 
 org.springframework.aop;version="[4.2.1, 4.2.2)",
 org.springframework.aspects;version="[4.2.1, 4.2.2)",
 org.springframework.beans;version="[4.2.1, 4.2.2)",
 org.springframework.context;version="[4.2.1, 4.2.2)",
 org.springframework.context.support;version="[4.2.1, 4.2.2)",
 org.springframework.core;version="[4.2.1, 4.2.2)",
 org.springframework.expression;version="[4.2.1, 4.2.2)",
 org.springframework.jdbc;version="[4.2.1, 4.2.2)",
 org.springframework.jms;version="[4.2.1, 4.2.2)",
 org.springframework.orm;version="[4.2.1, 4.2.2)",
 org.springframework.oxm;version="[4.2.1, 4.2.2)",
 org.springframework.transaction;version="[4.2.1, 4.2.2)",
 org.springframework.web;version="[4.2.1, 4.2.2)",
 org.springframework.webmvc;version="[4.2.1, 4.2.2)",
 org.springframework.webmvc.portlet;version="[4.2.1, 4.2.2)",
 org.springframework.websocket;version="[4.2.1, 4.2.2)",
 oevm.org.aopalliance;version="[1.0.0, 1.0.0]",
 javax.jms;version="[1,2)"


Current Spring Version into Spring: 4.2.4

Is this file used by virgo?

Regards,

Junior Sousa

[Updated on: Thu, 10 November 2016 15:34]

Report message to a moderator

Re: Virgo 3.7.0.M03 - Repository/org.springframework.spring-library-4.2.1.RELEASE.libd incompatible [message #1751475 is a reply to message #1747176] Tue, 10 January 2017 15:41 Go to previous messageGo to next message
Matteo Cantarelli is currently offline Matteo CantarelliFriend
Messages: 26
Registered: June 2012
Junior Member
I'm wondering the same while I investigate some uses-conflict I'm getting...
Re: Virgo 3.7.0.M03 - Repository/org.springframework.spring-library-4.2.1.RELEASE.libd incompatible [message #1751983 is a reply to message #1747176] Tue, 17 January 2017 14:15 Go to previous messageGo to next message
Florian Waibel is currently offline Florian WaibelFriend
Messages: 160
Registered: June 2010
Senior Member
Thanks for reporting.
I'll fix this with https://bugs.eclipse.org/bugs/show_bug.cgi?id=510305 the update to Spring Framework 4.2.9.RELEASE.
Re: Virgo 3.7.0.M03 - Repository/org.springframework.spring-library-4.2.1.RELEASE.libd incompatible [message #1752732 is a reply to message #1751983] Thu, 26 January 2017 15:49 Go to previous message
Florian Waibel is currently offline Florian WaibelFriend
Messages: 160
Registered: June 2010
Senior Member
We shipped milestone 3.7.0.M04 with a new library definition.

Please open a bug if you still have a problem.
Previous Topic:Virgo 3.7.0.M04 has been shipped
Next Topic:Virgo 3.7.0.M04 - Snaps is not available for download
Goto Forum:
  


Current Time: Sun Nov 18 07:45:00 GMT 2018

Powered by FUDForum. Page generated in 0.01885 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top