Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Trouble installing Neon version on Mac OSX(Error message about Java VM when running installer)
Trouble installing Neon version on Mac OSX [message #1745938] Wed, 19 October 2016 16:03
Michael DeBellis is currently offline Michael DeBellisFriend
Messages: 1
Registered: October 2016
Junior Member
I have an old version of Eclipse installed on my Mac desktop. It is Luna Release 2 (4.4.2). On my Mac I'm running OSX El Capitan Version 10.11.6 on a 64 bit processor.

I started using Eclipse a long time ago and then went to more conceptual work in logic and ontologies where I didn't need Java so haven't used it in quite a while and I never really got very familiar with Eclipse. I'm fairly familiar with Java, programmed in it quite a bit a long time ago but am a bit rusty.

Now I need Java/Eclipse for a Semantic Web project I'm doing with Protege (an ontology editor from Stanford). I've done a lot in Protege using OWL and SWRL but there are some things that I need to program.

When I went to Help>Check for Updates it said no updates were available which surprised me. Then I tried to just uninstall the working version and install the latest version from scratch. But when I try to run the installer I get the error message: "Version 1.6.0_65 of the JVM is not suitable version 1.7 or higher is required" I checked the Java console in my Mac Preferences and it said "Your system has the recommended version of Java. Java 8 update 111" I did some searching and found that apparently I need to download an Oracle developer version of Java to fix this(?) But the messages I found were 2 years old. I'm a bit leery to mess around with Java unless absolutely necessary, in the past I've had issues with Protege and Java versions and I use Protege all the time. So I un-deleted the old version of Eclipse and it still works. My questions are:

1) How much am I missing by just sticking with this older version of Eclipse?
2) How well supported is Eclipse on OSX? This seems like a really basic error that's existed for years and no one has bothered to fix it yet?
3) If I do want Neon is it still the only solution to load the Oracle developer version and is that a pretty safe thing to do or might it cause problems with Protege or other applications on my Mac that use Java?

Michael DeBellis
mdebellissf@gmail.com
Previous Topic:How to enable by default new Word Wrap feature in Neon
Next Topic:Build not working
Goto Forum:
  


Current Time: Mon Sep 16 20:44:40 GMT 2019

Powered by FUDForum. Page generated in 0.02670 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top