Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Update an already eclipse installed through oomph
Update an already eclipse installed through oomph [message #1745272] Fri, 07 October 2016 07:51 Go to next message
Dominique Jean-Prost is currently offline Dominique Jean-ProstFriend
Messages: 12
Registered: August 2016
Junior Member
Hello,

I used a specific setup to install my fully customized java EE neon.
I sent this setup file to a colleague of mine and he managed to install the very same eclipse setup, which is great.

Now, I added a new P2 Director in my setup, and installed a new eclipse plugin.
I sent my setup file to my colleague, and I was expecting that his eclipse would automatically upgrade itself, so that the new plugin would be installed on his installation. It didn't.

He then tried "Help/Perform Setup tasks", and it didn't installed the plugin neither.
So what's wrong ? Did I misunderstand oomph behaviour ? Did I miss something ?
Thank you.
dom
Re: Update an already eclipse installed through oomph [message #1745312 is a reply to message #1745272] Fri, 07 October 2016 12:34 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31032
Registered: July 2009
Senior Member
Comments inline below.

Dominique Jean-Prost wrote on Fri, 07 October 2016 03:51
Hello,

I used a specific setup to install my fully customized java EE neon.
I sent this setup file to a colleague of mine and he managed to install the very same eclipse setup, which is great.
How did you send it, as an attachment and then he copied it somewhere and used it? What kind of setup? A project setup?Quote:

Now, I added a new P2 Director in my setup, and installed a new eclipse plugin.
I sent my setup file to my colleague, and I was expecting that his eclipse would automatically upgrade itself, so that the new plugin would be installed on his installation. It didn't.
Did he put it where it exactly replaced the setup he's currently using?Quote:

He then tried "Help/Perform Setup tasks", and it didn't installed the plugin neither.
So what's wrong ? Did I misunderstand oomph behaviour ? Did I miss something ?
Thank you.
dom

Generally the best way to share it to maintain the setup on a website somewhere and have people point directly as that setup with a URL. Then you can change what's at that URL and everyone will see the changes. But I don't know how you guys exchanged setup, and more specifically where he put his the first time and where he put it the second time.
Re: Update an already eclipse installed through oomph [message #1745315 is a reply to message #1745312] Fri, 07 October 2016 12:38 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31032
Registered: July 2009
Senior Member
No Message Body
Re: Update an already eclipse installed through oomph [message #1745331 is a reply to message #1745312] Fri, 07 October 2016 13:34 Go to previous messageGo to next message
Dominique Jean-Prost is currently offline Dominique Jean-ProstFriend
Messages: 12
Registered: August 2016
Junior Member
Hello Ed,

I originally sent the project setup file to him by email. He copied this file in his file system, and installed eclipse with this.

I then sent it after my change, with a new content. He saved this file at the very same place, but nothing happened when using "perform setup tasks". Do you confirm it should have installed the new plugin ?

I will have a look to how I can put the setup file in a website so that it's easier to maintain.

Dom
Re: Update an already eclipse installed through oomph [message #1745368 is a reply to message #1745331] Sat, 08 October 2016 18:01 Go to previous message
Alexander Nittka is currently offline Alexander NittkaFriend
Messages: 1193
Registered: July 2009
Senior Member
The same (folder) location is not sufficient. You must also use the same file name.
In Eclipse, you can open the setup file actually used (Navigate->Open Setup-><theProject>), or you double check the list of tasks you see when manually triggering an update (Help->Perform Setup Task). Check there, whether your changes are actually present.

Alex


Need training, onsite consulting or any other kind of help for Xtext?
Go visit http://xtext.itemis.com or send a mail to xtext@itemis.de
Previous Topic:Installer says that restart needed but I think it is not
Next Topic:Linked resources are not supported by this application.
Goto Forum:
  


Current Time: Mon Apr 06 00:21:12 GMT 2020

Powered by FUDForum. Page generated in 0.01997 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top