Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » WEBSPHERE 8.5.5.10 (java.lang.ClassCastException)
icon7.gif  WEBSPHERE 8.5.5.10 [message #1745264] Fri, 07 October 2016 06:44 Go to next message
uma koduri is currently offline uma koduriFriend
Messages: 3
Registered: October 2016
Junior Member
For JDK 1.7 it is working fine. Now upgraded to JDK 1.8 we are getting below error for the BIRT reports.
com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1892)
[9/21/16 13:17:16:564 EDT] 00000090 SystemErr R Caused by: java.lang.ClassCastException: org.apache.xerces.parsers.XIncludeAwareParserConfiguration incompatible with org.apache.xerces.xni.parser.XMLParserConfiguration
[9/21/16 13:17:16:565 EDT] 00000090 SystemErr R at org.apache.xerces.parsers.DOMParser.<init>(Unknown Source)
[9/21/16 13:17:16:565 EDT] 00000090 SystemErr R at org.apache.xerces.parsers.DOMParser.<init>(Unknown Source)
[9/21/16 13:17:16:565 EDT] 00000090 SystemErr R at org.apache.xerces.jaxp.DocumentBuilderImpl.<init>(Unknown Source)
[9/21/16 13:17:16:565 EDT] 00000090 SystemErr R at org.apache.xerces.jaxp.DocumentBuilderFactoryImpl.newDocumentBuilder(Unknown Source)
[9/21/16 13:17:16:566 EDT] 00000090 SystemErr R at org.eclipse.birt.report.engine.parser.HTMLTextParser.parseHTML(HTMLTextParser.java:139)
[9/21/16 13:17:16:566 EDT] 00000090 SystemErr R at org.eclipse.birt.report.engine.parser.TextParser.parse(TextParser.java:111)

Systemout.log

************ Start Display Current Environment ************
WebSphere Platform 8.5.5.10 [EXPRESS 8.5.5.10 cf101629.01] running with process name QPAYROLL_SlfSvAppSvrZ8\QPAYROLL_SlfSvAppSvrZ8\SlfSvAppSvrZ8 and process id 873478/QEJBSVR/SLFSVAPPSV
Host Operating System is OS/400, version V7R3M0
Java version = 1.8.0, Java Runtime Version = jvmap6480sr3-20160428_01_cr2.8, Java Compiler = j9jit28, Java VM name = IBM J9 VM
was.install.root = /QIBM/ProdData/WebSphere/AppServer/V85/Express

Please respond on this ASAP. We are struck ed with the generating reports

Thanks, Uma
Re: WEBSPHERE 8.5.5.10 [message #1745977 is a reply to message #1745264] Thu, 20 October 2016 06:17 Go to previous message
uma koduri is currently offline uma koduriFriend
Messages: 3
Registered: October 2016
Junior Member
Hi Everyone,

Please respond on the above issue. We posted the issue more than one week back. Still we didnot get any responce on this. Please help us on this.
Thanks , Uma
Previous Topic:duplicate post, admin delete it please
Next Topic:ClassCastException in PersistenceUnitProcessor using a PoJo data source/data set with eclipselink
Goto Forum:
  


Current Time: Sat Aug 24 06:36:40 GMT 2019

Powered by FUDForum. Page generated in 0.02022 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top