Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Debugging arduino (samd) target
Debugging arduino (samd) target [message #1744555] Wed, 28 September 2016 09:08 Go to next message
Jean François is currently offline Jean FrançoisFriend
Messages: 2
Registered: September 2016
Junior Member
hello
I can't figure out how to debug arduino target (equipped with samd MCU).
It should be possible with the help of openocd but I don't succeed to configure it properly.
Any help is welcome.
Regards
Re: Debugging arduino (samd) target [message #1744600 is a reply to message #1744555] Wed, 28 September 2016 18:49 Go to previous messageGo to next message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 690
Registered: August 2014
Senior Member
If the board is an Arduino Due with SAM3X processor, you need an OpenOCD -compatible adapter to connect to the JTAG pins. There is no built-in JTAG interface on the board.


--

Tauno Voipio
Re: Debugging arduino (samd) target [message #1744627 is a reply to message #1744600] Thu, 29 September 2016 06:34 Go to previous messageGo to next message
Jean François is currently offline Jean FrançoisFriend
Messages: 2
Registered: September 2016
Junior Member
Hello,
Thank you very much for the reply.
My board is a Zero, equipped with an ATSAMD21G18, so it includes Atmel EDBG and as far as I understand there is no need to additional hardware.
Anyway, in both cases, i'm not sure I'm going the right way to configure the debug. Things are not clear to me, any pointer to a tutorial?
Regards
Re: Debugging arduino (samd) target [message #1744680 is a reply to message #1744627] Thu, 29 September 2016 13:03 Go to previous message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 690
Registered: August 2014
Senior Member
You could start with this: <http://starter-kit.nettigo.eu/2015/debug-sketch-on-arduino-zero-pro-with-gdb-and-openocd/>.


--

Tauno Voipio
Previous Topic:BOP Define descovery gives empty values
Next Topic:"GCC" not found in path
Goto Forum:
  


Current Time: Fri Jan 28 03:53:17 GMT 2022

Powered by FUDForum. Page generated in 0.01253 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top