Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Register EPackage probelm "Couldn't find an interface"(EPackages registered in workflow but interface not found when running)
Register EPackage probelm "Couldn't find an interface" [message #1743374] Wed, 14 September 2016 16:06 Go to next message
tom KIRKHAM is currently offline tom KIRKHAMFriend
Messages: 16
Registered: August 2016
Junior Member
Hi All,

I am working with my own ecore transformed into xtext on this tutorial
https://eclipse.org/Xtext/documentation/101_five_minutes.html

I previously posted about dependencies and xtext references. Things build fine by when running the web server I get the error below
Problems instantiating module org.xtext.paasage.editor.GenerateCamel:

and also this

org.eclipse.emf.mwe.core.ConfigurationException: Couldn't find an interface eu.paasage.camel.CamelPackage

The epackage is registered in the workflow like
registerGeneratedEPackage = "eu.paasage.camel.CamelPackage"

and the source code for the CamelPackage class is in "src/eu/paasage./camel/CamelPackage"

I have tried many solutions suggested for this error but no luck, does anybody have any ideas?

Thanks,
Tom

PS if i remove the epackage registrations i get this error when running the web ui

Unresolved proxy http://www.paasage.eu/2015/06/camel#//CamelModel. Make sure the EPackage has been registered.

[Updated on: Wed, 14 September 2016 16:15]

Report message to a moderator

Re: Register EPackage probelm "Couldn't find an interface" [message #1743378 is a reply to message #1743374] Wed, 14 September 2016 16:54 Go to previous messageGo to next message
tom KIRKHAM is currently offline tom KIRKHAMFriend
Messages: 16
Registered: August 2016
Junior Member
Hi, I have managed to move this on by registering the ecore package. The error I now get is about a invalid header, see trace below:

Working Directory: C:\Users\tk78\neonCAMELeditorWeb\org.xtext.paasage.model.parent\org.xtext.paasage.model.web
Gradle User Home: C:\Users\tk78\.gradle
Gradle Distribution: Gradle wrapper from target build
Gradle Version: 2.8
Java Home: C:\Program Files\Java\jdk1.8.0_45
JVM Arguments: None
Program Arguments: None
Gradle Tasks: jettyRun

:org.xtext.paasage.model:generateXtextLanguage
0 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - Skipping conflicting project org.eclipse.emf.cdo at 'archive:file:/C:/Users/tk78/.m2/repository/org/eclipse/emf/cdo_4.3.0/v20140520-1823/cdo_4.3.0-v20140520-1823.jar!/' and using 'archive:file:/C:/Users/tk78/.gradle/caches/modules-2/files-2.1/org.eclipse.emf/cdo_4.3.0/v20140520-1823/c91081e7ed38605b91aea68dc96c3f50c9c12888/cdo_4.3.0-v20140520-1823.jar!/' instead.
37 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - Skipping conflicting project antlr at 'archive:file:/C:/Users/tk78/.gradle/caches/modules-2/files-2.1/org.antlr/antlr-runtime/3.2/31c746001016c6226bd7356c9f87a6a084ce3715/antlr-runtime-3.2.jar!/' and using 'archive:file:/C:/Users/tk78/.gradle/caches/modules-2/files-2.1/org.xtext/antlr-generator/3.2.1/d3fa97d931949af341889c94f6455822674e52f2/antlr-generator-3.2.1.jar!/' instead.
38 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - Skipping conflicting project antlr at 'archive:file:/C:/Users/tk78/.gradle/caches/modules-2/files-2.1/org.xtext/antlr-generator/3.2.1/d3fa97d931949af341889c94f6455822674e52f2/antlr-generator-3.2.1.jar!/' and using 'archive:file:/C:/Users/tk78/.gradle/caches/modules-2/files-2.1/antlr/antlr/2.7.7/83cd2cd674a217ade95a4bb83a8a14f351f48bd0/antlr-2.7.7.jar!/' instead.
48 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Registering platform uri 'C:\Users\tk78\neonCAMELeditorWeb'
792 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - Skipping conflicting project gradle at 'archive:file:/C:/Users/tk78/neonCAMELeditorWeb/org.xtext.example.kyriakos.parent/gradle/wrapper/gradle-wrapper.jar!/' and using 'archive:file:/C:/Users/tk78/neonCAMELeditorWeb/org.xtext.paasage.CamelUI.parent/gradle/wrapper/gradle-wrapper.jar!/' instead.
832 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - Skipping conflicting project gradle at 'archive:file:/C:/Users/tk78/neonCAMELeditorWeb/org.xtext.paasage.CamelUI.parent/gradle/wrapper/gradle-wrapper.jar!/' and using 'archive:file:/C:/Users/tk78/neonCAMELeditorWeb/org.xtext.paasage.camelWebEditor.parent/gradle/wrapper/gradle-wrapper.jar!/' instead.
834 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - Skipping conflicting project .antlr at 'archive:file:/C:/Users/tk78/neonCAMELeditorWeb/org.xtext.example.kyriakos.parent/org.xtext.example.kyriakos/.antlr-generator-3.2.0-patch.jar!/' and using 'archive:file:/C:/Users/tk78/neonCAMELeditorWeb/org.xtext.paasage.camelWebEditor.parent/org.xtext.paasage.camelWebEditor/.antlr-generator-3.2.0-patch.jar!/' instead.
1129 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - Skipping conflicting project org.eclipse.emf.cdo.common at 'archive:file:/C:/Users/tk78/.gradle/caches/modules-2/files-2.1/org.eclipse.emf.cdo/common_4.3.0/v20140309-0644/a4144abb21923590ebd793471a6762584701f722/common_4.3.0-v20140309-0644.jar!/' and using 'archive:file:/C:/Users/tk78/neonCAMELeditorWeb/org.xtext.paasage.camelWebEditor.parent/org.xtext.paasage.camelWebEditor/build/resources/main/common_4.3.0-v20140309-0644.jar!/' instead.
2000 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - Skipping conflicting project gradle at 'archive:file:/C:/Users/tk78/neonCAMELeditorWeb/org.xtext.paasage.camelWebEditor.parent/gradle/wrapper/gradle-wrapper.jar!/' and using 'archive:file:/C:/Users/tk78/neonCAMELeditorWeb/org.xtext.paasage.model.parent/gradle/wrapper/gradle-wrapper.jar!/' instead.
2001 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - Skipping conflicting project .antlr at 'archive:file:/C:/Users/tk78/neonCAMELeditorWeb/org.xtext.paasage.camelWebEditor.parent/org.xtext.paasage.camelWebEditor/.antlr-generator-3.2.0-patch.jar!/' and using 'archive:file:/C:/Users/tk78/neonCAMELeditorWeb/org.xtext.paasage.model.parent/org.xtext.paasage.model/.antlr-generator-3.2.0-patch.jar!/' instead.
2293 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - Skipping conflicting project org.eclipse.emf.cdo.common at 'archive:file:/C:/Users/tk78/neonCAMELeditorWeb/org.xtext.paasage.camelWebEditor.parent/org.xtext.paasage.camelWebEditor/build/resources/main/common_4.3.0-v20140309-0644.jar!/' and using 'archive:file:/C:/Users/tk78/neonCAMELeditorWeb/org.xtext.paasage.model.parent/org.xtext.paasage.model/build/resources/main/common_4.3.0-v20140309-0644.jar!/' instead.
3511 [main] INFO clipse.emf.mwe.utils.GenModelHelper - Registered GenModel 'http://www.paasage.eu/2015/06/camel' from 'platform:/resource/org.xtext.paasage.model/model/camel.genmodel'
3511 [main] INFO clipse.emf.mwe.utils.GenModelHelper - Registered GenModel 'http://www.paasage.eu/2015/06/camel/deployment' from 'platform:/resource/org.xtext.paasage.model/model/camel.genmodel'
3511 [main] INFO clipse.emf.mwe.utils.GenModelHelper - Registered GenModel 'http://www.paasage.eu/2015/06/camel/execution' from 'platform:/resource/org.xtext.paasage.model/model/camel.genmodel'
3511 [main] INFO clipse.emf.mwe.utils.GenModelHelper - Registered GenModel 'http://www.paasage.eu/2015/06/camel/location' from 'platform:/resource/org.xtext.paasage.model/model/camel.genmodel'
3511 [main] INFO clipse.emf.mwe.utils.GenModelHelper - Registered GenModel 'http://www.paasage.eu/2015/06/camel/metric' from 'platform:/resource/org.xtext.paasage.model/model/camel.genmodel'
3512 [main] INFO clipse.emf.mwe.utils.GenModelHelper - Registered GenModel 'http://www.paasage.eu/2015/06/camel/organisation' from 'platform:/resource/org.xtext.paasage.model/model/camel.genmodel'
3512 [main] INFO clipse.emf.mwe.utils.GenModelHelper - Registered GenModel 'http://www.paasage.eu/2015/06/camel/provider' from 'platform:/resource/org.xtext.paasage.model/model/camel.genmodel'
3512 [main] INFO clipse.emf.mwe.utils.GenModelHelper - Registered GenModel 'http://www.paasage.eu/2015/06/camel/requirement' from 'platform:/resource/org.xtext.paasage.model/model/camel.genmodel'
3512 [main] INFO clipse.emf.mwe.utils.GenModelHelper - Registered GenModel 'http://www.paasage.eu/2015/06/camel/scalability' from 'platform:/resource/org.xtext.paasage.model/model/camel.genmodel'
3512 [main] INFO clipse.emf.mwe.utils.GenModelHelper - Registered GenModel 'http://www.paasage.eu/2015/06/camel/security' from 'platform:/resource/org.xtext.paasage.model/model/camel.genmodel'
3512 [main] INFO clipse.emf.mwe.utils.GenModelHelper - Registered GenModel 'http://www.paasage.eu/2015/06/camel/type' from 'platform:/resource/org.xtext.paasage.model/model/camel.genmodel'
3512 [main] INFO clipse.emf.mwe.utils.GenModelHelper - Registered GenModel 'http://www.paasage.eu/2015/06/camel/unit' from 'platform:/resource/org.xtext.paasage.model/model/camel.genmodel'
4231 [main] INFO text.xtext.generator.XtextGenerator - Initializing Xtext generator
4234 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Adding generated EPackage 'org.eclipse.xtext.common.types.TypesPackage'
4298 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - Skipping conflicting project org.eclipse.emf.cdo at 'archive:file:/C:/Users/tk78/.gradle/caches/modules-2/files-2.1/org.eclipse.emf/cdo_4.3.0/v20140520-1823/c91081e7ed38605b91aea68dc96c3f50c9c12888/cdo_4.3.0-v20140520-1823.jar!/' and using 'archive:file:/C:/Users/tk78/.m2/repository/org/eclipse/emf/cdo_4.3.0/v20140520-1823/cdo_4.3.0-v20140520-1823.jar!/' instead.
4300 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - Skipping conflicting project org.eclipse.emf.cdo.common at 'archive:file:/C:/Users/tk78/neonCAMELeditorWeb/org.xtext.paasage.model.parent/org.xtext.paasage.model/build/resources/main/common_4.3.0-v20140309-0644.jar!/' and using 'archive:file:/C:/Users/tk78/.gradle/caches/modules-2/files-2.1/org.eclipse.emf.cdo/common_4.3.0/v20140309-0644/a4144abb21923590ebd793471a6762584701f722/common_4.3.0-v20140309-0644.jar!/' instead.
4315 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - Skipping conflicting project org.eclipse.emf.cdo at 'archive:file:/C:/Users/tk78/.m2/repository/org/eclipse/emf/cdo_4.3.0/v20140520-1823/cdo_4.3.0-v20140520-1823.jar!/' and using 'archive:file:/C:/Users/tk78/.gradle/caches/modules-2/files-2.1/org.eclipse.emf/cdo_4.3.0/v20140520-1823/c91081e7ed38605b91aea68dc96c3f50c9c12888/cdo_4.3.0-v20140520-1823.jar!/' instead.
4329 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - Skipping conflicting project antlr at 'archive:file:/C:/Users/tk78/.gradle/caches/modules-2/files-2.1/antlr/antlr/2.7.7/83cd2cd674a217ade95a4bb83a8a14f351f48bd0/antlr-2.7.7.jar!/' and using 'archive:file:/C:/Users/tk78/.gradle/caches/modules-2/files-2.1/org.antlr/antlr-runtime/3.2/31c746001016c6226bd7356c9f87a6a084ce3715/antlr-runtime-3.2.jar!/' instead.
4340 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - Skipping conflicting project antlr at 'archive:file:/C:/Users/tk78/.gradle/caches/modules-2/files-2.1/org.antlr/antlr-runtime/3.2/31c746001016c6226bd7356c9f87a6a084ce3715/antlr-runtime-3.2.jar!/' and using 'archive:file:/C:/Users/tk78/.gradle/caches/modules-2/files-2.1/org.xtext/antlr-generator/3.2.1/d3fa97d931949af341889c94f6455822674e52f2/antlr-generator-3.2.1.jar!/' instead.
4344 [main] WARN lipse.emf.mwe.utils.StandaloneSetup - Skipping conflicting project antlr at 'archive:file:/C:/Users/tk78/.gradle/caches/modules-2/files-2.1/org.xtext/antlr-generator/3.2.1/d3fa97d931949af341889c94f6455822674e52f2/antlr-generator-3.2.1.jar!/' and using 'archive:file:/C:/Users/tk78/.gradle/caches/modules-2/files-2.1/antlr/antlr/2.7.7/83cd2cd674a217ade95a4bb83a8a14f351f48bd0/antlr-2.7.7.jar!/' instead.
4352 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Registering project org.xtext.paasage.model at 'file:/C:/Users/tk78/neonCAMELeditorWeb/org.xtext.paasage.model.parent/org.xtext.paasage.model/'
4355 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Registering project org.xtext.paasage.model.tests at 'file:/C:/Users/tk78/neonCAMELeditorWeb/org.xtext.paasage.model.parent/org.xtext.paasage.model.tests/'
4355 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Registering project org.xtext.paasage.model.ide at 'file:/C:/Users/tk78/neonCAMELeditorWeb/org.xtext.paasage.model.parent/org.xtext.paasage.model.ide/'
4356 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Registering project org.xtext.paasage.model.ui at 'file:/C:/Users/tk78/neonCAMELeditorWeb/org.xtext.paasage.model.parent/org.xtext.paasage.model.ui/'
4356 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Registering project org.xtext.paasage.model.ui.tests at 'file:/C:/Users/tk78/neonCAMELeditorWeb/org.xtext.paasage.model.parent/org.xtext.paasage.model.ui.tests/'
4357 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Registering project org.xtext.paasage.model.idea at 'file:/C:/Users/tk78/neonCAMELeditorWeb/org.xtext.paasage.model.parent/org.xtext.paasage.model.idea/'
4358 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Registering project org.xtext.paasage.model.web at 'file:/C:/Users/tk78/neonCAMELeditorWeb/org.xtext.paasage.model.parent/org.xtext.paasage.model.web/'
4374 [main] INFO lipse.emf.mwe.utils.StandaloneSetup - Using resourceSet registry. The registered Packages will not be registered in the global EPackage.Registry.INSTANCE!
4606 [main] INFO clipse.emf.mwe.utils.GenModelHelper - Registered GenModel 'http://www.eclipse.org/Xtext/Xbase/XAnnotations' from 'platform:/resource/org.eclipse.xtext.xbase/model/Xbase.genmodel'
4610 [main] INFO clipse.emf.mwe.utils.GenModelHelper - Registered GenModel 'http://www.eclipse.org/xtext/xbase/Xtype' from 'platform:/resource/org.eclipse.xtext.xbase/model/Xbase.genmodel'
4625 [main] INFO clipse.emf.mwe.utils.GenModelHelper - Registered GenModel 'http://www.eclipse.org/xtext/xbase/Xbase' from 'platform:/resource/org.eclipse.xtext.xbase/model/Xbase.genmodel'
4625 [main] INFO clipse.emf.mwe.utils.GenModelHelper - Registered GenModel 'http://www.eclipse.org/xtext/common/JavaVMTypes' from 'platform:/resource/org.eclipse.xtext.common.types/model/JavaVMTypes.genmodel'
8485 [main] INFO text.xtext.generator.XtextGenerator - Generating org.xtext.paasage.model.Camel
124850 [main] INFO text.xtext.generator.XtextGenerator - Generating common infrastructure
124867 [main] ERROR mf.mwe2.launch.runtime.Mwe2Launcher - Problems running workflow org.xtext.paasage.model.GenerateCamel:
[ERROR]: GeneratorException: (Element: -UNKNOWN-; Reported by: XtextGenerator)
java.io.IOException: invalid header field
at java.util.jar.Attributes.read(Attributes.java:406)
at java.util.jar.Manifest.read(Manifest.java:199)
at org.eclipse.xtext.util.MergeableManifest.<init>(MergeableManifest.java:186)
at org.eclipse.xtext.util.MergeableManifest.<init>(MergeableManifest.java:195)
at org.eclipse.xtext.xtext.generator.XtextGenerator.mergeManifest(XtextGenerator.java:393)
at org.eclipse.xtext.xtext.generator.XtextGenerator.generateManifests(XtextGenerator.java:365)
at org.eclipse.xtext.xtext.generator.XtextGenerator.invokeInternal(XtextGenerator.java:217)
at org.eclipse.emf.mwe.core.lib.AbstractWorkflowComponent.invoke(AbstractWorkflowComponent.java:126)
at org.eclipse.emf.mwe.core.lib.Mwe2Bridge.invoke(Mwe2Bridge.java:34)
at org.eclipse.emf.mwe.core.lib.AbstractWorkflowComponent.invoke(AbstractWorkflowComponent.java:201)
at org.eclipse.emf.mwe2.runtime.workflow.AbstractCompositeWorkflowComponent.invoke(AbstractCompositeWorkflowComponent.java:35)
at org.eclipse.emf.mwe2.runtime.workflow.Workflow.run(Workflow.java:19)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:102)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:62)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:52)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.run(Mwe2Launcher.java:78)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.main(Mwe2Launcher.java:36)

java.lang.RuntimeException: Problems running workflow org.xtext.paasage.model.GenerateCamel:
[ERROR]: GeneratorException: (Element: -UNKNOWN-; Reported by: XtextGenerator)
java.io.IOException: invalid header field
at java.util.jar.Attributes.read(Attributes.java:406)
at java.util.jar.Manifest.read(Manifest.java:199)
at org.eclipse.xtext.util.MergeableManifest.<init>(MergeableManifest.java:186)
at org.eclipse.xtext.util.MergeableManifest.<init>(MergeableManifest.java:195)
at org.eclipse.xtext.xtext.generator.XtextGenerator.mergeManifest(XtextGenerator.java:393)
at org.eclipse.xtext.xtext.generator.XtextGenerator.generateManifests(XtextGenerator.java:365)
at org.eclipse.xtext.xtext.generator.XtextGenerator.invokeInternal(XtextGenerator.java:217)
at org.eclipse.emf.mwe.core.lib.AbstractWorkflowComponent.invoke(AbstractWorkflowComponent.java:126)
at org.eclipse.emf.mwe.core.lib.Mwe2Bridge.invoke(Mwe2Bridge.java:34)
at org.eclipse.emf.mwe.core.lib.AbstractWorkflowComponent.invoke(AbstractWorkflowComponent.java:201)
at org.eclipse.emf.mwe2.runtime.workflow.AbstractCompositeWorkflowComponent.invoke(AbstractCompositeWorkflowComponent.java:35)
at org.eclipse.emf.mwe2.runtime.workflow.Workflow.run(Workflow.java:19)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:102)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:62)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:52)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.run(Mwe2Launcher.java:78)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.main(Mwe2Launcher.java:36)

at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:104)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:62)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:52)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.run(Mwe2Launcher.java:78)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.main(Mwe2Launcher.java:36)
Caused by: java.lang.RuntimeException:
[ERROR]: GeneratorException: (Element: -UNKNOWN-; Reported by: XtextGenerator)
java.io.IOException: invalid header field
at java.util.jar.Attributes.read(Attributes.java:406)
at java.util.jar.Manifest.read(Manifest.java:199)
at org.eclipse.xtext.util.MergeableManifest.<init>(MergeableManifest.java:186)
at org.eclipse.xtext.util.MergeableManifest.<init>(MergeableManifest.java:195)
at org.eclipse.xtext.xtext.generator.XtextGenerator.mergeManifest(XtextGenerator.java:393)
at org.eclipse.xtext.xtext.generator.XtextGenerator.generateManifests(XtextGenerator.java:365)
at org.eclipse.xtext.xtext.generator.XtextGenerator.invokeInternal(XtextGenerator.java:217)
at org.eclipse.emf.mwe.core.lib.AbstractWorkflowComponent.invoke(AbstractWorkflowComponent.java:126)
at org.eclipse.emf.mwe.core.lib.Mwe2Bridge.invoke(Mwe2Bridge.java:34)
at org.eclipse.emf.mwe.core.lib.AbstractWorkflowComponent.invoke(AbstractWorkflowComponent.java:201)
at org.eclipse.emf.mwe2.runtime.workflow.AbstractCompositeWorkflowComponent.invoke(AbstractCompositeWorkflowComponent.java:35)
at org.eclipse.emf.mwe2.runtime.workflow.Workflow.run(Workflow.java:19)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:102)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:62)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:52)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.run(Mwe2Launcher.java:78)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.main(Mwe2Launcher.java:36)

at org.eclipse.emf.mwe.core.lib.Mwe2Bridge.handleIssues(Mwe2Bridge.java:56)
at org.eclipse.emf.mwe.core.lib.Mwe2Bridge.invoke(Mwe2Bridge.java:48)
at org.eclipse.emf.mwe.core.lib.AbstractWorkflowComponent.invoke(AbstractWorkflowComponent.java:201)
at org.eclipse.emf.mwe2.runtime.workflow.AbstractCompositeWorkflowComponent.invoke(AbstractCompositeWorkflowComponent.java:35)
at org.eclipse.emf.mwe2.runtime.workflow.Workflow.run(Workflow.java:19)
at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:102)
... 4 more
:org.xtext.paasage.model:generateXtextLanguage FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':org.xtext.paasage.model:generateXtextLanguage'.
> Process 'command 'C:\Program Files\Java\jdk1.8.0_45\bin\java.exe'' finished with non-zero exit value 1

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 2 mins 9.672 secs

Anybody, any ideas?

Thanks,
Tom

[Updated on: Wed, 14 September 2016 16:56]

Report message to a moderator

Re: Register EPackage probelm "Couldn't find an interface" [message #1743384 is a reply to message #1743378] Wed, 14 September 2016 18:43 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13887
Registered: July 2009
Senior Member
did you try to debug this?
did you have a look at the existing MANIFEST.MF file if it is broken?
can you share a reproducable example?


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Register EPackage probelm "Couldn't find an interface" [message #1743485 is a reply to message #1743384] Thu, 15 September 2016 20:15 Go to previous messageGo to next message
tom KIRKHAM is currently offline tom KIRKHAMFriend
Messages: 16
Registered: August 2016
Junior Member
Hi Christian,

The error was caused by me. i had deleted some files trying to get to the bottom of the original error in relation to the ePackage registering.

I am currently deploying the editor as a war and see if I get the same error. If so I will change the contents of the war until I find the cause. Will keep you posted.

Thanks,
Tom
Re: Register EPackage probelm "Couldn't find an interface" [message #1743490 is a reply to message #1743485] Thu, 15 September 2016 21:06 Go to previous messageGo to next message
tom KIRKHAM is currently offline tom KIRKHAMFriend
Messages: 16
Registered: August 2016
Junior Member
Hi Christian,

Still no joy I keep getting the register epackage problem. I dont know if it could be a bug, if you have time here is my project https://fs11n2.sendspace.com/dl/9293784ec69f1ee4669d6113ef67e5bc/57db0da137172e12/i066lz/test.zip

Thanks,
Tom
Re: Register EPackage probelm "Couldn't find an interface" [message #1743499 is a reply to message #1743490] Fri, 16 September 2016 04:51 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13887
Registered: July 2009
Senior Member
Hi,

this code seems to be a big mess. could not get it running as it is a very wild mix of gradle and eclipse stuff.
thus i can have only a look at the code.

what i saw is that you dont override

class CamelStandaloneSetup extends CamelStandaloneSetupGenerated {

	def static void doSetup() {
		new CamelStandaloneSetup().createInjectorAndDoEMFRegistration()
	}
	
	override register(Injector injector) {
		if (!EPackage.Registry.INSTANCE.containsKey(CamelPackage.eNS_URI)) {
			EPackage.Registry.INSTANCE.put(CamelPackage.eNS_URI, CamelPackage.eINSTANCE);
		} //maybe you have to register the subpackages as well
		super.register(injector)
	}
	
}




Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Register EPackage probelm "Couldn't find an interface" [message #1743538 is a reply to message #1743499] Fri, 16 September 2016 09:28 Go to previous messageGo to next message
tom KIRKHAM is currently offline tom KIRKHAMFriend
Messages: 16
Registered: August 2016
Junior Member
Hi Christian,

Thanks for the reply. I have added the code and eclipse flagged up the CamelPackage in the editor but it seems to compile. However when running build tests I get this error below, I am going to try and fix it by adding the net4j into the maven. Will let you know how I get on.

Cheers,
Tom

org.eclipse.xtext.parser.ParseException: java.lang.NoClassDefFoundError: org/eclipse/net4j/util/options/IOptionsContainer
at org.eclipse.xtext.parser.antlr.AbstractAntlrParser.doParse(AbstractAntlrParser.java:105)
at org.eclipse.xtext.parser.antlr.AbstractAntlrParser.parse(AbstractAntlrParser.java:84)
at org.eclipse.xtext.parser.antlr.AbstractAntlrParser.doParse(AbstractAntlrParser.java:62)
Re: Register EPackage probelm "Couldn't find an interface" [message #1743540 is a reply to message #1743538] Fri, 16 September 2016 09:35 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13887
Registered: July 2009
Senior Member
seems you claspath is still not correct (the cdo part)

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Register EPackage probelm "Couldn't find an interface" [message #1743549 is a reply to message #1743540] Fri, 16 September 2016 10:00 Go to previous messageGo to next message
tom KIRKHAM is currently offline tom KIRKHAMFriend
Messages: 16
Registered: August 2016
Junior Member
Hi, I added the requested files and I now get this error on build Caused by: java.lang.NoSuchMethodError: antlr.TokenStreamRewriteEngine.size()I

Will let you know if I find a solution

Cheers,
Tom
Re: Register EPackage probelm "Couldn't find an interface" [message #1743551 is a reply to message #1743549] Fri, 16 September 2016 10:13 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13887
Registered: July 2009
Senior Member
Looks like wrong antlr version

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: Register EPackage probelm "Couldn't find an interface" [Solved] [message #1744189 is a reply to message #1743551] Fri, 23 September 2016 09:48 Go to previous message
tom KIRKHAM is currently offline tom KIRKHAMFriend
Messages: 16
Registered: August 2016
Junior Member
Hi Christian,

Thanks for the help. I have now got the Web UI for my DSL working. The advice above was great here are the main pointers (for anybody who else has similar problems) that I have taken from my experience.

1. Add the code above into the standalone section
1a. add standalone into the mwe workflow i.e.
Workflow {
bean = StandaloneSetup {
scanClassPath = true
platformUri = "${rootPath}/.."
1b make sure the genmodel is referenced after that in the worlflow
registerGenModelFile = "platform:/resource/org.xtext.stfc.paasage/model/camel.genmodel"
/
1c also include the ecore model in the worklfow in the Standard language bit.
language = StandardLanguage {
name = "org.xtext.stfc.paasage.CamelEdit"
fileExtensions = "camel"
referencedResource = "platform:/resource/org.xtext.stfc.paasage/model/camel.ecore"
1d I commented out the fragmentAdapter lines
2. Add the org.eclipse.emf.mwe.core,\ to bundle
3. My DSL had lots of dependancies that caused the errors i.e. no proxy ...... They were added using Maven repos into the gradle buildscript (see below)
4. They brought in Antlr2 libs in the .m2 and ,gradle folders which I had to remove, they also brought in other dependencies which had to be resolved.

Thanks,
Tom

repositories {
maven { url "http://repository.ow2.org/nexus/content/repositories/snapshots" }
maven { url "http://jenkins.paasage.cetic.be/repository"}
maven { url "https://mvnrepository.com/artifact/org.apache.logging.log4j/log4j-core"}
maven { url "http://repository.ow2.org/nexus/content/repositories/snapshots/"}
// maven { url "http://central.maven.org/maven2/org/"}
}

dependencies {
//compile group: 'antlr', name: 'antlr', version: '3.2'
compile group: 'org.ow2.paasage.mddb.cdo', name: 'camel-cdo-storage', version: '2016.4.0-SNAPSHOT'
compile group: 'org.ow2.paasage', name: 'camel', version: '2015.9.1-SNAPSHOT'
//compile group: 'org.eclipselabs', name: 'net4j.p2', version: '4.4.0'
compile group: 'org.eclipse.emf.cdo', name: 'common_4.3.0', version: 'v20140309-0644'

}


Previous Topic:DSL Textual Model to Z Notation conversion?
Next Topic:Xtext double hash comment
Goto Forum:
  


Current Time: Tue Apr 20 14:42:50 GMT 2021

Powered by FUDForum. Page generated in 0.02520 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top