Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » How to integrate CSV with Eclipse 4.2.1(Source Control)
How to integrate CSV with Eclipse 4.2.1 [message #1742823] Wed, 07 September 2016 22:35 Go to next message
Olan Knight is currently offline Olan KnightFriend
Messages: 2
Registered: September 2016
Junior Member
Windows 7, 32 bit o/s
Eclipse v4.2.1.
Java 1.6u45
Source control is QVCS, which I've been using for years with PowerBuilder.

-------------------
Background:
I've used Eclipse off an on over the last few years, but my primary development tool is PowerBuilder, so while I can use Eclipse, I am pretty much a rank amateur with it. I stick to the functions I know and leave everything else alone.

~~~~~~~~~~~~~~~~~~~~~~~~
Issue:
I want to integrate my QVCS with my Eclipse, but I cannot find one single helpful document online.

My research SEEMS to indicate that I'll need org.eclipse.cvs and possibly org.eclipse.cvs.source, but I've no idea how to go about integrating them into the Eclipse IDE OR how to get the repository to point to my QVCS repository.

HELP!!!

Thanks In Advance!

Re: How to integrate CSV with Eclipse 4.2.1 [message #1742827 is a reply to message #1742823] Wed, 07 September 2016 23:17 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3413
Registered: July 2009
Senior Member

You would install it from the Juno update site. Go to the Help menu and choose to Install New Software... If the update site http://download.eclipse.org/releases/juno/ is not in the dropdown, add it, and then type "CVS" into the filter box.

Like so:
http://i.imgur.com/dAvyoA0l.png


Nitin Dahyabhai
Eclipse Web Tools Platform
Re: How to integrate CSV with Eclipse 4.2.1 [message #1742960 is a reply to message #1742827] Thu, 08 September 2016 21:46 Go to previous message
Olan Knight is currently offline Olan KnightFriend
Messages: 2
Registered: September 2016
Junior Member
Thank you so much for your reply!

!. I did as you asked, but had a bit of difficulty in figuring out how to proceed.

2. Figured it out after restarting Eclipse, and was able to select the "Eclipse CVS Client" under "Collaberation" (the search option did nothing.

3. Clicked the NEXT button to proceed.

4. Ended up with this error:
Your original request has been modified.
"Eclipse CVS Client" is already installed, so an update will be performed instead.
Cannot complete the install because of a conflicting dependency.
Software being installed: Eclipse CVS Client 1.3.201.v20130116-085741-7B79FJKAkF7BG7ODH5CAJT (org.eclipse.cvs.feature.group 1.3.201.v20130116-085741-7B79FJKAkF7BG7ODH5CAJT)
Software currently installed: Eclipse SDK 4.2.1.M20120914-1800 (org.eclipse.sdk.ide 4.2.1.M20120914-1800)
Only one of the following can be installed at once:
Eclipse CVS Client 1.3.200.v20120525-1249-7B79FJJAkF7BF7VEH5IAJT (org.eclipse.cvs.feature.jar 1.3.200.v20120525-1249-7B79FJJAkF7BF7VEH5IAJT)
Eclipse CVS Client 1.3.201.v20130116-085741-7B79FJKAkF7BG7ODH5CAJT (org.eclipse.cvs.feature.jar 1.3.201.v20130116-085741-7B79FJKAkF7BG7ODH5CAJT)
Cannot satisfy dependency:
From: Eclipse CVS Client 1.3.200.v20120525-1249-7B79FJJAkF7BF7VEH5IAJT (org.eclipse.cvs.feature.group 1.3.200.v20120525-1249-7B79FJJAkF7BF7VEH5IAJT)
To: org.eclipse.cvs.feature.jar [1.3.200.v20120525-1249-7B79FJJAkF7BF7VEH5IAJT]
Cannot satisfy dependency:
From: Eclipse CVS Client 1.3.201.v20130116-085741-7B79FJKAkF7BG7ODH5CAJT (org.eclipse.cvs.feature.group 1.3.201.v20130116-085741-7B79FJKAkF7BG7ODH5CAJT)
To: org.eclipse.cvs.feature.jar [1.3.201.v20130116-085741-7B79FJKAkF7BG7ODH5CAJT]
Cannot satisfy dependency:
From: Eclipse Project SDK 4.2.1.v20120814-120134-7T7oDODQ-3Heq-afCDlg7T4xJuvxaC2ohMfCfB5451Rz0 (org.eclipse.sdk.feature.group 4.2.1.v20120814-120134-7T7oDODQ-3Heq-afCDlg7T4xJuvxaC2ohMfCfB5451Rz0)
To: org.eclipse.cvs.feature.group [1.3.200.v20120525-1249-7B79FJJAkF7BF7VEH5IAJT]
Cannot satisfy dependency:
From: Eclipse SDK 4.2.1.M20120914-1800 (org.eclipse.sdk.ide 4.2.1.M20120914-1800)
To: org.eclipse.sdk.feature.group [4.2.1.v20120814-120134-7T7oDODQ-3Heq-afCDlg7T4xJuvxaC2ohMfCfB5451Rz0]

5. Now the first error listed is ""Eclipse CVS Client" is already installed,". Which I do not believe.
I went into Project/Properties/....and examined the Libraries and the "Order & Export" windows. No CVS jar file or anything.
Then I clicked the ADD JARS and the ADD EXTERNAL JARS looking for the CVS jar file. Still nothing.

6. What did I do wrong?
Previous Topic:Text cursor won't move to input (using PyDev)?
Next Topic:New To Eclipse!
Goto Forum:
  


Current Time: Mon Jun 17 02:00:15 GMT 2019

Powered by FUDForum. Page generated in 0.03080 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top