Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » neon nightmare
neon nightmare [message #1742309] Thu, 01 September 2016 15:36 Go to next message
Greg Watson is currently offline Greg WatsonFriend
Messages: 114
Registered: July 2009
Senior Member
Hi,

I'm a long time Eclipse user, but since Neon (Eclipse IDE for Eclipse Committers) I've been having all sorts of problems. I have a complex workspace with multiple projects from multiple git repos. I won't go into all the issues here, but the main two I'm having at the moment are:

1. Although I've set an API baseline, Eclipse is telling me that a many APIs are missing @since tags. This doesn't make sense, since many of these APIs have been around for a year or more.

2. Eclipse seems override plugins in my workspace with those it obtains from a target definition. The "Target Platform State" view shows both plugins, but it is the one with the *lower* version that is being used (since I'm getting errors against the new APIs).

Please tell me how to get Eclipse to do sensible things with the API baseline and target definition!

Thanks,
Greg
Re: neon nightmare [message #1759775 is a reply to message #1742309] Tue, 18 April 2017 03:56 Go to previous message
philipp huebner is currently offline philipp huebnerFriend
Messages: 48
Registered: July 2009
Member
I'd suggest to switch to something professional
Previous Topic:Tycho version 0.23.1 showing error in Eclipse IDE Indigo 3.7
Next Topic:Getting the Parent View of a control.
Goto Forum:
  


Current Time: Fri Sep 21 13:22:57 GMT 2018

Powered by FUDForum. Page generated in 0.01562 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top