Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » Switching Eclipse Neon to use a more recent version of SWT
Switching Eclipse Neon to use a more recent version of SWT [message #1741504] Thu, 25 August 2016 14:35
Robert Munteanu is currently offline Robert MunteanuFriend
Messages: 30
Registered: July 2009
Member
Hi,

I am running Eclipse Neon on openSUSE Linux. As luck would have it, some GTK 3 fixes arrived too late to be added to this release, so I need a more recent version of SWT.

However, just adding the update site and trying to update SWT does not work. Here's what I did:

- Added the 4.7 stream update site to Eclipse: http://download.eclipse.org/eclipse/updates/4.7-I-builds/
- Opened the Install dialog and selected Eclipse Platform 4.7.0.I20160824-1429
- Pressed Next

At this point the progress bar indicated that it 'Cannot perform operation. Computing alternate solutions, may take a while'.

After that I'm presented with a screenshot which suggests that I need to uninstall parts of my IDE - not sure how much it will uninstall since 'Eclipse IDE for Java Developers' brings in a large number of features.

How can I update my Eclipse Neon instance to a newer version of SWT?

Thanks,

Robert

(Note: also posted at http://stackoverflow.com/questions/38556080/switching-eclipse-neon-to-use-a-more-recent-version-of-swt )
Previous Topic: Switching Eclipse Neon to use a more recent version of SWT
Next Topic: Switching Eclipse Neon to use a more recent version of SWT
Goto Forum:
  


Current Time: Sat Dec 16 18:56:06 GMT 2017

Powered by FUDForum. Page generated in 0.01643 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software