Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » RichTextEditor in Tomcat runs only in development mode(RichTextEditor in a Tomcat-deployed standalone RAP-Application runs only with -Dorg.eclipse.rap.rwt.developmentMode=true set)
RichTextEditor in Tomcat runs only in development mode [message #1741426] Thu, 25 August 2016 04:46 Go to next message
Frank Jakop is currently offline Frank JakopFriend
Messages: 5
Registered: July 2016
Junior Member
I'm checking the new RichTextEditor feature in RAP 3.1. I've built a simple demo project which consists only of an EntryPoint adding a RichTextEditor-Widget.
When I access the webapp's url it works fine when I set CATALINA_OPTS=-Dorg.eclipse.rap.rwt.developmentMode=true.
Without this option the webapp produces a strange error
Error: Error: Operation "call" on target "rwt.client.ClientFileLoader" of type "null" failed:
Cannot read property 'handler' of undefined
Properties: 
file = rwt-resources/ckeditor/ckeditor.js
type = js


  Script: {"head":{"cid":"03fb7d47"},"operations":[["call","rwt.client.ClientFileLoader","load",{"file":"rwt-resources/ckeditor/ckeditor.js","type":"js"}],["call","rwt.client.ClientFileLoader","load",{"file":"rwt-resources/ckeditor/config.js","type":"js"}],["call","rwt.client.ClientFileLoader","load",{"file":"rwt-resources/ckeditor/RichTextEditor.js","type":"js"}],["call","rwt.client.ClientFileLoader","load",{"file":"rwt-resources/ckeditor/RichTextEditorHandler.js","type":"js"}],["create","w2","rwt.widgets.Shell",{"style":["NO_TRIM"]}],["listen","w2",{"Move":true,"Resize":true,"Activate":true,"Close":true}],["set","w2",{"active":true,"mode":"maximized","minimumSize":[30,0],"activeControl":"w3","children":["w3"],"bounds":[0,0,1920,1031],"visibility":true}],["create","w3","rwt.widgets.Composite",{"parent":"w2","style":["NONE"],"children":[],"bounds":[0,0,1920,1031],"tabIndex":1,"clientArea":[0,0,1920,1031]}],["set","w1",{"focusControl":"w3"}],["set","rwt.client.ClientMessages",{"messages":{"ServerError":"Server Error","ServerErrorDescription":"The application terminated unexpectedly.","ConnectionError":"Network Error","ConnectionErrorDescription":"The server seems to be temporarily unavailable.","SessionTimeout":"Session Timeout","SessionTimeoutDescription":"The server session timed out.","ClientError":"Client Error","ClientErrorDescription":"The application terminated unexpectedly.","Retry":"Retry","Restart":"Restart","Details":"Details"}}],["create","r4","rwt.widgets.RichTextEditor",{"parent":"w3","config":{"toolbarGroups":[{"name":"basicstyles","groups":["basicstyles","cleanup"]},{"name":"paragraph","groups":["list","indent","align"]},"/",{"name":"styles"},{"name":"colors"}],"removeButtons":",PasteText,PasteFromWord,Styles,Format","toolbarCanCollapse":false,"toolbarStartupExpanded":true}}]]}
  Stack: Error: Operation "call" on target "rwt.client.ClientFileLoader" of type "null" failed:
Cannot read property 'handler' of undefined
Properties: 
file = rwt-resources/ckeditor/ckeditor.js
type = js

    at Object._processError (http://localhost:8080/webtest/rwt-resources/310/rap-client.js:225:3803)
    at Object.processOperationArray (http://localhost:8080/webtest/rwt-resources/310/rap-client.js:225:920)
    at Object.processMessage (http://localhost:8080/webtest/rwt-resources/310/rap-client.js:225:249)
    at _handleSuccess (http://localhost:8080/webtest/rwt-resources/310/rap-client.js:229:3428)
    at Object._success (http://localhost:8080/webtest/rwt-resources/310/rap-client.js:98:1012)
    at Object._onReadyStateChange (http://localhost:8080/webtest/rwt-resources/310/rap-client.js:98:1821)
    at XMLHttpRequest. (http://localhost:8080/webtest/rwt-resources/310/rap-client.js:7:219)
  Debug: off
  Request: {"head":{"requestCounter":0},"operations":[["set","w1",{"bounds":[0,0,1920,1031],"dpi":[96,96],"colorDepth":24}],["set","rwt.client.ClientInfo",{"timezoneOffset":-120}],["set","w1",{"cursorLocation":[0,0]}]]}


I've attached a demo maven project, just unzip and run mvn package, then deploy the War in your Tomcat.
Accessing "/webtest/start" yields the error.
Now set your CATALINA_OPTS to -Dorg.eclipse.rap.rwt.developmentMode=true and restart the Tomcat, everything is fine.

Has anyone an idea what's amiss here?
Re: RichTextEditor in Tomcat runs only in development mode [message #1742576 is a reply to message #1741426] Mon, 05 September 2016 12:03 Go to previous message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2285
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
This issue was invalid and the corresponding bug has been closed.
Previous Topic:Styling for RAP Eclipse 4 port
Next Topic:Mouse wheel scroll speed in tables
Goto Forum:
  


Current Time: Tue Aug 21 19:37:04 GMT 2018

Powered by FUDForum. Page generated in 0.01544 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top