Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » API Baseline Activation fails
API Baseline Activation fails [message #1741397] Wed, 24 August 2016 17:31 Go to next message
Patrick-Jeffrey Pollo Guilbert is currently offline Patrick-Jeffrey Pollo GuilbertFriend
Messages: 6
Registered: January 2016
Junior Member
Hi, on my Ubuntu 14.04 using Java 1.8.74 64 bits, any setup file that has an APIBaselineTask fails during the installation. I tried installing Eclipse Neon with the Oomph setup file and I got the following error :

Performing Mylyn Builds https://hudson.eclipse.org/oomph (org.eclipse.mylyn.hudson)
Performing API Baseline, activate
java.lang.NullPointerException
  at org.eclipse.oomph.setup.util.DownloadUtil.downloadURL(DownloadUtil.java:45)
  at org.eclipse.oomph.setup.pde.impl.APIBaselineTaskImpl.downloadAndUnzip(APIBaselineTaskImpl.java:424)
  at org.eclipse.oomph.setup.pde.impl.APIBaselineTaskImpl.perform(APIBaselineTaskImpl.java:388)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3021)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.access$1(SetupTaskPerformer.java:2964)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil$1.run(SetupTaskPerformer.java:4160)
  at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2240)
  at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2267)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.performNeededSetupTasks(SetupTaskPerformer.java:4154)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.access$0(SetupTaskPerformer.java:4152)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:2955)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:2930)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:2861)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9.run(ProgressPage.java:555)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$11$1.run(ProgressPage.java:681)
  at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

Took 26 seconds.
There are failed tasks.
Press Back to choose different settings or Cancel to abort.


Any idea where and why this could be failing? It used to work fine some time ago. I'm also using the latest Oomph installer with no updates available.
Re: API Baseline Activation fails [message #1741403 is a reply to message #1741397] Wed, 24 August 2016 19:21 Go to previous message
Patrick-Jeffrey Pollo Guilbert is currently offline Patrick-Jeffrey Pollo GuilbertFriend
Messages: 6
Registered: January 2016
Junior Member
Upon further investigating this was caused by my user setup having an error with an empty Baseline task... My bad!
Previous Topic:Mirror update sites referenced in setup
Next Topic:Trying to figure Oomph Out - how to use it
Goto Forum:
  


Current Time: Tue Apr 07 04:54:11 GMT 2020

Powered by FUDForum. Page generated in 0.01471 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top