Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Installing Eclipse on MacBook Pro(Can't find newly downloaded JDK or JRE)
Installing Eclipse on MacBook Pro [message #1741054] Mon, 22 August 2016 14:33 Go to next message
Norman Paterson is currently offline Norman PatersonFriend
Messages: 2
Registered: August 2016
Junior Member
I've just installed Eclipse 3.7.2 on my MacBook Pro running OSX 10.9.5. I chose 3.7.2 because I want also to use Eclipse on my iMac which runs OSX 10.6.8, and Eclipse 3.7.2 was recommended - I forget where. The Eclipse workspace is shared on DropBox.

I've worked through the Workbench User Guide to the Java Development User Guide, as far as Preparing Eclipse. The Macs come with JRE 1.6. The advice in Preparing Eclipse is to install SDK 1.4 as well as the latest one.

I was getting nowhere trying to find a suitable download of 1.4 so I decided to skip that for the moment and install the latest which is 1.8, with both the JRE and the JDK. (Advice on where to find 1.4 for the Mac appreciated!)

I downloaded both JRE and JDK from Oracle and installed them on the MacBook Pro without any problem. Now, I can do this on Terminal:

normans-mbp-2:~ norman$ java -version
java version "1.8.0_102"
Java(TM) SE Runtime Environment (build 1.8.0_102-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.102-b14, mixed mode)
normans-mbp-2:~ norman$ 


And this:

normans-mbp-2:~ norman$ ls -l /Library/Java/JavaVirtualMachines/
total 0
drwxr-xr-x  3 root  wheel  102 21 Aug 21:38 jdk1.8.0_102.jdk
normans-mbp-2:~ norman$ 


I have no reason to suppose anything is wrong with these - no error messages for example. But I can't get Eclipse to find them. I go to Eclipse/Preferences/Java/Installed JREs. "Java SE 6 (Mac OS X Default)" is the only one listed. I note that it is installed in /System/Library, not /Library - but nothing about that was offered as an option during installation.

The help text says "Additional SDKs can be added by searching the hard drive for installed SDKs. To do so, simply click the Search... button and specify a root folder for the search." But there is nowhere to specify a root folder. If I click Search, a window opens and closes too quickly to read, but seeming to report the progress of the search. Nothing changes in the "Installed JREs" table.

I've tried restarting Eclipse, tried restarting the Mac, and sacrificed 2 goats, with no joy.

My questions are:
1. What do I need to do to have Java 8 show up in the Installed JREs table?
2. And where can I find a Java 1.4 for the Mac?

I see Mac installation has come up before, but not recently. Apologies if I have missed a reply that deals with it. Thanks for your help.
Re: Installing Eclipse on MacBook Pro [message #1741217 is a reply to message #1741054] Tue, 23 August 2016 19:01 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3422
Registered: July 2009
Senior Member

It's possible that 3.7.2, being so old, does not recognize 1.8 as a valid version. It was the first to support being run by 1.7 IIRC. Failing that, there should still be an Add button.

Nitin Dahyabhai
Eclipse Web Tools Platform
Previous Topic:Need Photran and Java IDE
Next Topic:JPA validation error in Eclipse Neon JPA persistence.xml
Goto Forum:
  


Current Time: Thu Jun 27 02:20:02 GMT 2019

Powered by FUDForum. Page generated in 0.02608 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top