Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » e(fx)clipse » Possibly wrong dependency on EMF Edit (in 2.4 release)
Possibly wrong dependency on EMF Edit (in 2.4 release) [message #1740330] Thu, 11 August 2016 17:06
SWT Wasserhardt is currently offline SWT WasserhardtFriend
Messages: 3
Registered: May 2016
Junior Member
Hello,

I found (https://www.eclipse.org/forums/index.php/t/1079053/) that the latest stable release of e(fx)clipse (2.4.0) is based on MARS.1 Eclipse release.

The "Target Platform Feature" ships some of the MARS.1 plugins. The included version of org.eclipse.emf.edit is 2.10.1.v20150123-042 whereas all MARS releases (in the official MARS repo) have 2.11.0 or higher versions.

I suppose this is a mistake, but maybe it's expected for some reason...
As it's a singleton plugins, there could be conflicts with other features based on MARS which depends on org.eclipse.emf.edit.

A workaround is to use the org.eclipse.fx.runtime.e4fx.feature that does not ship org.eclipse.emf.edit 2.10, and add the 2.11 version from the MARS repository.
This worked for me.

Even if it's not in bugzilla, this post may help some people.

Cheers,
Stephane
Previous Topic:How to start unit testing
Next Topic:How do I tell AdapterFactoryObservableList which feature of the root object to use?
Goto Forum:
  


Current Time: Sat May 27 00:28:57 GMT 2017

Powered by FUDForum. Page generated in 0.02234 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software