Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Model Driven Health Tools » Support for JDK1.6(Support for JDK1.6 - CDA 2.1 and CDA 1.1 libraries)
Support for JDK1.6 [message #1740186] Wed, 10 August 2016 08:42 Go to next message
nm anand is currently offline nm anandFriend
Messages: 4
Registered: August 2016
Junior Member
Hello,

We are using JDK1.6 runtime environment, but seems like the latest consol1 and consol2 jars need 1.7 environment. Are there 1.6 compatible libraries?

I am trying to use the following:

https://github.com/mdht/mdht-models/releases/tag/v2.5.16.20160725_Consol2

https://github.com/mdht/mdht-models/releases/tag/v2.5.8.20160323_Consol1

Thanks,
Anand
Re: Support for JDK1.6 [message #1740206 is a reply to message #1740186] Wed, 10 August 2016 12:55 Go to previous messageGo to next message
Sean Muir is currently offline Sean MuirFriend
Messages: 52
Registered: September 2015
Member
Is there specific a reason you can not upgrade to 1.7 at least 1.8 preferred ?
It is the easier approach

I do not believe we have any 1.7 or greater specific java code

The method we would follow is to create a profile for the maven build
This would need to be done for both the core and models


Are you familiar with maven ?

Thanks

Sean


Re: Support for JDK1.6 [message #1740208 is a reply to message #1740206] Wed, 10 August 2016 13:06 Go to previous messageGo to next message
nm anand is currently offline nm anandFriend
Messages: 4
Registered: August 2016
Junior Member
Sean

Due to complexity of our product, we won't be able to upgrade to 1.7 or higher.

I am not familiar with maven as we are using ANT internally.

It would really be helpful if you can provide the 1.6 compatible libraries of the releases I mentioned earlier.

Thanks in advance
Narinder
Re: Support for JDK1.6 [message #1740223 is a reply to message #1740186] Wed, 10 August 2016 14:29 Go to previous message
Dan Brown is currently offline Dan BrownFriend
Messages: 19
Registered: December 2015
Junior Member
There is nothing recent avaialable for JDK1.6. If you or someone wanted to spend the time, I don't think it would be too much work to produce though.
Previous Topic:Generating EMF from FHIR artifacts
Next Topic:XSI/Template Processing
Goto Forum:
  


Current Time: Wed Sep 19 09:26:32 GMT 2018

Powered by FUDForum. Page generated in 0.01798 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top