Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » eRCP » Upgraded RCP to Neon cannot launch with @noDefault(Looking for ways to get @nodefault working in neon.)
Upgraded RCP to Neon cannot launch with @noDefault [message #1739956] Sat, 06 August 2016 00:07
Sally Rich is currently offline Sally RichFriend
Messages: 3
Registered: July 2009
Junior Member
we have a 3.x based rcp running compatibility fine in 4.5.1 since that came out. I upgraded to neon to try it out and am unable to launch. we launch with @nodefault for instance location as we allow our user to pick from various servers and then set the instancelocation programatically based on their selection. If I set the location to something arbitrary we launch fine, but then of course we can't set the workspace programatically because of the inability to 'change' the workspace once it is set.

The ResourcePlugin appears to now need the instancelocation set before it used to (just guessing):
ResourcesPlugin.start throws an exception
Caused by: java.lang.IllegalStateException: The instance data location has not been specified yet.

Looking for ways to get @nodefault working again if anyone has any idea.


Caused by: org.osgi.framework.BundleException: Exception in org.eclipse.core.resources.ResourcesPlugin.start() of bundle org.eclipse.core.resources.
at org.eclipse.osgi.internal.framework.BundleContextImpl.startActivator(BundleContextImpl.java:795)
at org.eclipse.osgi.internal.framework.BundleContextImpl.start(BundleContextImpl.java:724)
at org.eclipse.osgi.internal.framework.EquinoxBundle.startWorker0(EquinoxBundle.java:932)
at org.eclipse.osgi.internal.framework.EquinoxBundle$EquinoxModule.startWorker(EquinoxBundle.java:309)
at org.eclipse.osgi.container.Module.doStart(Module.java:581)
at org.eclipse.osgi.container.Module.start(Module.java:449)
at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:470)
at org.eclipse.osgi.internal.hooks.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:107)
... 43 more
Caused by: java.lang.IllegalStateException: The instance data location has not been specified yet.
at org.eclipse.core.internal.runtime.DataArea.assertLocationInitialized(DataArea.java:54)
at org.eclipse.core.internal.runtime.DataArea.getStateLocation(DataArea.java:124)
at org.eclipse.core.internal.runtime.InternalPlatform.getStateLocation(InternalPlatform.java:539)
at org.eclipse.core.runtime.Plugin.getStateLocation(Plugin.java:289)
at org.eclipse.core.internal.resources.LocalMetaArea.<init>(LocalMetaArea.java:59)
at org.eclipse.core.resources.ResourcesPlugin.start(ResourcesPlugin.java:456)
at org.eclipse.osgi.internal.framework.BundleContextImpl$3.run(BundleContextImpl.java:774)
at org.eclipse.osgi.internal.framework.BundleContextImpl$3.run(BundleContextImpl.java:1)
at java.security.AccessController.doPrivileged(Native Method)
at org.eclipse.osgi.internal.framework.BundleContextImpl.startActivator(BundleContextImpl.java:767)
Previous Topic:How to test the "accessibility phrase"
Next Topic:Eclipse e4 application does not start in Java Web start
Goto Forum:
  


Current Time: Thu Nov 15 21:49:10 GMT 2018

Powered by FUDForum. Page generated in 0.02220 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top