Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » EMF Neon problem(Unable to build a working run configuration with Neon EMF.)
EMF Neon problem [message #1739525] Tue, 02 August 2016 16:45 Go to next message
Rick Borgen is currently offline Rick BorgenFriend
Messages: 3
Registered: August 2016
Junior Member
I have a substantial EMF application (> 40 classes) that runs under Eclipse Mars. Am trying to port to Eclipse Neon without success.

The models and code were exported from the old setup and imported into a fresh Eclipse Neon installation on a Centos machine. Attempted to build a run configuration in the usual way. In the Plugins tab, I deselected all of the selections, selected the editor, and clicked "Validate Plug-ins". The validation fails for org.eclipse..e4.ui.workbench.swt with the message:

Missing Constraint: Require Capability: osgi.extender; filter=" (&(osgi.extender=osgi.component)(version >1.2)(!(version>2.0)))"

What does this mean?

An attempt on a Mac runs into the same problem.
Re: EMF Neon problem [message #1739551 is a reply to message #1739525] Tue, 02 August 2016 20:17 Go to previous messageGo to next message
Rick Borgen is currently offline Rick BorgenFriend
Messages: 3
Registered: August 2016
Junior Member
a brief addition... I also did the usual "Add Required Plug-ins" prior to "Validate Plug-ins".
Re: EMF Neon problem [message #1739570 is a reply to message #1739525] Wed, 03 August 2016 05:38 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30451
Registered: July 2009
Senior Member
Rick,

This problem sounds familiar. I assume that in your Run configuration
you've selectively included only certain plugins and/or features, not
just all available ones from the workspace and target platform. I
suspect this problem is related to org.eclipse.equinox.ds not being in
your Run Configuration (because for testing the Oomph installer with a
Neon target platform, that's exactly the error I see when I don't
include that bundle). I also have to manually add
org.eclipse.equinox.event or I get runtime failures; but that might just
be something we need in the installer because we use
org.eclipse.equinox.p2.* and listen to its event bus.

If I look at the text of my launch configuration I end up with this
extra entry:

<setEntry
value="org.eclipse.equinox.ds:1.4.400.v20160226-2036:default:true"/>

And somehow this was not an issue (wasn't needed) for a Mars target
platform. I'm not sure why.


On 02.08.2016 20:46, Rick Borgen wrote:
> I have a substantial EMF application (> 40 classes) that runs under
> Eclipse Mars. Am trying to port to Eclipse Neon without success.
>
> The models and code were exported from the old setup and imported into
> a fresh Eclipse Neon installation on a Centos machine. Attempted to
> build a run configuration in the usual way. In the Plugins tab, I
> deselected all of the selections, selected the editor, and clicked
> "Validate Plug-ins". The validation fails for
> org.eclipse..e4.ui.workbench.swt with the message:
>
> Missing Constraint: Require Capability: osgi.extender; filter="
> (&(osgi.extender=osgi.component)(version >1.2)(!(version>2.0)))"
>
> What does this mean?
>
> An attempt on a Mac runs into the same problem.
Re: EMF Neon problem [message #1739674 is a reply to message #1739570] Wed, 03 August 2016 16:43 Go to previous messageGo to next message
Rick Borgen is currently offline Rick BorgenFriend
Messages: 3
Registered: August 2016
Junior Member
Thanks much Ed!

Adding in org.eclipse.equinox.ds (just checking the box) and then one more run of "Add Required Plug-ins" made the Validator happy. Then I was able to run the application successfully. For my app, there was no need for org.eclipse.equinox.event.

--Rick

[Updated on: Wed, 03 August 2016 21:24]

Report message to a moderator

Re: EMF Neon problem [message #1771696 is a reply to message #1739674] Tue, 29 August 2017 15:43 Go to previous messageGo to next message
Michael Glass is currently offline Michael GlassFriend
Messages: 1
Registered: August 2017
Junior Member
Thanks for this thread!

The issue is still live. I just migrated a sizable project which started 2011 from using Neon to using Oxygen and ran into these very issues. Applying the usual updates to product and run configurations etc. did not fix it.

Then, adding "org.eclipse.equinox.ds" made the validator happy AND further adding "org.eclipse.equinox.event" fixed the ton of runtime errors. It is really hard to know and find.

Cheers,
Michael
Re: EMF Neon problem [message #1793491 is a reply to message #1739525] Thu, 09 August 2018 07:11 Go to previous messageGo to next message
Alexander Till is currently offline Alexander TillFriend
Messages: 4
Registered: August 2018
Junior Member
I had the same problem, additionally to "org.eclipse.equinox.ds" I had to add the plugin "org.eclipse.equinox.util" to get an clean validation and startup.
Re: EMF Neon problem [message #1803612 is a reply to message #1793491] Tue, 05 March 2019 12:49 Go to previous messageGo to next message
Missing name Mising name is currently offline Missing name Mising nameFriend
Messages: 3
Registered: December 2011
Junior Member
Thank you for this life saving thread.
I have no idea how you're supposed to figure out this answer from the reported problem.
All this is way too arcane and mysterious.
Re: EMF Neon problem [message #1803617 is a reply to message #1803612] Tue, 05 March 2019 14:55 Go to previous message
Ed Willink is currently offline Ed WillinkFriend
Messages: 6457
Registered: July 2009
Senior Member
Hi

Beware org.eclipse.equinox.ds has a new nightmare, and I don't think it finishes until 2018-12.

org.eclipse.equinox.ds was a redundant plugin except that it was what started org.apache.flex.scr. The platform removed the dead org.eclipse.equinox.ds orphaning everything that used it to start felix. Tycho 1.3.0 was slow to provide the compatible behaviour. Some projects therefore added a 'missing' import which solved the problem in 2018-09 but created a new where-is-org.eclipse.equinox.ds problem in 2018-12. Hopefully everything has now settled down. If you have added any org.eclipse.equinox.ds dependencies, remove them, or at least change them to optional. But if optional you will have to apologize to Tycho.

See https://bugs.eclipse.org/bugs/show_bug.cgi?id=539655

Regards

Ed Willink

Previous Topic:Unable to update the URI fragment of proxy element on Edapt Migration
Next Topic:[EMFStore] Performance Measure
Goto Forum:
  


Current Time: Thu Sep 19 08:45:22 GMT 2019

Powered by FUDForum. Page generated in 0.01996 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top