Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Toolbar focus has different behavior than SWT
Toolbar focus has different behavior than SWT [message #1739437] Mon, 01 August 2016 12:33 Go to next message
Nicola  Zanaga is currently offline Nicola ZanagaFriend
Messages: 52
Registered: July 2009
Member
In RAP, a toolbar always get focus regardless of options.
In SWT, in a toolbar with no option, it's automatically added "SWT.NO_FOCUS" option (see Toolbar.checkStyle in SWT). However, it's legal to manually add "SWT.NO_FOCUS" option.

In RAP the no focus options it's ignored, and you always can get focus on toolbar.
Here the snippet (pressing tab toolbar get focus):

        Shell shell = new Shell(display);

        Composite c = new Composite(shell, SWT.NONE);
        c.setBounds(0, 0, 400, 500);
        Text t = new Text(c, SWT.BORDER);
        t.setBounds(0, 0, 400, 400);
        ToolBar b = new ToolBar(c, SWT.FLAT | SWT.NO_FOCUS);
        b.setBounds(0, 400, 400, 100);
        ToolItem toolItem = new ToolItem(b, SWT.NONE);
        toolItem.setImage(Display.getDefault().getSystemImage(SWT.ICON_INFORMATION));

        shell.open();
Re: Toolbar focus has different behavior than SWT [message #1739583 is a reply to message #1739437] Wed, 03 August 2016 07:01 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2277
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi Nicola,
please file a bugzilla and we will look on it as soon as possible.
Regards,
Ivan

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Toolbar focus has different behavior than SWT [message #1739593 is a reply to message #1739583] Wed, 03 August 2016 07:56 Go to previous message
Nicola  Zanaga is currently offline Nicola ZanagaFriend
Messages: 52
Registered: July 2009
Member
Bug:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=499085
Previous Topic:Key event listener and active keys: clear active keys doesn't work
Next Topic:Badge and style
Goto Forum:
  


Current Time: Mon May 28 07:38:49 GMT 2018

Powered by FUDForum. Page generated in 0.01985 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top