Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » Very basic question to first use of EEF
Very basic question to first use of EEF [message #1738762] Sat, 23 July 2016 08:47 Go to next message
graf huy is currently offline graf huyFriend
Messages: 1
Registered: July 2016
Junior Member
Hello !

When creating a ecore modeling project, I can't generate code with EEF plug-in installed: errors are build.properties does not exist.

Manifest.mf seems ok with the required set environment, warning is no more.

How can i generate this build.properties file ? Searching on the internet says you must generate (code) model (???) to have it built automatically?

Thank you.


*eclipse neon EMF
*java jre 1.8 installed
*lastest EMF and ecore librairies on neon
Re: Very basic question to first use of EEF [message #1738927 is a reply to message #1738762] Tue, 26 July 2016 07:58 Go to previous message
HN Hindriks is currently offline HN HindriksFriend
Messages: 6
Registered: July 2016
Junior Member
Usually when generating code, you use a GenModel This website explains it.
The GenModel is able to generate code for plugins, and also generates a build.properties file along with that.

Edit: I noticed that the website I linked doesn't mention how to obtain a genmodel. In eclipse, you can do this by right-clicking the project folder, and selecting new->other->EMF Generative Model

[Updated on: Tue, 26 July 2016 08:00]

Report message to a moderator

Previous Topic:Manual invocation of proxy resolution required?
Next Topic:How to correctly save cross-referenced models to XMI
Goto Forum:
  


Current Time: Sat Jun 19 10:50:51 GMT 2021

Powered by FUDForum. Page generated in 0.01405 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top