Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Values of stereotype attributes not shown
Values of stereotype attributes not shown [message #1738444] Tue, 19 July 2016 23:09
Roman Wirtz is currently offline Roman WirtzFriend
Messages: 2
Registered: July 2015
Junior Member
Dear all,

I defined an UML Profile in Papyrus with different Stereotypes for classes. These stereotypes consists of attributes that have primitive types (String, Real, Integer,..) as values, as well as other stereotypes.

After applying these stereotypes in a class diagram, I can set all values for the attributes.
But when I try to show the attributes in a comment or in the compartment, the values for the attributes with the primitive types are not shown. Just the name of the attribute is shown. The attributes that have a stereotype as type are shown normally with name + value.

I tried this several times with the latest version of Eclipse Mars and Papyrus. Today, I tried this with Eclipse Neon but it doesn't work.

Is this a general problem with Papyrus or what am I doing wrong?

Thanks for your help and best regards,
Roman
Previous Topic:Providing default style for notation element
Next Topic:Return-type multiplicity field is empty
Goto Forum:
  


Current Time: Fri Jul 03 15:06:30 GMT 2020

Powered by FUDForum. Page generated in 0.01395 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top