Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » 4DIAC - Framework for Distributed Industrial Automation and Control » flip-flop tutorial: No RMT_DEV available in 4DIAC IDE (4DIAC IDE doesn't offer "RMT_DEV" in "Palette")
flip-flop tutorial: No RMT_DEV available in 4DIAC IDE [message #1737869] Wed, 13 July 2016 15:35 Go to next message
Gudrun Schuchmann is currently offline Gudrun SchuchmannFriend
Messages: 3
Registered: July 2016
Junior Member
Hi,

I am a total newbie to 4DIAC IDE so I am doing my first steps working through the Flip-Flop Tutorial.

https://www.eclipse.org/4diac/documentation/html/tutorials/flipFlop_tutorial.html

At the step "Adding a Device" - unfortunately - there is no "RMT_DEV" in the "Devices" list of the "Palette" that I could choose. My entries are:

BeagleBoneBlack
FBRT_WINDOW
FORTE_PC
PFC200
Raspberry PI

Below the last item (Raspberry PI) there is a list of blank items.

I continued with the tutorial choosing "Forte_PC" instead but at substep 7. of "Adding a Device" I was not able to access the parameters of "MGR_ID".

My questions:
1. Where is "RMT_DEV" in my settings (- importable?)?
2. Alternative device in the list above to continue the tutorial?
3. How to access the parameters of "MGR_ID" - to accurately configure the Device's parameter values?

Any assistance is appreciated



Gudrun



Re: flip-flop tutorial: No RMT_DEV available in 4DIAC IDE [message #1737979 is a reply to message #1737869] Thu, 14 July 2016 15:50 Go to previous messageGo to next message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 615
Registered: January 2014
Senior Member
Hi,

With the latest versions of 4diac we have replaced the generic devices (i.e., RMT_DEV, RMT_FRAME) with more concrete ones. With FORTE_PC you have chosen the correct one to replace the RMT_DEV. FBRT_WINDOW would be the one replacing the RMT_FRAME. Unfortunately we haven't updated the tutorials yet.

There was a Bug in 4diac-ide 1.8 RC1 that device parameters were not selectable any more [1]. This should have been fixed and available in 4diac-ide 1.8 RC2. If not please let us know. You can still access this value as a workaround by selecting the device and edit the value in the property view shown below the System configuration editor.

I hope this helps.

BR,
Alois


[1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=495646
Re: flip-flop tutorial: No RMT_DEV available in 4DIAC IDE [message #1738087 is a reply to message #1737979] Fri, 15 July 2016 16:04 Go to previous messageGo to next message
Gudrun Schuchmann is currently offline Gudrun SchuchmannFriend
Messages: 3
Registered: July 2016
Junior Member
Hi,

"by selecting the device and edit the value in the property view shown below the System configuration editor."

worked Smile

Many thanks for the quick reply Smile


Best regards


Gudrun
Re: flip-flop tutorial: No RMT_DEV available in 4DIAC IDE [message #1738149 is a reply to message #1738087] Sat, 16 July 2016 09:15 Go to previous messageGo to next message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 615
Registered: January 2014
Senior Member
Hi,

great. Just for completeness: By double clicking or slow double clicking on the parameter value in the system configuration editor you should be able to directly edit the parameter in the system configuration editor.

May I ask which 4diac-ide version you are using?

BR,
Alois
Re: flip-flop tutorial: No RMT_DEV available in 4DIAC IDE [message #1738527 is a reply to message #1738149] Wed, 20 July 2016 14:36 Go to previous messageGo to next message
Gudrun Schuchmann is currently offline Gudrun SchuchmannFriend
Messages: 3
Registered: July 2016
Junior Member
Hi,


" May I ask which 4diac-ide version you are using?"

4DIAC-IDE_1.8RC1_linux.gtk.x86_64
FORTE_1.8_RC1

on a Fedora Linux system.

I hope that answers your question.

Thanks for your interest and best regards


Gudrun
Re: flip-flop tutorial: No RMT_DEV available in 4DIAC IDE [message #1738535 is a reply to message #1738527] Wed, 20 July 2016 15:29 Go to previous message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 615
Registered: January 2014
Senior Member
Thx for the info. Yes that answers my question. I just wanted to be sure that the bug you mention has not reappeared in a newer version.

Alois
Previous Topic:Basic FB as Event Source
Next Topic:FORTE terminate when pressing "Launch local FORTE"
Goto Forum:
  


Current Time: Wed Aug 15 12:41:11 GMT 2018

Powered by FUDForum. Page generated in 0.02181 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top