Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Setting a Korean -Duser.name in eclipse.ini
icon5.gif  Setting a Korean -Duser.name in eclipse.ini [message #1736854] Sun, 03 July 2016 11:25 Go to next message
Pa Sm is currently offline Pa SmFriend
Messages: 1
Registered: July 2016
Junior Member
Hello,

I'm trying to set a Korean Hangul user.name in the eclipse.ini for the purpose of setting the @author parameter for the JavaDoc source comment template.

I've tried:

1. eclipse.ini saved as UTF-8
Ex:
-vmargs
-Dfile.encoding=UTF-8
-Duser.name=홍길동


This results in:
/**
 * @author �길�
 *
 */


2. eclipse.ini saved as UTF-8 BOM
Same results as above.

3. eclipse.ini saved as ANSI
Results in:
/**
 * @author ???
 *
 */


4. Escaped unicode

-Duser.name=\uD64D\uAE38\uB3D9


Displays as literal:
/**
 * @author \uD64D\uAE38\uB3D9
 *
 */



A fellow co-worker has his eclipse.ini setup with Korean characters and they display fine in his templates. Confused

Any suggestions are appreciated
Re: Setting a Korean -Duser.name in eclipse.ini [message #1736929 is a reply to message #1736854] Mon, 04 July 2016 12:06 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 30467
Registered: July 2009
Senior Member
I believe the eclipse.ini is read with system default encoding and while
you try to set that to UTF-8, until that file itself is read, it's
probably not UTF-8.


On 04.07.2016 01:18, Pa Sm wrote:
> Hello,
>
> I'm trying to set a Korean Hangul user.name in the eclipse.ini for the
> purpose of setting the @author parameter for the JavaDoc source
> comment template.
>
> I've tried:
>
> 1. eclipse.ini saved as UTF-8
> Ex:
> -vmargs
> -Dfile.encoding=UTF-8
> -Duser.name=홍길동
>
>
> This results in:
> /**
> * @author �길�
> *
> */
>
> 2. eclipse.ini saved as UTF-8 BOM
> Same results as above.
>
> 3. eclipse.ini saved as ANSI Results in:
> /**
> * @author ???
> *
> */
>
> 4. Escaped unicode
>
> -Duser.name=\uD64D\uAE38\uB3D9
>
> Displays as literal:
> /**
> * @author \uD64D\uAE38\uB3D9
> *
> */
>
>
> A fellow co-worker has his eclipse.ini setup with Korean characters
> and they display fine in his templates. :?
> Any suggestions are appreciated
Previous Topic:eclipse-jee-mars-R-win32-x86_64
Next Topic:Overriding standard commands
Goto Forum:
  


Current Time: Mon Sep 23 11:48:27 GMT 2019

Powered by FUDForum. Page generated in 0.03870 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top