Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » e(fx)clipse » Target Platform(Target Platform missing required bundles)
Target Platform [message #1736846] Sat, 02 July 2016 23:01 Go to next message
Henri Boucher is currently offline Henri BoucherFriend
Messages: 40
Registered: September 2015
Member
I've followed tutorial4 and created the following target:

http://download.eclipse.org/efxclipse/runtime-released/2.4.0/site/ 29 plug-ins available
RCP e4 Target Platform Feature 2.4.0.201605121035

After making the target Active only 3 items show up in Package Explorer - Plug-in Dependencies:

org.eclipse.fx.ide.css.jfx8_2.4.0....
jfxswt.jar
org.eclipse.fx.ui.di.interopt_2.4.0...

and all the Require-Bundle items, with the exception of interopt are flagged as "cannot be resolved" in MANIFEST.MF.

I have had this work in the past. Any ideas? Can you reproduce this?

I have found that if I select "Current Target: Copy settings from the current target Platform" in the Target Definition dialog everything works (java-neon/eclipse - 635 plug-ins available). Of course this in not very desirable.

Henri
Re: Target Platform [message #1736878 is a reply to message #1736846] Mon, 04 July 2016 07:06 Go to previous message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 6363
Registered: July 2009
Senior Member
Well what require-bundles do you have there?

The e4 target platform feature only has the e(fx)clipse bundles, it does
not contain the e4 platform.

Tom

On 03.07.16 01:01, Henri Boucher wrote:
> I've followed tutorial4 and created the following target:
>
> http://download.eclipse.org/efxclipse/runtime-released/2.4.0/site/ 29
> plug-ins available
> RCP e4 Target Platform Feature 2.4.0.201605121035
>
> After making the target Active only 3 items show up in Package Explorer
> - Plug-in Dependencies:
>
> org.eclipse.fx.ide.css.jfx8_2.4.0....
> jfxswt.jar
> org.eclipse.fx.ui.di.interopt_2.4.0...
>
> and all the Require-Bundle items, with the exception of interopt are
> flagged as "cannot be resolved" in MANIFEST.MF.
>
> I have had this work in the past. Any ideas? Can you reproduce this?
>
> I have found that if I select "Current Target: Copy settings from the
> current target Platform" in the Target Definition dialog everything
> works (java-neon/eclipse - 635 plug-ins available). Of course this in
> not very desirable.
>
> Henri
Previous Topic:Trying to setup target platform, but tutorial isn't working
Next Topic:Eclipse Neon 4.6.0 with E(fx)clipse 2.4.0 not working
Goto Forum:
  


Current Time: Sun Nov 19 14:23:47 GMT 2017

Powered by FUDForum. Page generated in 0.02142 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software