Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » OM2M » Running mn-cse in virtual machine.
Running mn-cse in virtual machine. [message #1736633] Thu, 30 June 2016 16:41 Go to next message
Trung Luu is currently offline Trung LuuFriend
Messages: 32
Registered: June 2016
Member
Hi all, i'm trying to run the IN-CSE in my computer running Windows and the MN-CSE in a Virtual Machine running Linux OS. I configured the CseBase IP and CseRemote IP according to the IP of the computer and the VM. However, the MN-CSE cannot register in the IN-CSE. I ask if anyone used to do this task for help. Thank you.
Re: Running mn-cse in virtual machine. [message #1736701 is a reply to message #1736633] Fri, 01 July 2016 09:06 Go to previous messageGo to next message
Guillaume Garzone is currently offline Guillaume GarzoneFriend
Messages: 38
Registered: April 2015
Member
Hello Trung Luu,

The IN must be able to reach the ip:port of the MN and the MN must be able to reach the ip:port of your IN.
Could you check if you can ping (or whatever) each node from the VM and the Windows side?

Regards,
Guillaume
Re: Running mn-cse in virtual machine. [message #1736781 is a reply to message #1736701] Fri, 01 July 2016 16:31 Go to previous messageGo to next message
Trung Luu is currently offline Trung LuuFriend
Messages: 32
Registered: June 2016
Member
I tried to run IN-CSE and MN-CSE in different Virtual Machine and it work. But between real PC and VM, it can ping the IP of the another but the request is still not sent. I don't know what the problem is. Thanks for your help.
Re: Running mn-cse in virtual machine. [message #1736940 is a reply to message #1736781] Mon, 04 July 2016 13:30 Go to previous messageGo to next message
Guillaume Garzone is currently offline Guillaume GarzoneFriend
Messages: 38
Registered: April 2015
Member
Hello,
Can you try to run both IN and MN on your real PC to be sure that there is not a hidden issue there?
Regards,
Guillaume
Re: Running mn-cse in virtual machine. [message #1737214 is a reply to message #1736940] Wed, 06 July 2016 12:55 Go to previous messageGo to next message
Mahdi Ben Alaya is currently offline Mahdi Ben AlayaFriend
Messages: 227
Registered: November 2013
Senior Member
Hello,
Trung, please tell us if Guillaume remark helped you to solve your issue otherwise give us more details.
Re: Running mn-cse in virtual machine. [message #1737222 is a reply to message #1737214] Wed, 06 July 2016 13:08 Go to previous messageGo to next message
Trung Luu is currently offline Trung LuuFriend
Messages: 32
Registered: June 2016
Member
Hello,

I ran both IN and MN in my PC and it works perfectly, it happen so when I run both on Virtual Machine Linux Debian. But when I run 1 of them in my real PC and 1 in Virtual Machine, the request from MN cannot be sent to IN. I'm sorry for late reply.

Best Regards,

Re: Running mn-cse in virtual machine. [message #1737250 is a reply to message #1737222] Wed, 06 July 2016 15:43 Go to previous messageGo to next message
Mahdi Ben Alaya is currently offline Mahdi Ben AlayaFriend
Messages: 227
Registered: November 2013
Senior Member
I think you need to open required ports on your machines. E.g. 8080 to reach the IN.
Re: Running mn-cse in virtual machine. [message #1737251 is a reply to message #1737250] Wed, 06 July 2016 15:44 Go to previous messageGo to next message
Trung Luu is currently offline Trung LuuFriend
Messages: 32
Registered: June 2016
Member
Dear Mahdi,
it works now, thanks for fast support.
Best Regards,

Trung
Re: Running mn-cse in virtual machine. [message #1737253 is a reply to message #1737251] Wed, 06 July 2016 15:46 Go to previous message
Mahdi Ben Alaya is currently offline Mahdi Ben AlayaFriend
Messages: 227
Registered: November 2013
Senior Member
Happy it is working for you.
I will try to help you on the other issue.

Mahdi

[Updated on: Wed, 06 July 2016 15:48]

Report message to a moderator

Previous Topic:Create your own Plugin
Next Topic:Trouble with dependencies
Goto Forum:
  


Current Time: Mon Sep 24 05:54:40 GMT 2018

Powered by FUDForum. Page generated in 0.02278 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top