Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » OM2M » Lifecycle error after cloning project from git repository(Lifecycle error)
Lifecycle error after cloning project from git repository [message #1736364] Tue, 28 June 2016 20:59 Go to next message
Son Duong is currently offline Son DuongFriend
Messages: 60
Registered: June 2016
Member
Hi all,

I follow the instructions in the website to get the om2m. And after cloning the om2m project fom the Git repository, all of the files I have got the lifecycle errors: "Cannot read lifecycle mapping metadata for artifact org.apache.maven.plugins:mav". Can anyone have an idea how to solve this problem. I used eclipse luna rcp and also got maven 3.3.9 and installed Tycho Project Configurators.

https://s32.postimg.org/46onq0lg5/image.jpg
https://s32.postimg.org/xk8kn3eo5/image.jpg


Thank you!
Re: Lifecycle error after cloning project from git repository [message #1736699 is a reply to message #1736364] Fri, 01 July 2016 09:00 Go to previous message
Guillaume Garzone is currently offline Guillaume GarzoneFriend
Messages: 38
Registered: April 2015
Member
Hello Son Duong,

OM2M uses maven and tycho to build the projects. I think this issue is due to a miss of tycho in your ide: be sure to check & install the tycho maven plugin. This should solve your issue:
https://wiki.eclipse.org/OM2M/one/Clone#Install_Tycho_plugin

Regards,
Guillaume
Previous Topic:The question about Data storage in IN and MN
Next Topic:Why the ID of lamp sample is 30??
Goto Forum:
  


Current Time: Wed Sep 26 06:44:29 GMT 2018

Powered by FUDForum. Page generated in 0.02399 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top