Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » OM2M » Add a new plugin in OM2M (without Eclipse)
Add a new plugin in OM2M (without Eclipse) [message #1735758] Wed, 22 June 2016 13:37 Go to next message
Can LIU is currently offline Can LIUFriend
Messages: 29
Registered: May 2016
Junior Member
Hi guys,

Recently, I am trying to add my java project in OM2M, which runs in Raspberry Pi.
I write a java project in my PC and i installed successfully OM2M on Raspberry Pi with command lines(No eclipse in my Raspberry Pi).
After followed the tutorial in the website, i realized that we need eclipse to add a new plugin in OM2M.
My question is that it's is possible to add a new plugin in OM2M just with command lines? or you have some other advice for me to run my java project in OM2M on Raspberry Pi?

Thanks in advance and hope you have a good day!

Can
Re: Add a new plugin in OM2M (without Eclipse) [message #1735895 is a reply to message #1735758] Thu, 23 June 2016 13:01 Go to previous messageGo to next message
Francois AissaouiFriend
Messages: 38
Registered: April 2015
Member
Hi,

Quick answer will be yes, but difficult.

In fact, if you want to use the OM2M build procedure to integrate your plugin like in the wiki tutorial, you have to create a specific folder structure for maven, write the pom.xml file, the MANIFEST.mf file and then your java code and so on.
So yes you can write every thing with vim (or whatever is your favorite command line text editor) or, and much simpler, you can make the development on your computer and create some scripts to push directly your code on the raspberry pi after the compilation (as the "mvn install" operation is quite slow on raspberry pi, and can use a lot of memory for the maven repository, it is preferable to compile on your computer).

Regards,
Fran├žois
Re: Add a new plugin in OM2M (without Eclipse) [message #1740454 is a reply to message #1735895] Sat, 13 August 2016 07:44 Go to previous messageGo to next message
Yu-Hao Hsu is currently offline Yu-Hao HsuFriend
Messages: 15
Registered: July 2016
Junior Member
Hi,

I also met the same problem.
I want to run new plugin like in the wiki tutorial in my raspberry pi.
What I tried is I add the new plugin using eclipse in my computer, and then I move the whole om2m project to my raspberry pi.
Finally I run $ mvn clean install on my raspberry pi.

But now I met some error , the below is the error message after I tpe mvn clean install:

[ERROR] Failed to execute goal org.eclipse.tycho:tycho-compiler-plugin:0.20.0:compile (default-compile) on project org.eclipse.om2m.sample.ipe: Fatal error compiling: target level should be comprised in between '1.1' and '1.7' (or '5', '5.0', ..., '7' or '7.0') or cldc1.1: 1.8 -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
[ERROR]
[ERROR] After correcting the problems, you can resume the build with the command
[ERROR] mvn <goals> -rf :org.eclipse.om2m.sample.ipe


Did Anyone try to move the project in the raspberry pi?
Please give me some advice.
Thank you in advance!

Howard
Re: Add a new plugin in OM2M (without Eclipse) [message #1740634 is a reply to message #1740454] Tue, 16 August 2016 13:43 Go to previous message
Can LIU is currently offline Can LIUFriend
Messages: 29
Registered: May 2016
Junior Member
Hi Howard,

I think that you have some version problem in the file pom.xml in your plug-in.


Can

[Updated on: Tue, 16 August 2016 13:48]

Report message to a moderator

Previous Topic:OM2M using COAP Protocol
Next Topic:oneM2M and CoAP
Goto Forum:
  


Current Time: Wed Nov 14 07:38:18 GMT 2018

Powered by FUDForum. Page generated in 0.03146 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top