Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Mylyn Gitlab query not working
Mylyn Gitlab query not working [message #1735496] Mon, 20 June 2016 11:37 Go to next message
Christian Wolff is currently offline Christian WolffFriend
Messages: 18
Registered: April 2016
Junior Member
Hey!

I am using the Mylyn Gitlab Connector (https://marketplace.eclipse.org/content/mylyn-gitlab-connector) to add task repositories to my projects and to create queries. This works without any issues. Now I want to create these queries using Oomphs MylynQueriesTask.

I created the following setup task:

<setupTask
          xsi:type="mylyn:MylynQueriesTask"
          connectorKind="gitlab"
          repositoryURL="https://gitlab.mycompany.de/myprojects/project.git"
          userID="${gitlab.user.login}"
          password="${gitlab.user.password}">
        <query
            summary="project issues"/>
</setupTask>


The task repository and query are visible (created like specified), but executing the query results in a pop-up notification: "Unable to execute Query: Unknown Exception: null".

The only way I found to make a query on this repository work is to create a new query, right-click it => Repository => Properties and then closing the properties window with "Finish". The new query and any query created afterwards will then function as expected. The old query never works (although it stops producing the mentioned exception, it just won't have any children).

What could be the cause for this behaviour? Am I making a mistake?

Thanks in advance
Christian
Re: Mylyn Gitlab query not working [message #1735497 is a reply to message #1735496] Mon, 20 June 2016 11:52 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31048
Registered: July 2009
Senior Member
Christian,

How did you define the variables for gitlab.user.login and
gitlab.user.password? The exception stack trace would help pinpoint
what specifically is null that shouldn't be. It should be available in
the error log (and probably in the setup log). Did you look at other
query tasks to see how they were authored?


On 20.06.2016 07:37, Christian Wolff wrote:
> Hey!
>
> I am using the Mylyn Gitlab Connector
> (https://marketplace.eclipse.org/content/mylyn-gitlab-connector) to
> add task repositories to my projects and to create queries. This works
> without any issues. Now I want to create these queries using Oomphs
> MylynQueriesTask.
> I created the following setup task:
>
>
> <setupTask
> xsi:type="mylyn:MylynQueriesTask"
> connectorKind="gitlab"
> repositoryURL="https://gitlab.mycompany.de/myprojects/project.git"
> userID="${gitlab.user.login}"
> password="${gitlab.user.password}">
> <query
> summary="project issues"/>
> </setupTask>
>
>
> The task repository and query are visible (created like specified),
> but executing the query results in a pop-up notification: "Unable to
> execute Query: Unknown Exception: null".
>
> The only way I found to make a query on this repository work is to
> create a new query, right-click it => Repository => Properties and
> then closing the properties window with "Finish". The new query and
> any query created afterwards will then function as expected. The old
> query never works (although it stops producing the mentioned
> exception, it just won't have any children).
>
> What could be the cause for this behaviour? Am I making a mistake?
>
> Thanks in advance
> Christian
Re: Mylyn Gitlab query not working [message #1735499 is a reply to message #1735497] Mon, 20 June 2016 12:26 Go to previous messageGo to next message
Christian Wolff is currently offline Christian WolffFriend
Messages: 18
Registered: April 2016
Junior Member
Hi Ed,

I defined the variables like this:

      <setupTask
          xsi:type="setup:VariableTask"
          type="PASSWORD"
          name="gitlab.user.password"
          label="Gitlab password for issues"/>
      <setupTask
          xsi:type="setup:VariableTask"
          name="gitlab.user.login"
          label="Gitlab login for issues"/>


Here is the error log
!SESSION 2016-06-20 14:02:41.599 -----------------------------------------------
eclipse.buildId=4.5.2.M20160212-1500
java.version=1.8.0_92
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=de_DE
Framework arguments:  -product org.eclipse.epp.package.jee.product
Command-line arguments:  -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.jee.product -data C:\develop\Workspaces\mycompany_Mars_Test

!ENTRY org.eclipse.jface 2 0 2016-06-20 14:03:01.200
!MESSAGE Keybinding conflicts occurred.  They may interfere with normal accelerator operation.
!SUBENTRY 1 org.eclipse.jface 2 0 2016-06-20 14:03:01.200
!MESSAGE A conflict occurred for ALT+CTRL+T:
Binding(ALT+CTRL+T,
	ParameterizedCommand(Command(org.eclipse.team.svn.ui.command.EditPropertiesCommand,Show Properties,
		,
		Category(org.eclipse.team.svn.ui.command.category,SVN,null,true),
		org.eclipse.ui.internal.WorkbenchHandlerServiceHandler@1a0e5c0c,
		,,true),null),
	org.eclipse.ui.defaultAcceleratorConfiguration,
	org.eclipse.ui.contexts.window,,,system)
Binding(ALT+CTRL+T,
	ParameterizedCommand(Command(org.eclipse.tm.terminal.connector.local.command.launch,Open Local Terminal on Selection,
		,
		Category(org.eclipse.tm.terminal.view.ui.commands.category,Terminal Commands,null,true),
		org.eclipse.ui.internal.WorkbenchHandlerServiceHandler@5bb45afc,
		,,true),null),
	org.eclipse.ui.defaultAcceleratorConfiguration,
	org.eclipse.ui.contexts.window,,,system)

!ENTRY org.eclipse.egit.ui 2 0 2016-06-20 14:03:15.892
!MESSAGE Warning: The environment variable HOME is not set. The following directory will be used to store the Git
user global configuration and to define the default location to store repositories: 'I:\'. If this is
not correct please set the HOME environment variable and restart Eclipse. Otherwise Git for Windows and
EGit might behave differently since they see different configuration options.
This warning can be switched off on the Team > Git > Confirmations and Warnings preference page.

!ENTRY org.eclipse.m2e.logback.appender 4 0 2016-06-20 14:03:31.021
!MESSAGE Unable to update index for public|https://nexus.mycompany.de/nexus/repository/public/: C:\develop\m2_repo\.cache\m2e\1.6.2\dda625bf06e067e7ab3335a28dd06616\nexus-maven-repository-index.zip (Das System kann die angegebene Datei nicht finden)
!STACK 0
java.io.FileNotFoundException: C:\develop\m2_repo\.cache\m2e\1.6.2\dda625bf06e067e7ab3335a28dd06616\nexus-maven-repository-index.zip (Das System kann die angegebene Datei nicht finden)
	at java.io.FileInputStream.open0(Native Method)
	at java.io.FileInputStream.open(FileInputStream.java:195)
	at java.io.FileInputStream.<init>(FileInputStream.java:138)
	at org.apache.maven.index.updater.DefaultIndexUpdater$FileFetcher.retrieve(DefaultIndexUpdater.java:568)
	at org.apache.maven.index.updater.DefaultIndexUpdater.loadIndexDirectory(DefaultIndexUpdater.java:206)
	at org.apache.maven.index.updater.DefaultIndexUpdater.access$300(DefaultIndexUpdater.java:75)
	at org.apache.maven.index.updater.DefaultIndexUpdater$LuceneIndexAdaptor.setIndexFile(DefaultIndexUpdater.java:645)
	at org.apache.maven.index.updater.DefaultIndexUpdater.fetchAndUpdateIndex(DefaultIndexUpdater.java:844)
	at org.apache.maven.index.updater.DefaultIndexUpdater.fetchAndUpdateIndex(DefaultIndexUpdater.java:156)
	at org.eclipse.m2e.core.internal.index.nexus.NexusIndexManager.updateRemoteIndex(NexusIndexManager.java:1140)
	at org.eclipse.m2e.core.internal.index.nexus.NexusIndexManager.updateIndex(NexusIndexManager.java:1084)
	at org.eclipse.m2e.core.internal.index.nexus.NexusIndexManager$1.run(NexusIndexManager.java:656)
	at org.eclipse.m2e.core.internal.index.nexus.IndexUpdaterJob.run(IndexUpdaterJob.java:72)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

!ENTRY org.eclipse.jst.j2ee.core 4 0 2016-06-20 14:03:38.270
!MESSAGE 
!STACK 0
java.lang.InterruptedException
	at org.eclipse.core.internal.jobs.OrderedLock.acquire(OrderedLock.java:112)
	at org.eclipse.jst.j2ee.internal.J2EEInit.aquireInitializePackageContentsLock(J2EEInit.java:454)
	at org.eclipse.jst.j2ee.ejb.internal.impl.EjbPackageImpl.freeze(EjbPackageImpl.java:1757)
	at org.eclipse.jst.j2ee.ejb.internal.impl.EjbPackageImpl.init(EjbPackageImpl.java:325)
	at org.eclipse.jst.j2ee.ejb.EjbPackage.<clinit>(EjbPackage.java:1916)
	at org.eclipse.jst.j2ee.ejb.internal.impl.EjbFactoryImpl.getPackage(EjbFactoryImpl.java:671)
	at org.eclipse.jst.j2ee.internal.provider.J2EEAdapterFactoryLabelProvider.<clinit>(J2EEAdapterFactoryLabelProvider.java:42)
	at org.eclipse.jst.j2ee.navigator.internal.J2EELabelProvider.initialize(J2EELabelProvider.java:57)
	at org.eclipse.jst.j2ee.navigator.internal.J2EELabelProvider.init(J2EELabelProvider.java:246)
	at org.eclipse.ui.internal.navigator.extensions.NavigatorContentExtension$2.run(NavigatorContentExtension.java:156)
	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
	at org.eclipse.ui.internal.navigator.extensions.NavigatorContentExtension.getLabelProvider(NavigatorContentExtension.java:148)
	at org.eclipse.ui.internal.navigator.NavigatorContentServiceLabelProvider.findStyledText(NavigatorContentServiceLabelProvider.java:165)
	at org.eclipse.ui.internal.navigator.NavigatorContentServiceLabelProvider.getStyledText(NavigatorContentServiceLabelProvider.java:153)
	at org.eclipse.ui.internal.navigator.NavigatorDecoratingLabelProvider$StyledLabelProviderAdapter.getStyledText(NavigatorDecoratingLabelProvider.java:63)
	at org.eclipse.jface.viewers.DelegatingStyledCellLabelProvider.getStyledText(DelegatingStyledCellLabelProvider.java:206)
	at org.eclipse.jface.viewers.DecoratingStyledCellLabelProvider.getStyledText(DecoratingStyledCellLabelProvider.java:199)
	at org.eclipse.jface.viewers.DelegatingStyledCellLabelProvider.update(DelegatingStyledCellLabelProvider.java:106)
	at org.eclipse.jface.viewers.DecoratingStyledCellLabelProvider.update(DecoratingStyledCellLabelProvider.java:136)
	at org.eclipse.jface.viewers.ViewerColumn.refresh(ViewerColumn.java:154)
	at org.eclipse.jface.viewers.AbstractTreeViewer.doUpdateItem(AbstractTreeViewer.java:949)
	at org.eclipse.jface.viewers.AbstractTreeViewer$UpdateItemSafeRunnable.run(AbstractTreeViewer.java:114)
	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
	at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:50)
	at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:173)
	at org.eclipse.jface.viewers.AbstractTreeViewer.doUpdateItem(AbstractTreeViewer.java:1029)
	at org.eclipse.jface.viewers.StructuredViewer$UpdateItemSafeRunnable.run(StructuredViewer.java:473)
	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
	at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:50)
	at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:173)
	at org.eclipse.jface.viewers.StructuredViewer.updateItem(StructuredViewer.java:2176)
	at org.eclipse.jface.viewers.AbstractTreeViewer.createTreeItem(AbstractTreeViewer.java:843)
	at org.eclipse.jface.viewers.AbstractTreeViewer.createAddedElements(AbstractTreeViewer.java:347)
	at org.eclipse.jface.viewers.AbstractTreeViewer.internalAdd(AbstractTreeViewer.java:281)
	at org.eclipse.jface.viewers.TreeViewer.internalAdd(TreeViewer.java:630)
	at org.eclipse.jface.viewers.AbstractTreeViewer.add(AbstractTreeViewer.java:156)
	at org.eclipse.ui.navigator.CommonViewer.add(CommonViewer.java:301)
	at org.eclipse.jface.viewers.AbstractTreeViewer.add(AbstractTreeViewer.java:664)
	at org.eclipse.jdt.internal.ui.packageview.PackageExplorerContentProvider$4.run(PackageExplorerContentProvider.java:977)
	at org.eclipse.jdt.internal.ui.packageview.PackageExplorerContentProvider.runUpdates(PackageExplorerContentProvider.java:195)
	at org.eclipse.jdt.internal.ui.packageview.PackageExplorerContentProvider.runPendingUpdates(PackageExplorerContentProvider.java:187)
	at org.eclipse.jdt.internal.ui.packageview.PackageExplorerContentProvider$1.runInUIThread(PackageExplorerContentProvider.java:165)
	at org.eclipse.ui.progress.UIJob$1.run(UIJob.java:97)
	at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
	at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
	at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4155)
	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3772)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1127)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:337)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1018)
	at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:156)
	at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:694)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:337)
	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:606)
	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:139)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:498)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:669)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:608)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1515)

!ENTRY de.weingardt.gitlab.core 4 0 2016-06-20 14:03:38.829
!MESSAGE Unable to execute Query: Unknown Exception: null

!ENTRY org.eclipse.m2e.logback.appender 2 0 2016-06-20 14:03:51.382
!MESSAGE Using platform encoding (Cp1252 actually) to copy filtered resources, i.e. build is platform dependent!

!ENTRY org.eclipse.m2e.logback.appender 2 0 2016-06-20 14:03:51.438
!MESSAGE Using platform encoding (Cp1252 actually) to copy filtered resources, i.e. build is platform dependent!

!ENTRY org.eclipse.m2e.logback.appender 2 0 2016-06-20 14:03:54.004
!MESSAGE Using platform encoding (Cp1252 actually) to copy filtered resources, i.e. build is platform dependent!

!ENTRY org.eclipse.m2e.logback.appender 2 0 2016-06-20 14:03:54.045
!MESSAGE Using platform encoding (Cp1252 actually) to copy filtered resources, i.e. build is platform dependent!


Unfortunately there is no stack trace for the problematic exception. I looked at query tasks for bugzilla and gerrit, but could not find any for gitlab. The strange behaviour to make the repository and queries work is what confuses me the most.
Re: Mylyn Gitlab query not working [message #1735587 is a reply to message #1735499] Tue, 21 June 2016 10:40 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31048
Registered: July 2009
Senior Member
None of these task traces appear related. Navigate -> Open Setup Log
doesn't show any related stack traces either?

Perhaps that connector's query requires a non-null URL like this
Bugzilla connector query we have in Oomph has a URL for the query (where
in fact the URL is exactly what specifies the query):

<?xml version="1.0" encoding="UTF-8"?>
<mylyn:MylynQueriesTask
xmi:version="2.0"
xmlns:xmi="http://www.omg.org/XMI"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:mylyn="http://www.eclipse.org/oomph/setup/mylyn/1.0"
xsi:schemaLocation="http://www.eclipse.org/oomph/setup/mylyn/1.0
http://git.eclipse.org/c/oomph/org.eclipse.oomph.git/plain/setups/models/Mylyn.ecore"
repositoryURL="https://bugs.eclipse.org/bugs"
userID="${bugzilla.id}"
password="${eclipse.user.password}">
<query summary="Oomph Bugs"
url="https://bugs.eclipse.org/bugs/buglist.cgi?product=Oomph&amp;bug_status=UNCONFIRMED&amp;bug_status=NEW&amp;bug_status=ASSIGNED&amp;bug_status=REOPENED&amp;bug_severity=blocker&amp;bug_severity=critical&amp;bug_severity=major&amp;bug_severity=normal&amp;bug_severity=minor&amp;bug_severity=trivial"/>
</mylyn:MylynQueriesTask>

If it doesn't need a URL I would expect it needs at least some type of
query attributes...

On 20.06.2016 08:26, Christian Wolff wrote:
> Hi Ed,
>
> I defined the variables like this:
>
>
> <setupTask
> xsi:type="setup:VariableTask"
> type="PASSWORD"
> name="gitlab.user.password"
> label="Gitlab password for issues"/>
> <setupTask
> xsi:type="setup:VariableTask"
> name="gitlab.user.login"
> label="Gitlab login for issues"/>
>
>
> Here is the error log
>
> !SESSION 2016-06-20 14:02:41.599
> -----------------------------------------------
> eclipse.buildId=4.5.2.M20160212-1500
> java.version=1.8.0_92
> java.vendor=Oracle Corporation
> BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=de_DE
> Framework arguments: -product org.eclipse.epp.package.jee.product
> Command-line arguments: -os win32 -ws win32 -arch x86_64 -product
> org.eclipse.epp.package.jee.product -data
> C:\develop\Workspaces\mycompany_Mars_Test
>
> !ENTRY org.eclipse.jface 2 0 2016-06-20 14:03:01.200
> !MESSAGE Keybinding conflicts occurred. They may interfere with
> normal accelerator operation.
> !SUBENTRY 1 org.eclipse.jface 2 0 2016-06-20 14:03:01.200
> !MESSAGE A conflict occurred for ALT+CTRL+T:
> Binding(ALT+CTRL+T,
> ParameterizedCommand(Command(org.eclipse.team.svn.ui.command.EditPropertiesCommand,Show
> Properties,
> ,
> Category(org.eclipse.team.svn.ui.command.category,SVN,null,true),
> org.eclipse.ui.internal.WorkbenchHandlerServiceHandler@1a0e5c0c,
> ,,true),null),
> org.eclipse.ui.defaultAcceleratorConfiguration,
> org.eclipse.ui.contexts.window,,,system)
> Binding(ALT+CTRL+T,
> ParameterizedCommand(Command(org.eclipse.tm.terminal.connector.local.command.launch,Open
> Local Terminal on Selection,
> ,
> Category(org.eclipse.tm.terminal.view.ui.commands.category,Terminal
> Commands,null,true),
> org.eclipse.ui.internal.WorkbenchHandlerServiceHandler@5bb45afc,
> ,,true),null),
> org.eclipse.ui.defaultAcceleratorConfiguration,
> org.eclipse.ui.contexts.window,,,system)
>
> !ENTRY org.eclipse.egit.ui 2 0 2016-06-20 14:03:15.892
> !MESSAGE Warning: The environment variable HOME is not set. The
> following directory will be used to store the Git
> user global configuration and to define the default location to store
> repositories: 'I:\'. If this is
> not correct please set the HOME environment variable and restart
> Eclipse. Otherwise Git for Windows and
> EGit might behave differently since they see different configuration
> options.
> This warning can be switched off on the Team > Git > Confirmations and
> Warnings preference page.
>
> !ENTRY org.eclipse.m2e.logback.appender 4 0 2016-06-20 14:03:31.021
> !MESSAGE Unable to update index for
> public|https://nexus.mycompany.de/nexus/repository/public/:
> C:\develop\m2_repo\.cache\m2e\1.6.2\dda625bf06e067e7ab3335a28dd06616\nexus-maven-repository-index.zip
> (Das System kann die angegebene Datei nicht finden)
> !STACK 0
> java.io.FileNotFoundException:
> C:\develop\m2_repo\.cache\m2e\1.6.2\dda625bf06e067e7ab3335a28dd06616\nexus-maven-repository-index.zip
> (Das System kann die angegebene Datei nicht finden)
> at java.io.FileInputStream.open0(Native Method)
> at java.io.FileInputStream.open(FileInputStream.java:195)
> at java.io.FileInputStream.<init>(FileInputStream.java:138)
> at
> org.apache.maven.index.updater.DefaultIndexUpdater$FileFetcher.retrieve(DefaultIndexUpdater.java:568)
> at
> org.apache.maven.index.updater.DefaultIndexUpdater.loadIndexDirectory(DefaultIndexUpdater.java:206)
> at
> org.apache.maven.index.updater.DefaultIndexUpdater.access$300(DefaultIndexUpdater.java:75)
> at
> org.apache.maven.index.updater.DefaultIndexUpdater$LuceneIndexAdaptor.setIndexFile(DefaultIndexUpdater.java:645)
> at
> org.apache.maven.index.updater.DefaultIndexUpdater.fetchAndUpdateIndex(DefaultIndexUpdater.java:844)
> at
> org.apache.maven.index.updater.DefaultIndexUpdater.fetchAndUpdateIndex(DefaultIndexUpdater.java:156)
> at
> org.eclipse.m2e.core.internal.index.nexus.NexusIndexManager.updateRemoteIndex(NexusIndexManager.java:1140)
> at
> org.eclipse.m2e.core.internal.index.nexus.NexusIndexManager.updateIndex(NexusIndexManager.java:1084)
> at
> org.eclipse.m2e.core.internal.index.nexus.NexusIndexManager$1.run(NexusIndexManager.java:656)
> at
> org.eclipse.m2e.core.internal.index.nexus.IndexUpdaterJob.run(IndexUpdaterJob.java:72)
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
>
> !ENTRY org.eclipse.jst.j2ee.core 4 0 2016-06-20 14:03:38.270
> !MESSAGE !STACK 0
> java.lang.InterruptedException
> at
> org.eclipse.core.internal.jobs.OrderedLock.acquire(OrderedLock.java:112)
> at
> org.eclipse.jst.j2ee.internal.J2EEInit.aquireInitializePackageContentsLock(J2EEInit.java:454)
> at
> org.eclipse.jst.j2ee.ejb.internal.impl.EjbPackageImpl.freeze(EjbPackageImpl.java:1757)
> at
> org.eclipse.jst.j2ee.ejb.internal.impl.EjbPackageImpl.init(EjbPackageImpl.java:325)
> at org.eclipse.jst.j2ee.ejb.EjbPackage.<clinit>(EjbPackage.java:1916)
> at
> org.eclipse.jst.j2ee.ejb.internal.impl.EjbFactoryImpl.getPackage(EjbFactoryImpl.java:671)
> at
> org.eclipse.jst.j2ee.internal.provider.J2EEAdapterFactoryLabelProvider.<clinit>(J2EEAdapterFactoryLabelProvider.java:42)
> at
> org.eclipse.jst.j2ee.navigator.internal.J2EELabelProvider.initialize(J2EELabelProvider.java:57)
> at
> org.eclipse.jst.j2ee.navigator.internal.J2EELabelProvider.init(J2EELabelProvider.java:246)
> at
> org.eclipse.ui.internal.navigator.extensions.NavigatorContentExtension$2.run(NavigatorContentExtension.java:156)
> at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
> at
> org.eclipse.ui.internal.navigator.extensions.NavigatorContentExtension.getLabelProvider(NavigatorContentExtension.java:148)
> at
> org.eclipse.ui.internal.navigator.NavigatorContentServiceLabelProvider.findStyledText(NavigatorContentServiceLabelProvider.java:165)
> at
> org.eclipse.ui.internal.navigator.NavigatorContentServiceLabelProvider.getStyledText(NavigatorContentServiceLabelProvider.java:153)
> at
> org.eclipse.ui.internal.navigator.NavigatorDecoratingLabelProvider$StyledLabelProviderAdapter.getStyledText(NavigatorDecoratingLabelProvider.java:63)
> at
> org.eclipse.jface.viewers.DelegatingStyledCellLabelProvider.getStyledText(DelegatingStyledCellLabelProvider.java:206)
> at
> org.eclipse.jface.viewers.DecoratingStyledCellLabelProvider.getStyledText(DecoratingStyledCellLabelProvider.java:199)
> at
> org.eclipse.jface.viewers.DelegatingStyledCellLabelProvider.update(DelegatingStyledCellLabelProvider.java:106)
> at
> org.eclipse.jface.viewers.DecoratingStyledCellLabelProvider.update(DecoratingStyledCellLabelProvider.java:136)
> at
> org.eclipse.jface.viewers.ViewerColumn.refresh(ViewerColumn.java:154)
> at
> org.eclipse.jface.viewers.AbstractTreeViewer.doUpdateItem(AbstractTreeViewer.java:949)
> at
> org.eclipse.jface.viewers.AbstractTreeViewer$UpdateItemSafeRunnable.run(AbstractTreeViewer.java:114)
> at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
> at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:50)
> at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:173)
> at
> org.eclipse.jface.viewers.AbstractTreeViewer.doUpdateItem(AbstractTreeViewer.java:1029)
> at
> org.eclipse.jface.viewers.StructuredViewer$UpdateItemSafeRunnable.run(StructuredViewer.java:473)
> at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
> at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:50)
> at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:173)
> at
> org.eclipse.jface.viewers.StructuredViewer.updateItem(StructuredViewer.java:2176)
> at
> org.eclipse.jface.viewers.AbstractTreeViewer.createTreeItem(AbstractTreeViewer.java:843)
> at
> org.eclipse.jface.viewers.AbstractTreeViewer.createAddedElements(AbstractTreeViewer.java:347)
> at
> org.eclipse.jface.viewers.AbstractTreeViewer.internalAdd(AbstractTreeViewer.java:281)
> at
> org.eclipse.jface.viewers.TreeViewer.internalAdd(TreeViewer.java:630)
> at
> org.eclipse.jface.viewers.AbstractTreeViewer.add(AbstractTreeViewer.java:156)
> at org.eclipse.ui.navigator.CommonViewer.add(CommonViewer.java:301)
> at
> org.eclipse.jface.viewers.AbstractTreeViewer.add(AbstractTreeViewer.java:664)
> at
> org.eclipse.jdt.internal.ui.packageview.PackageExplorerContentProvider$4.run(PackageExplorerContentProvider.java:977)
> at
> org.eclipse.jdt.internal.ui.packageview.PackageExplorerContentProvider.runUpdates(PackageExplorerContentProvider.java:195)
> at
> org.eclipse.jdt.internal.ui.packageview.PackageExplorerContentProvider.runPendingUpdates(PackageExplorerContentProvider.java:187)
> at
> org.eclipse.jdt.internal.ui.packageview.PackageExplorerContentProvider$1.runInUIThread(PackageExplorerContentProvider.java:165)
> at org.eclipse.ui.progress.UIJob$1.run(UIJob.java:97)
> at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
> at
> org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
> at
> org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4155)
> at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3772)
> at
> org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1127)
> at
> org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:337)
> at
> org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1018)
> at
> org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:156)
> at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:694)
> at
> org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:337)
> at
> org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:606)
> at
> org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
> at
> org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:139)
> at
> org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
> at java.lang.reflect.Method.invoke(Method.java:498)
> at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:669)
> at org.eclipse.equinox.launcher.Main.basicRun(Main.java:608)
> at org.eclipse.equinox.launcher.Main.run(Main.java:1515)
>
> !ENTRY de.weingardt.gitlab.core 4 0 2016-06-20 14:03:38.829
> !MESSAGE Unable to execute Query: Unknown Exception: null
>
> !ENTRY org.eclipse.m2e.logback.appender 2 0 2016-06-20 14:03:51.382
> !MESSAGE Using platform encoding (Cp1252 actually) to copy filtered
> resources, i.e. build is platform dependent!
>
> !ENTRY org.eclipse.m2e.logback.appender 2 0 2016-06-20 14:03:51.438
> !MESSAGE Using platform encoding (Cp1252 actually) to copy filtered
> resources, i.e. build is platform dependent!
>
> !ENTRY org.eclipse.m2e.logback.appender 2 0 2016-06-20 14:03:54.004
> !MESSAGE Using platform encoding (Cp1252 actually) to copy filtered
> resources, i.e. build is platform dependent!
>
> !ENTRY org.eclipse.m2e.logback.appender 2 0 2016-06-20 14:03:54.045
> !MESSAGE Using platform encoding (Cp1252 actually) to copy filtered
> resources, i.e. build is platform dependent!
>
>
> Unfortunately there is no stack trace for the problematic exception. I
> looked at query tasks for bugzilla and gerrit, but could not find any
> for gitlab. The strange behaviour to make the repository and queries
> work is what confuses me the most.
Re: Mylyn Gitlab query not working [message #1735595 is a reply to message #1735587] Tue, 21 June 2016 11:25 Go to previous messageGo to next message
Christian Wolff is currently offline Christian WolffFriend
Messages: 18
Registered: April 2016
Junior Member
I tried setting the URL. This is my Setup-Task:
<setupTask xsi:type="mylyn:MylynQueriesTask" connectorKind="gitlab" repositoryURL="https://gitlab.mycompany.de/projects/project.git" userID="${gitlab.user.login}" password="${gitlab.user.password}">
	<query summary="project" url="https://gitlab.mycompany.de/projects/project.git"/>
</setupTask>


This produced the same exception. I have appended the full setup.log but I guess this is the interesting part (?):
[2016-06-21 13:04:44] Performing Mylyn Queries https://gitlab.mycompany.de/myprojects/project.git (gitlab)
[2016-06-21 13:04:44] Adding gitlab repository: https://gitlab.mycompany.de/myprojects/project.git
[2016-06-21 13:04:44] Adding gitlab query: project
[2016-06-21 13:04:44] Setting query URL = https://gitlab.mycompany.de/myprojects/project.git

Manually synchronising the query after the setup won't work either. Only the "workaround" mentioned in the first post works.
  • Attachment: setup.log
    (Size: 277.63KB, Downloaded 84 times)
Re: Mylyn Gitlab query not working [message #1735604 is a reply to message #1735595] Tue, 21 June 2016 11:52 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31048
Registered: July 2009
Senior Member
Hmmm, no stack trace. In
org.eclipse.oomph.setup.ui.wizards.ProgressPage.run(String,
ProgressLogRunnable) we have logic like this:

catch (OperationCanceledException ex)
{
// Do nothing
}
catch (Throwable ex)
{

that should catch all Throwables and log them so I'm not sure how it's
possible for an exception to propagate to the point where a dialog box
should come up...

When you configure the query manually in the IDE, do you really have to
provide no other data for the query? I.e., no URL and no attributes?

In the end, to fix whatever the problem is, I either need a stack trace,
or I need to be able to reproduce the problem locally? At this point I
can't even guess what might be wrong. Certainly the log you should
seems to indicate that nothing is failing and that there are no
exceptions, except the log is truncated or nothing else happens after
setting the query URL?

On 21.06.2016 07:25, Christian Wolff wrote:
> I tried setting the URL. This is my Setup-Task:
>
> <setupTask xsi:type="mylyn:MylynQueriesTask" connectorKind="gitlab" repositoryURL="https://gitlab.mycompany.de/projects/project.git" userID="${gitlab.user.login}" password="${gitlab.user.password}">
> <query summary="project" url="https://gitlab.mycompany.de/projects/project.git"/>
> </setupTask>
>
>
> This produced the same exception. I have appended the full setup.log but I guess this is the interesting part (?):
>
> [2016-06-21 13:04:44] Performing Mylyn Queries https://gitlab.mycompany.de/myprojects/project.git (gitlab)
> [2016-06-21 13:04:44] Adding gitlab repository: https://gitlab.mycompany.de/myprojects/project.git
> [2016-06-21 13:04:44] Adding gitlab query: project
> [2016-06-21 13:04:44] Setting query URL = https://gitlab.mycompany.de/myprojects/project.git
>
> Manually synchronising the query after the setup won't work either. Only the "workaround" mentioned in the first post works.
Re: Mylyn Gitlab query not working [message #1735622 is a reply to message #1735604] Tue, 21 June 2016 12:59 Go to previous messageGo to next message
Christian Wolff is currently offline Christian WolffFriend
Messages: 18
Registered: April 2016
Junior Member
I fear this was the complete log Sad Manually creating a query only requires a name.

I have created a public gitlab repository with one issue and no other content. You can use this as a task repository (for any eclipse project) using the mylyn gitlab connector plugin. To test this you need an account on www.gitlab.com and I probably (?) have to add your user to the project. The query should display the one created issue.

The repository can be found here:
https://gitlab.com/Christian122/test-project.git

Alternatively you could create your own repository and issue on the site. Would probably be much easier than using my repo Smile . I just created this to confirm it was still producing the same exception, not only with our gitlab environment.

I attached a basic setup which reproduces the problem in which you can insert your own repository. I hope this helps!
  • Attachment: Simple.setup
    (Size: 1.98KB, Downloaded 163 times)
Re: Mylyn Gitlab query not working [message #1735624 is a reply to message #1735622] Tue, 21 June 2016 13:11 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31048
Registered: July 2009
Senior Member
Christian,

Please open a Bugzilla with a reference to this thread and with these
details. I'll try to find time in the coming days to have a look, but
I'm traveling so can't promise a quick fix, perhaps not until July.


On 21.06.2016 08:59, Christian Wolff wrote:
> I fear this was the complete log :( Manually creating a query only requires a name.
>
> I have created a public gitlab repository with one issue and no other content. You can use this as a task repository (for any eclipse project) using the mylyn gitlab connector plugin. To test this you need an account on www.gitlab.com and I probably (?) have to add your user to the project. The query should display the one created issue.
>
> The repository can be found here:
> https://gitlab.com/Christian122/test-project.git
>
> Alternatively you could create your own repository and issue on the site. Would probably be much easier than using my repo :) . I just created this to confirm it was still producing the same exception, not only with our gitlab environment.
>
> I attached a basic setup which reproduces the problem in which you can insert your own repository. I hope this helps!
Re: Mylyn Gitlab query not working [message #1735632 is a reply to message #1735624] Tue, 21 June 2016 13:41 Go to previous message
Christian Wolff is currently offline Christian WolffFriend
Messages: 18
Registered: April 2016
Junior Member
I have created the bug report: https://bugs.eclipse.org/bugs/show_bug.cgi?id=496467

Thank you for your support and save travels!
Previous Topic:Oomph artwork
Next Topic:[Solved] How to cancle a Task
Goto Forum:
  


Current Time: Fri Apr 10 13:38:40 GMT 2020

Powered by FUDForum. Page generated in 0.03751 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top