Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » [SOLVED] Problems when installing setup task extensions
[SOLVED] Problems when installing setup task extensions [message #1735022] Tue, 14 June 2016 17:21 Go to next message
Steffen Holzer is currently offline Steffen HolzerFriend
Messages: 59
Registered: January 2016
Member

Hello, it's me again.

I ran into the following problem:

When the eclipse installer tries to install my self created setup task extension (in this post I'll only mention the 'cli-task' but there are others with the exact same problem) the installer throws
Internal Error
Cannot complete the install because one or more required items could not be found

org.eclipse.core.runtime.CoreException: Cannot complete the install because one or more required items could not be found.
	at org.eclipse.oomph.util.OomphPlugin.coreException(OomphPlugin.java:280)
	at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.resolve(ProfileTransactionImpl.java:414)
	at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:326)
	at org.eclipse.oomph.setup.ui.EnablementComposite$5.run(EnablementComposite.java:316)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
Contains: Software being installed: artificial_root 1.0.0.v1465924705675
Contains: Missing requirement: artificial_root 1.0.0.v1465924705675 requires 'task-cli.feature.group 0.0.0' but it could not be found


I included the Setup file and the setup task extension can be found here : https://github.com/maybeec/oomph-task-cli. I actually have no idea where the problem is since Eclipse itself can install the extension without problems
  • Attachment: Cli.setup
    (Size: 1.75KB, Downloaded 152 times)


"Always code as if the guy who ends up maintaining your code will be a violent psychopath who knows where you live" - John Woods

[Updated on: Thu, 16 June 2016 16:11]

Report message to a moderator

Re: Problems when installing setup task extensions [message #1735096 is a reply to message #1735022] Wed, 15 June 2016 13:57 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31038
Registered: July 2009
Senior Member
Steffen,

Looking at your model I see

<eAnnotations source="http://www.eclipse.org/oomph/setup/Enablement">
<details key="variableName" value="p2.cli"/>
<details key="repository"
value="http://maybeec.github.io/oomph-task-cli/update"/>
<details key="installableUnits" value="task-cli.feature.group"/>
</eAnnotations>

Using the Repository Explorer to look at this site, I see it doesn't
have a feature with that ID. Instead it has

com.github.maybeec.oomph.task.cli.feature.feature.group

So just be sure you've specified the right ID for the update sites.

On 14.06.2016 19:22, Steffen Holzer wrote:
> Hello, it's me again.
>
> I ran into the following problem:
>
> When the eclipse installer tries to install my self created setup task extension (in this post I'll only mention the 'cli-task' but there are others with the exact same problem) the installer throws
>
> Internal Error
> Cannot complete the install because one or more required items could not be found
>
> org.eclipse.core.runtime.CoreException: Cannot complete the install because one or more required items could not be found.
> at org.eclipse.oomph.util.OomphPlugin.coreException(OomphPlugin.java:280)
> at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.resolve(ProfileTransactionImpl.java:414)
> at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:326)
> at org.eclipse.oomph.setup.ui.EnablementComposite$5.run(EnablementComposite.java:316)
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
> Contains: Software being installed: artificial_root 1.0.0.v1465924705675
> Contains: Missing requirement: artificial_root 1.0.0.v1465924705675 requires 'task-cli.feature.group 0.0.0' but it could not be found
>
>
> I included the Setup file and the setup task extension can be found here : https://github.com/maybeec/oomph-task-cli. I actually have no idea where the problem is since Eclipse itself can install the extension without problems
Re: Problems when installing setup task extensions [message #1735116 is a reply to message #1735096] Wed, 15 June 2016 15:54 Go to previous message
Steffen Holzer is currently offline Steffen HolzerFriend
Messages: 59
Registered: January 2016
Member

Thank you Ed,
Thank you alot


"Always code as if the guy who ends up maintaining your code will be a violent psychopath who knows where you live" - John Woods
Previous Topic:java.lang.Exception when cloning a repo on GitHub
Next Topic:File copy under win7
Goto Forum:
  


Current Time: Tue Apr 07 11:16:06 GMT 2020

Powered by FUDForum. Page generated in 0.02135 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top