Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » Problem during loading the created model(Problem during loading the created model)
icon5.gif  Problem during loading the created model [message #1734622] Fri, 10 June 2016 04:59 Go to next message
naveen ramesh is currently offline naveen rameshFriend
Messages: 56
Registered: May 2016
Member
Hi,
Problem when creating the model object.I have the ecore model BasicFamily.ecore and the genmodel BasicFamily.genmodel.Now for the BasicFamily.genmodel the model,edit and editor code is generated.Once the code is generated i run the eclipse application for the generated editor code and in that application i started creating the modelling project and for that project when i try to create family model defined in the BasicFamily.ecore it used to throw the exception as mentioned below

java.lang.StackOverflowError
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(Unknown Source)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.defineClass(ModuleClassLoader.java:272)
at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.defineClass(ClasspathManager.java:632)



So after research in the internet it is mentioned that for recursive call the stack size mentioned is not enough for the eclipse.So how can i increase the size of the stack.

Thanks in advance

Re: Problem during loading the created model [message #1734631 is a reply to message #1734622] Fri, 10 June 2016 06:39 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31917
Registered: July 2009
Senior Member
You can edit the eclipse.ini to add the appropriate VM option:

http://stackoverflow.com/questions/3700459/how-to-increase-the-java-stack-size

On 10.06.2016 06:59, naveen ramesh wrote:
> Hi,
> Problem when creating the model object.I have the ecore model
> BasicFamily.ecore and the genmodel BasicFamily.genmodel.Now for the
> BasicFamily.genmodel the model,edit and editor code is generated.Once
> the code is generated i run the eclipse application for the generated
> editor code and in that application i started creating the modelling
> project and for that project when i try to create family model defined
> in the BasicFamily.ecore it used to throw the exception as mentioned
> below
>
> java.lang.StackOverflowError
> at java.lang.ClassLoader.defineClass1(Native Method)
> at java.lang.ClassLoader.defineClass(Unknown Source)
> at
> org.eclipse.osgi.internal.loader.ModuleClassLoader.defineClass(ModuleClassLoader.java:272)
> at
> org.eclipse.osgi.internal.loader.classpath.ClasspathManager.defineClass(ClasspathManager.java:632)
>
>
> So after research in the internet it is mentioned that for
> recursive call the stack size mentioned is not enough for the
> eclipse.So how can i increase the size of the stack.
>
> Thanks in advance
>
>


Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:adding new action to submenu
Next Topic:[xcore] Error: Cannot find compatible feature in sealed EClass
Goto Forum:
  


Current Time: Tue Jun 22 21:41:30 GMT 2021

Powered by FUDForum. Page generated in 0.01926 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top