Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BPMN 2.0 Modeler » Validation Error Decorations do not show
Validation Error Decorations do not show [message #1733195] Wed, 25 May 2016 10:23 Go to next message
Kai Rosswag is currently offline Kai RosswagFriend
Messages: 8
Registered: April 2016
Junior Member
Hi all,

as the title says, the validation error decorations do not show up for me.
It works in the xml editor/the source view (the errors/hints do get annotated at the start of the line), but not in the graphical editor.

I am using a custom runtime extension (which doesn't do anything yet) and the bpmn2 project nature.

Did I forget to add something to my extension so the validator will work? I tried to follow the developer tutorials. There are also no error messages in the log.

If needed I will gladly provide additional information.

Thanks in advance.
Re: Validation Error Decorations do not show [message #1733333 is a reply to message #1733195] Thu, 26 May 2016 14:01 Go to previous messageGo to next message
Robert Brodt is currently offline Robert BrodtFriend
Messages: 811
Registered: August 2010
Location: Colorado Springs, CO
Senior Member

Hmm, that's odd. The BPMN2 validator, which is responsible for creating Problem records, should be invoked whenever you save a file, or if you click "Validate" on the context menu. Can you verify if BPMN2ProjectValidator.validate() is being called when you save/validate a file?
icon11.gif  Re: Validation Error Decorations do not show [message #1733435 is a reply to message #1733333] Fri, 27 May 2016 12:42 Go to previous messageGo to next message
Kai Rosswag is currently offline Kai RosswagFriend
Messages: 8
Registered: April 2016
Junior Member
Thanks for your answer.
After going through the debugger on the validate method I found my error in the url:
platform:/resource//folder/diagram.bpmn


Hint: After resource there should only be one "/", the other one somehow sneaked in while assembling the url. Funny how that didn't really affect anything else..

Thanks again for your help Smile

Re: Validation Error Decorations do not show [message #1733491 is a reply to message #1733435] Sat, 28 May 2016 12:43 Go to previous message
Robert Brodt is currently offline Robert BrodtFriend
Messages: 811
Registered: August 2010
Location: Colorado Springs, CO
Senior Member

Awesome Smile glad I was able to help.
Previous Topic:change color with code
Next Topic:Neon M2 build is not available
Goto Forum:
  


Current Time: Sun Feb 18 08:42:58 GMT 2018

Powered by FUDForum. Page generated in 0.02027 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software