Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Eclipse 4.5.2 process suspends when launching RCP with debugger
Eclipse 4.5.2 process suspends when launching RCP with debugger [message #1732993] Mon, 23 May 2016 15:30 Go to next message
Bo Berney is currently offline Bo BerneyFriend
Messages: 12
Registered: July 2009
Junior Member
We have an RCP product we run in e3 compatibility mode.
Eclipse Mars.2 Release 4.5.2
Build id: 20160218-0600
Windows 7x64
JDK 1.8.0_91 x86_64

When launching our RCP application in the Eclipse debugger, the Eclipse IDE suspends (CPU shows "Suspended" in Process Explorer). When I resume it using Process Explorer, the launch never completes. If the IDE becomes responsive, then at least I can close and restart. Sometimes the IDE will hang even after resuming.

I cannot connect JVisualVM to it while it is suspended, but when it hung after resuming, I did notice that the following thread was hanging and blocking the main thread:

"Worker-4" #33 prio=5 os_prio=0 tid=0x000000001bfe6000 nid=0x5b6c runnable [0x0000000022d9e000]
   java.lang.Thread.State: RUNNABLE
	at java.io.FileInputStream.readBytes(Native Method)
	at java.io.FileInputStream.read(FileInputStream.java:255)
	at java.io.BufferedInputStream.read1(BufferedInputStream.java:284)
	at java.io.BufferedInputStream.read(BufferedInputStream.java:345)
	- locked <0x00000000d7f879f8> (a java.io.BufferedInputStream)
	at sun.nio.cs.StreamDecoder.readBytes(StreamDecoder.java:284)
	at sun.nio.cs.StreamDecoder.implRead(StreamDecoder.java:326)
	at sun.nio.cs.StreamDecoder.read(StreamDecoder.java:178)
	- locked <0x00000000d7f89bf8> (a java.io.InputStreamReader)
	at java.io.InputStreamReader.read(InputStreamReader.java:184)
	at java.io.BufferedReader.fill(BufferedReader.java:161)
	at java.io.BufferedReader.readLine(BufferedReader.java:324)
	- locked <0x00000000d7f89bf8> (a java.io.InputStreamReader)
	at java.io.BufferedReader.readLine(BufferedReader.java:389)
	at org.eclipse.debug.internal.core.LaunchManager.cacheNativeEnvironment(LaunchManager.java:821)
	at org.eclipse.debug.internal.core.LaunchManager.getNativeEnvironmentCasePreserved(LaunchManager.java:1826)
	- locked <0x0000000081394628> (a org.eclipse.debug.internal.core.LaunchManager)
	at org.eclipse.debug.internal.core.LaunchManager.getNativeEnvironment(LaunchManager.java:1806)
	- locked <0x0000000081394628> (a org.eclipse.debug.internal.core.LaunchManager)
	at org.eclipse.jdt.internal.launching.StandardVMDebugger.prependJREPath(StandardVMDebugger.java:422)
	at org.eclipse.jdt.internal.launching.StandardVMDebugger.run(StandardVMDebugger.java:226)
	at org.eclipse.pde.launching.AbstractPDELaunchConfiguration.launch(AbstractPDELaunchConfiguration.java:85)
	at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:885)
	at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:739)
	at org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(DebugUIPlugin.java:1039)
	at org.eclipse.debug.internal.ui.DebugUIPlugin$8.run(DebugUIPlugin.java:1256)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)


After resuming, the hanging launch was showing "Constructing command line..." in the Progress view.

I was able to debug fine a couple weeks ago, but somehow it is in a useless state and I cannot get it to debug at all.

Any ideas?

Attached is the complete stack trace for when it hung after resuming.
  • Attachment: stack.txt
    (Size: 23.36KB, Downloaded 46 times)

[Updated on: Mon, 23 May 2016 08:41]

Report message to a moderator

Re: Eclipse 4.5.2 process suspends when launching RCP with debugger [message #1732999 is a reply to message #1732993] Mon, 23 May 2016 16:09 Go to previous message
Patrik Suzzi is currently offline Patrik SuzziFriend
Messages: 86
Registered: June 2010
Location: Imola, Italy
Member

Hi, Bo!

Could you please file a bug against Platform UI, reporting the same information ?

here is the link :
https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Platform&component=UI
Previous Topic:How does one get the minimize and maximize view menu items to render on the view menu?
Next Topic:Is there a way to get the CSS spy to work on a RCP e4 JavaFX FXML app?
Goto Forum:
  


Current Time: Sat Sep 23 14:52:25 GMT 2017

Powered by FUDForum. Page generated in 0.06110 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software