Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Eclipse Process Manager (Stardust) » M2eclipse error 401 unauthorized(When working with remote repository that needs authentication Maven works fine from console but Eclipse is not abe to download the artifacts and throws a 401 unauthorized response)
M2eclipse error 401 unauthorized [message #1732209] Fri, 13 May 2016 12:59 Go to next message
Pablo Parra is currently offline Pablo ParraFriend
Messages: 2
Registered: May 2016
Junior Member
Hi all,
I'm looking for some help to solve an issue related apparently with m2e plugin in Eclipse.
I need to access to some artifacts located in a remote repository that needs authentication. After configure the settings.xml as explained in the Maven docs the command "mvn compile" works just fine and the artifacts are downloaded to local repository. But when using Eclipse to do the same a "Could not transfer artifact [...] Error code 401, Unauthorized" error is thrown and the jars are obviously not downloaded.
I have tried with different versions of Eclipse (Luna and Mars) and with updated version of the m2e plugin but the result is always the same.

Has anyone experienced a similar issue?

I have found some related posts where people seems to have similar issues but the few solutions proposed don't work for me.

Regards
Re: M2eclipse error 401 unauthorized [message #1735596 is a reply to message #1732209] Tue, 21 June 2016 11:26 Go to previous messageGo to next message
Tanmoy Roy is currently offline Tanmoy RoyFriend
Messages: 41
Registered: September 2013
Member
Hi Pablo,
Are you behind any proxy or firewall? In case then change your eclipse proxy settings.

-Tanmoy Roy
Re: M2eclipse error 401 unauthorized [message #1735602 is a reply to message #1735596] Tue, 21 June 2016 11:45 Go to previous message
Pablo Parra is currently offline Pablo ParraFriend
Messages: 2
Registered: May 2016
Junior Member
Finally seems that the problem was related to the credentials of the user. The remote repository was an Artifactory repository and using the password encryption of the Artifactory web (in the user profile section) instead of the Maven encryption solved the problem.

[Updated on: Tue, 21 June 2016 11:50]

Report message to a moderator

Previous Topic:Unable to compile Stardust src
Next Topic:Camel Endpoint Application - Webservice giving error 500
Goto Forum:
  


Current Time: Mon Nov 19 12:09:33 GMT 2018

Powered by FUDForum. Page generated in 0.02714 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top