Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » P2 update from specific repo to latest
P2 update from specific repo to latest [message #1731058] Mon, 02 May 2016 15:09 Go to next message
Christian Dumont is currently offline Christian DumontFriend
Messages: 2
Registered: May 2016
Junior Member
Hi,

i have an rcp project that was build with this repo :

http://download.eclipse.org/releases/mars/201510021000 (A)

and i would like to build the new repo for the software update with :

http://download.eclipse.org/releases/mars (B)


When my product perform a software update (Product A connect to repo B): i have this error :

Status ERROR: org.eclipse.equinox.p2.director code=10054 Cannot complete the install because of a conflicting dependency. null children=[Status ERROR: org.eclipse.equinox.p2.director code=0 Software being installed: Eclipse e4 Rich Client Platform 1.4.1.v20160212-1350 (org.eclipse.e4.rcp.feature.group 1.4.1.v20160212-1350) null Status ERROR: org.eclipse.equinox.p2.director code=0 Software currently installed: myProduct 1.0.0 (myProduct 1.0.0) null Status ERROR: org.eclipse.equinox.p2.director code=1 Only one of the following can be installed at once: null children=[Status ERROR: org.eclipse.equinox.p2.director code=0 Eclipse e4 Workbench 1.3.0.v20150531-1948 (org.eclipse.e4.ui.workbench 1.3.0.v20150531-1948) null Status ERROR: org.eclipse.equinox.p2.director code=0 Eclipse e4 Workbench 1.3.1.v20160203-0951 (org.eclipse.e4.ui.workbench 1.3.1.v20160203-0951) null] Status ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency: null children=[Status ERROR: org.eclipse.equinox.p2.director code=0 From: myProduct 1.0.0 (myProduct 1.0.0) null Status ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.e4.rcp.feature.group [1.4.0.v20150903-1804] null] Status ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency: null children=[Status ERROR: org.eclipse.equinox.p2.director code=0 From: Eclipse e4 Rich Client Platform 1.4.0.v20150903-1804 (org.eclipse.e4.rcp.feature.group 1.4.0.v20150903-1804) null Status ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.e4.ui.workbench [1.3.0.v20150531-1948] null] Status ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency: null children=[Status ERROR: org.eclipse.equinox.p2.director code=0 From: Eclipse e4 Rich Client Platform 1.4.1.v20160212-1350 (org.eclipse.e4.rcp.feature.group 1.4.1.v20160212-1350) null Status ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.e4.ui.workbench [1.3.1.v20160203-0951] null]]


Does anyone have an idea ?

Thanks
Re: P2 update from specific repo to latest [message #1731122 is a reply to message #1731058] Tue, 03 May 2016 01:54 Go to previous messageGo to next message
Brian de Alwis is currently offline Brian de AlwisFriend
Messages: 876
Registered: January 2012
Senior Member

I reformatted your error below. Basically you're hitting a problem as you're trying to install two version of org.eclipse.e4.ui.workbench, but it's a singleton bundle (i.e., only one version can be installed).

  • Your product 'myProduct' has a tight bound to the feature org.eclipse.e4.rcp 1.4.0. This feature includes bundle org.eclipse.e4.ui.workbench 1.3.0, which is a singleton bundle.
  • You asked to install feature org.eclipse.e4.rcp to version 1.4.1, which includes bundle org.eclipse.e4.ui.workbench 1.3.1, which is also a singleton bundle.
  • p2 cannot install org.eclipse.e4.rcp 1.4.1 as it conflicts as only one version of org.eclipse.e4.ui.workbench can be installed at any time.

The P2 FAQ has more information on deciphering.

Status ERROR: org.eclipse.equinox.p2.director code=10054 Cannot complete the install because of a conflicting dependency. null children=[
    Status ERROR: org.eclipse.equinox.p2.director code=0 Software being installed: Eclipse e4 Rich Client Platform 1.4.1.v20160212-1350 (org.eclipse.e4.rcp.feature.group 1.4.1.v20160212-1350) null
    Status ERROR: org.eclipse.equinox.p2.director code=0 Software currently installed: myProduct 1.0.0 (myProduct 1.0.0) null
    Status ERROR: org.eclipse.equinox.p2.director code=1 Only one of the following can be installed at once: null children=[
            Status ERROR: org.eclipse.equinox.p2.director code=0 Eclipse e4 Workbench 1.3.0.v20150531-1948 (org.eclipse.e4.ui.workbench 1.3.0.v20150531-1948) null
            Status ERROR: org.eclipse.equinox.p2.director code=0 Eclipse e4 Workbench 1.3.1.v20160203-0951 (org.eclipse.e4.ui.workbench 1.3.1.v20160203-0951) null
    ]
    Status ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency: null children=[
            Status ERROR: org.eclipse.equinox.p2.director code=0 From: myProduct 1.0.0 (myProduct 1.0.0) null
            Status ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.e4.rcp.feature.group [1.4.0.v20150903-1804] null
    ]
    Status ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency: null children=[
            Status ERROR: org.eclipse.equinox.p2.director code=0 From: Eclipse e4 Rich Client Platform 1.4.0.v20150903-1804 (org.eclipse.e4.rcp.feature.group 1.4.0.v20150903-1804) null
            Status ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.e4.ui.workbench [1.3.0.v20150531-1948] null
    ]
    Status ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency: null children=[
            Status ERROR: org.eclipse.equinox.p2.director code=0 From: Eclipse e4 Rich Client Platform 1.4.1.v20160212-1350 (org.eclipse.e4.rcp.feature.group 1.4.1.v20160212-1350) null
            Status ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.e4.ui.workbench [1.3.1.v20160203-0951] null
    ]
]


Eclipse Platform committer. Ask me about Eclipse support, training, and consulting.
Re: P2 update from specific repo to latest [message #1731208 is a reply to message #1731122] Tue, 03 May 2016 14:29 Go to previous messageGo to next message
Christian Dumont is currently offline Christian DumontFriend
Messages: 2
Registered: May 2016
Junior Member
Hi

First of all, thank's for your reply.

I understand what you're saying but as my product does not specify any version of org.eclipse.e4.rcp , do you have any idea why the p2 cannot update it
FYI in my feature and plugins i don't specify any version number for the required feature and plugin.

Regards,
Re: P2 update from specific repo to latest [message #1731210 is a reply to message #1731208] Tue, 03 May 2016 14:45 Go to previous messageGo to next message
Brian de Alwis is currently offline Brian de AlwisFriend
Messages: 876
Registered: January 2012
Senior Member

When you build a product, it is bound to an exact version of a feature.

Status ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency: null children=[
            Status ERROR: org.eclipse.equinox.p2.director code=0 From: myProduct 1.0.0 (myProduct 1.0.0) null
            Status ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.e4.rcp.feature.group [1.4.0.v20150903-1804] null
    ]



Eclipse Platform committer. Ask me about Eclipse support, training, and consulting.
Re: P2 update from specific repo to latest [message #1731212 is a reply to message #1731210] Tue, 03 May 2016 14:53 Go to previous message
Brian de Alwis is currently offline Brian de AlwisFriend
Messages: 876
Registered: January 2012
Senior Member

I should have added: there are techniques, like using a p2.inf, to avoid this direct version binding.

Eclipse Platform committer. Ask me about Eclipse support, training, and consulting.
Previous Topic:Open Attached Javadoc issue with e4 API
Next Topic:Preferences and default values
Goto Forum:
  


Current Time: Thu Sep 24 07:30:52 GMT 2020

Powered by FUDForum. Page generated in 0.02279 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top