Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Proposals » OSGi Enterprise Tools » Upgrading org.eclipse.osgi jar(Want to use org.eclipse.osgi_3.10.1 instead of org.eclipse.osgi_3.8.1)
Upgrading org.eclipse.osgi jar [message #1730504] Tue, 26 April 2016 12:11 Go to next message
Lonely Babe is currently offline Lonely BabeFriend
Messages: 1
Registered: April 2016
Junior Member
I'm trying to upgrade the OSGI framework jar from 3.8.1 to 3.10.1 but I'm facing some issues like some projects are available under 3.8.1 but not present under 3.10.1.

Examples : Projects such as org.eclipse.osgi.framework.adaptor & org.eclipse.osgi.framework.internal.core are no longer available under 3.10.1 jar but are present in 3.8.1

My project is currently using 3.8.1 but when I'm trying to upgrade to org.eclipse.osgi_3.10.1 then it's showing the following error:

Unsolved bundle : org.eclipse.osgi.framework.adaptor.

What is the workaround for this?
Re: Upgrading org.eclipse.osgi jar [message #1730621 is a reply to message #1730504] Wed, 27 April 2016 07:54 Go to previous message
Deepak Agrawal is currently offline Deepak AgrawalFriend
Messages: 1
Registered: April 2016
Junior Member
HI
I am also facing same issue, could anyone please respond with any migration guide or tutorial?
Regards
Deepak
Previous Topic:OSGI ExtensionPoints
Next Topic:Need to know how to plug bundles
Goto Forum:
  


Current Time: Wed Nov 14 18:00:58 GMT 2018

Powered by FUDForum. Page generated in 0.01961 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top