Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse upgrade from 3.8.2 to 4.5.2(Eclipse upgrade from 3.8.2 to 4.5.2)
Eclipse upgrade from 3.8.2 to 4.5.2 [message #1729417] Thu, 14 April 2016 03:31 Go to next message
DEEPALI KARLEKAR is currently offline DEEPALI KARLEKARFriend
Messages: 7
Registered: April 2016
Junior Member
HI
I am trying to upgrade my component from eclipse SDK 3.8.2 to 4.5.2. I had to fix various build errors after that I tried to launch my application. I am getting following error when I am running my component.
org.osgi.framework.BundleException: The bundle "org.eclipse.equinox.simpleconfigurator_1.1.100.v20150423-1455 [786]" could not be resolved. Reason: Missing Constraint: Import-Package: org.osgi.framework.namespace; version="1.0.0"
at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1328)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1312)
at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:324)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:390)
at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1130)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:438)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)


Any help is appreciated
Re: Eclipse upgrade from 3.8.2 to 4.5.2 [message #1729430 is a reply to message #1729417] Thu, 14 April 2016 06:52 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29460
Registered: July 2009
Senior Member
Have you tried to invoke "Validate Plug-ins" on your launch
configuration's Plug-ins tab?

On 14.04.2016 05:31, DEEPALI KARLEKAR wrote:
> HI I am trying to upgrade my component from eclipse SDK 3.8.2 to
> 4.5.2. I had to fix various build errors after that I tried to launch
> my application. I am getting following error when I am running my
> component.
> org.osgi.framework.BundleException: The bundle
> "org.eclipse.equinox.simpleconfigurator_1.1.100.v20150423-1455 [786]"
> could not be resolved. Reason: Missing Constraint: Import-Package:
> org.osgi.framework.namespace; version="1.0.0"
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1328)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1312)
> at
> org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:324)
> at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:390)
> at
> org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1130)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:438)
> at
> org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:1)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
> at
> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
>
>
> Any help is appreciated
Re: Eclipse upgrade from 3.8.2 to 4.5.2 [message #1729452 is a reply to message #1729430] Thu, 14 April 2016 09:29 Go to previous messageGo to next message
DEEPALI KARLEKAR is currently offline DEEPALI KARLEKARFriend
Messages: 7
Registered: April 2016
Junior Member
yes.. It says the same thing. Not that helpful
Re: Eclipse upgrade from 3.8.2 to 4.5.2 [message #1729464 is a reply to message #1729452] Thu, 14 April 2016 10:24 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29460
Registered: July 2009
Senior Member
So clearly you need to fix the launch configuration. Unless you take
some initiative to do that, I'll keep asking you questions. What does
your "Launch with:" specify on that tab? If you've manually selected
things, you'll probably need to revisit that (and use the Add Required
Plug-ins button). If it's not manually done, what is in your target
platform? What have you don't to update it?

On 14.04.2016 11:29, DEEPALI KARLEKAR wrote:
> yes.. It says the same thing. Not that helpful
Re: Eclipse upgrade from 3.8.2 to 4.5.2 [message #1729524 is a reply to message #1729464] Fri, 15 April 2016 06:13 Go to previous messageGo to next message
DEEPALI KARLEKAR is currently offline DEEPALI KARLEKARFriend
Messages: 7
Registered: April 2016
Junior Member
I am launching this as an eclipse application.

I was able to understand the problem. Its with osgi plugin. But now when I am updating my org.eclipse.osgi3.8 jar to org.eclipse.osgi_3.10.102.v20160118-1700, I am getting compatibility issues.

[Updated on: Fri, 15 April 2016 06:14]

Report message to a moderator

Re: Eclipse upgrade from 3.8.2 to 4.5.2 [message #1729538 is a reply to message #1729524] Fri, 15 April 2016 08:34 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 29460
Registered: July 2009
Senior Member
Your latest post doesn't contain a question. Nor does it answer my
questions.

On 15.04.2016 08:13, DEEPALI KARLEKAR wrote:
> I was able to understand the problem. Its with osgi plugin. But now
> when I am updating my org.eclipse.osgi3.8 jar to
> org.eclipse.osgi_3.10.102.v20160118-1700, I am getting compatibility
> issues.
Previous Topic:how to stop the debugger?
Next Topic:Eclipse starts in debug mode
Goto Forum:
  


Current Time: Sun Jul 22 12:55:06 GMT 2018

Powered by FUDForum. Page generated in 0.02808 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top