Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » E4LifeCycle.java created by Wizard has errors
E4LifeCycle.java created by Wizard has errors [message #1727652] Thu, 24 March 2016 19:42 Go to next message
Paul Roubekas is currently offline Paul RoubekasFriend
Messages: 207
Registered: March 2012
Location: Chattanooga, TN USA
Senior Member
Is the bellow sequence wrong? Or is there a bug in the Wizard? Are there manual step to get around these issues?

index.php/fa/25409/0/
  • Attachment: 1.png
    (Size: 752.37KB, Downloaded 278 times)


Oxygen 3a
Windows 10
Re: E4LifeCycle.java created by Wizard has errors [message #1727657 is a reply to message #1727652] Thu, 24 March 2016 20:29 Go to previous messageGo to next message
Dirk Fauth is currently offline Dirk FauthFriend
Messages: 2787
Registered: July 2012
Senior Member
Do you have a target definition enabled?
Re: E4LifeCycle.java created by Wizard has errors [message #1727671 is a reply to message #1727657] Thu, 24 March 2016 23:08 Go to previous messageGo to next message
Paul Roubekas is currently offline Paul RoubekasFriend
Messages: 207
Registered: March 2012
Location: Chattanooga, TN USA
Senior Member
Yes
index.php/fa/25418/0/
  • Attachment: Snap1.png
    (Size: 66.08KB, Downloaded 488 times)


Oxygen 3a
Windows 10
Re: E4LifeCycle.java created by Wizard has errors [message #1727679 is a reply to message #1727671] Fri, 25 March 2016 07:13 Go to previous messageGo to next message
Dirk Fauth is currently offline Dirk FauthFriend
Messages: 2787
Registered: July 2012
Senior Member
I'm a bit confused about what you are trying to create. An e4 application based on SWT or an e4 application based on JavaFX. And which versions of Eclipse and efxclipse do you use? IIRC efxclipse does not support Mars 4.5.2 because it brought up a breaking change regarding SWT dependencies from the e4 side (which is wrong and will be fixed, although not sure when)

If you want to create an e4 JavaFX application I suggest to use the efxclipse wizards.
Re: E4LifeCycle.java created by Wizard has errors [message #1727681 is a reply to message #1727679] Fri, 25 March 2016 08:07 Go to previous message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 6566
Registered: July 2009
Senior Member
Hi,

Dirk is right. What you are doing is creating an e4 application who uses
SWT but your target only holds the e(fx)clipse runtime hence it can not
work.

Tom

On 25.03.16 08:13, Dirk Fauth wrote:
> I'm a bit confused about what you are trying to create. An e4
> application based on SWT or an e4 application based on JavaFX. And which
> versions of Eclipse and efxclipse do you use? IIRC efxclipse does not
> support Mars 4.5.2 because it brought up a breaking change regarding SWT
> dependencies from the e4 side (which is wrong and will be fixed,
> although not sure when)
> If you want to create an e4 JavaFX application I suggest to use the
> efxclipse wizards.
Previous Topic:80 errors creating new Eclipse4 application
Next Topic:Using File oriented editors and package explorer in e4
Goto Forum:
  


Current Time: Mon Sep 28 09:04:53 GMT 2020

Powered by FUDForum. Page generated in 0.01905 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top