Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Babel » Babel update site resetting the TCP connection when downloading the artifacts(Babel update site resetting the TCP connection when downloading the artifacts)
icon9.gif  Babel update site resetting the TCP connection when downloading the artifacts [message #1725918] Tue, 08 March 2016 13:55 Go to next message
Dmitriy Grintshak is currently offline Dmitriy GrintshakFriend
Messages: 4
Registered: March 2016
Junior Member
Hello,

I have very weird behaviour of Maven build, which is downloading some artifacts from the Babel repository with Tycho.

The Maven build fails randomly with errors like the one below, on one of the following artifacts (the list is not complete):
- org.eclipse.core.contenttype.nl_de
- org.eclipse.core.databinding.beans.nl_de
- http://www.eclipse.org/downloads/download.php?file=/technology/babel/update-site/R0.10.1/helios/&format=xml&countryCode=gb&timeZone=2&format=xml

During the analysis, I excluded the corporate proxies (the build works in the same manner in the public network), and discovered with Wireshark, that I am receiving TCP RST at some moment from the update site.
At the same time, the build is working for my colleague.
The Maven version is 3.0.5, tried different Tycho versions (0.15.0 - 0.23.0), tried different targets (Kepler, Helios...).

I discovered similar issue, which seems to be still open (https://www.eclipse.org/forums/index.php/t/1071313/).
What could be the reason, for which the update site drops the connections?

The stack trace from Maven:

[INFO] Fetching org.eclipse.core.contenttype.nl_de_3.6.0.v20121120125106.jar (2.58kB of 2.58kB at 0B/s) from http://archive.eclipse.org/technology/babel/update-site/R0.10.1/helios/plugins/
[INFO] Downloading org.eclipse.core.databinding.beans.nl_de
[ERROR] Internal error: java.lang.NullPointerException -> [Help 1]
org.apache.maven.InternalErrorException: Internal error: java.lang.NullPointerException
        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:168)
        at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
        at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
        at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:606)
        at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
        at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
        at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
        at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
Caused by: java.lang.NullPointerException
        at org.eclipse.equinox.internal.p2.artifact.repository.simple.SimpleArtifactRepository.downloadArtifact(SimpleArtifactRepository.java:665)
        at org.eclipse.equinox.internal.p2.artifact.repository.simple.SimpleArtifactRepository.downloadArtifact(SimpleArtifactRepository.java:590)
        at org.eclipse.equinox.internal.p2.artifact.repository.simple.SimpleArtifactRepository.getArtifact(SimpleArtifactRepository.java:723)
        at org.eclipse.equinox.internal.p2.artifact.repository.MirrorRequest.getArtifact(MirrorRequest.java:287)
        at org.eclipse.equinox.internal.p2.artifact.repository.MirrorRequest.transferSingle(MirrorRequest.java:267)
        at org.eclipse.equinox.internal.p2.artifact.repository.MirrorRequest.transfer(MirrorRequest.java:208)
        at org.eclipse.tycho.p2.maven.repository.MavenMirrorRequest.perform(MavenMirrorRequest.java:100)
        at org.eclipse.equinox.internal.p2.artifact.repository.simple.SimpleArtifactRepository.getArtifact(SimpleArtifactRepository.java:707)
        at org.eclipse.equinox.internal.p2.artifact.repository.simple.SimpleArtifactRepository.getArtifacts(SimpleArtifactRepository.java:778)
        at org.eclipse.equinox.internal.p2.artifact.repository.CompositeArtifactRepository.getArtifacts(CompositeArtifactRepository.java:341)
        at org.eclipse.tycho.p2.target.P2ArtifactDownloadTool.downloadArtifactsToLocalMavenRepository(P2ArtifactDownloadTool.java:55)
        at org.eclipse.tycho.p2.target.TargetPlatformImpl.downloadArtifacts(TargetPlatformImpl.java:199)
        at org.eclipse.tycho.p2.impl.resolver.P2ResolverImpl.resolveProject(P2ResolverImpl.java:124)
        at org.eclipse.tycho.p2.impl.resolver.P2ResolverImpl.resolveProject(P2ResolverImpl.java:76)
        at org.eclipse.tycho.p2.resolver.P2TargetPlatformResolver.doResolvePlatform(P2TargetPlatformResolver.java:448)
        at org.eclipse.tycho.p2.resolver.P2TargetPlatformResolver.resolveDependencies(P2TargetPlatformResolver.java:425)
        at org.eclipse.tycho.core.resolver.DefaultTychoDependencyResolver.resolveProject(DefaultTychoDependencyResolver.java:98)
        at org.eclipse.tycho.core.maven.TychoMavenLifecycleParticipant.afterProjectsRead(TychoMavenLifecycleParticipant.java:64)
        at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:274)
        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
        ... 11 more
[ERROR]
Re: Babel update site resetting the TCP connection when downloading the artifacts [message #1726225 is a reply to message #1725918] Thu, 10 March 2016 15:41 Go to previous message
Dmitriy Grintshak is currently offline Dmitriy GrintshakFriend
Messages: 4
Registered: March 2016
Junior Member
After further investigation, I found, that the update site is causing the issue. I replied to the thread https://www.eclipse.org/forums/index.php/t/1071313/, and closing this one.

[Updated on: Thu, 10 March 2016 15:41]

Report message to a moderator

Previous Topic:Signed Language Packs
Next Topic:Update site / downloads down
Goto Forum:
  


Current Time: Tue May 22 21:52:09 GMT 2018

Powered by FUDForum. Page generated in 0.02344 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top