Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Are the xmi:id values used anywhere?
Are the xmi:id values used anywhere? [message #1725686] Sun, 06 March 2016 20:27 Go to next message
Erdal Karaca is currently offline Erdal KaracaFriend
Messages: 853
Registered: July 2009
Senior Member
When having a look at the e4xmi files in a text/xml editor, all model elements have the XMI ID set. Are the IDs used anywhere in the E4 codebase? If I would omit xmi:id values would the workbench model still be properly processed by E4?
Re: Are the xmi:id values used anywhere? [message #1725687 is a reply to message #1725686] Sun, 06 March 2016 20:32 Go to previous message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 6566
Registered: July 2009
Senior Member
The ids are used for cross-references in the XMI-Code so as long as you
are not using cross-refs in your XMI you are safe, but once the model is
loaded and persisted all elements will have an XMI-ID.

Tom

On 06.03.16 15:27, Erdal Karaca wrote:
> When having a look at the e4xmi files in a text/xml editor, all model
> elements have the XMI ID set. Are the IDs used anywhere in the E4
> codebase? If I would omit xmi:id values would the workbench model still
> be properly processed by E4?
>
Previous Topic:Unable to move junit view windows
Next Topic:Why does this error show up?
Goto Forum:
  


Current Time: Thu Sep 24 09:44:02 GMT 2020

Powered by FUDForum. Page generated in 0.01532 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top