Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Sirius » Edition Table Line Highlight not working - 3.1.0
Edition Table Line Highlight not working - 3.1.0 [message #1725121] Tue, 01 March 2016 01:34 Go to next message
Brandon Lewis is currently offline Brandon LewisFriend
Messages: 104
Registered: May 2012
Senior Member
I'm using Sirius 3.1.0 on Luna 4.4.2 on Mac OS 10.10.5.

In my example app, the highlight of the line of the edition table is not working. It's actually making all the text white, and then not highlighting the rows - resulting in it making almost all of the row/line be invisible.

I did a search yesterday and thought I saw that 3.1.0 was supposed to fix this. Can't find the post anymore. I upgraded from 3.0.0 to 3.1.0, cleared my runtime configuration, and the selected line highlight is not working.

Do I need to do something else?
Re: Edition Table Line Highlight not working - 3.1.0 [message #1725928 is a reply to message #1725121] Tue, 08 March 2016 14:39 Go to previous messageGo to next message
Pierre-Charles David is currently offline Pierre-Charles DavidFriend
Messages: 451
Registered: July 2009
Senior Member
Le 01/03/2016 02:34, Brandon Lewis a écrit :
> I'm using Sirius 3.1.0 on Luna 4.4.2 on Mac OS 10.10.5.
>
> In my example app, the highlight of the line of the edition table is not
> working. It's actually making all the text white, and then not
> highlighting the rows - resulting in it making almost all of the
> row/line be invisible.
>
> I did a search yesterday and thought I saw that 3.1.0 was supposed to
> fix this. Can't find the post anymore.

Maybe "Bug 460810 - Selected DTreeItem is not visible on Mac OS X" was
the one you found? It is indeed fixed in 3.1.0, but it only concerns
tree representations, not tables.

> I upgraded from 3.0.0 to 3.1.0,
> cleared my runtime configuration, and the selected line highlight is not
> working.

The bug is still present for tables.

> Do I need to do something else?

Can you open a bugzilla issue about this? Only one of us commiters is on
Mac, so I don't know if/when we'll be able to look into it. If we can
get around to fix it before Sirius 4.0, it's the kind of things we'll
backport on a maintenance 3.1.x version.

Regards,
Pierre-Charles

--
Pierre-Charles David - Obeo

Need training or professional services for Sirius?
http://www.obeodesigner.com/sirius


Pierre-Charles David - Obeo

Need training or professional services for Sirius?
http://www.obeodesigner.com/sirius
Re: Edition Table Line Highlight not working - 3.1.0 [message #1792578 is a reply to message #1725928] Thu, 19 July 2018 16:10 Go to previous message
Maged Elaasar is currently offline Maged ElaasarFriend
Messages: 21
Registered: September 2013
Junior Member
We also use Sirius's table representation on Mac and we like it, except for this bug (https://bugs.eclipse.org/bugs/show_bug.cgi?id=472052). Do you guys have a plan to address it in the near future? It is detracting from an otherwise awesome feature.

Thanks,
Maged
Previous Topic:Using Sirius Test plugins
Next Topic:Get Value of the TextArea
Goto Forum:
  


Current Time: Sun Nov 18 10:17:17 GMT 2018

Powered by FUDForum. Page generated in 0.02353 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top